Loading ...
Sorry, an error occurred while loading the content.
 

Re: Mission: Speed up MacVim

Expand Messages
  • Jjgod Jiang
    Hi Alex, ... I can confirm this. After some debugging, it turned out to be related to the font size and antialias settings. Consider it as a limitation of the
    Message 1 of 16 , Oct 15, 2008
      Hi Alex,

      On Wed, Oct 15, 2008 at 6:23 PM, Alex Suraci <i.am@...> wrote:
      > I have antialiasing turned off intentionally.
      >
      > The ugliness I'm talking about is the spacing between characters (see
      > the command line). As I type in the command line the spacing gets
      > weirder and weirder and the text gets shoved further to the left,
      > eventually going offscreen. You can also see that some lines of code
      > are jumbled, like the comment block for the key_regexp function.
      >
      > Un-borked screenshot: http://h4xr.org/r4wy

      I can confirm this. After some debugging, it turned out to be related
      to the font size and antialias settings. Consider it as a limitation
      of the current ATSUI renderer, I'm unable to find out a quick fix yet.
      However, I'm working on a new renderer without ATSUI dependency (which
      will also made the rendering process 64-bit clean), hopefully that will
      solve this problem (and some other quirks I observed with the ATSUI
      renderer).

      - Jiang

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.