Loading ...
Sorry, an error occurred while loading the content.

Using the option key in MacVim

Expand Messages
  • Jeremy Conlin
    I use the latex-suite in MacVim. There are several shortcuts/mappings that use the meta key. On the Mac, the meta key is the option key. In MacVim when I
    Message 1 of 21 , Oct 8, 2008
    • 0 Attachment
      I use the latex-suite in MacVim.  There are several shortcuts/mappings that use the meta key.  On the Mac, the meta key is the option key.  In MacVim when I press option and then a letter I get some symbol instead of using the map defined in latex-suite.  Is there some hidden preference I can change to use the option key as a modifier key?

      Thanks,
      Jeremy

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---

    • björn
      Hi Jeremy, ... It would be possible to make option-key presses being sent directly on to Vim which would (I think) fix the problem you are having. But...then
      Message 2 of 21 , Oct 8, 2008
      • 0 Attachment
        Hi Jeremy,

        2008/10/8 Jeremy Conlin <jeremit0@...>:
        > I use the latex-suite in MacVim. There are several shortcuts/mappings that
        > use the meta key. On the Mac, the meta key is the option key. In MacVim
        > when I press option and then a letter I get some symbol instead of using the
        > map defined in latex-suite. Is there some hidden preference I can change to
        > use the option key as a modifier key?

        It would be possible to make option-key presses being sent directly on
        to Vim which would (I think) fix the problem you are having.
        But...then it would be impossible to type characters that are only
        accessible by pressing option-key. This probably won't make a
        difference if you are programming and only accessing ASCII characters,
        but on many non-English keyboards some very essential characters are
        "hiding" behind an option-key. That is the reason why MacVim works
        the way it does now.

        I guess it would be possible to implement a setting which, when turned
        on, doesn't "interpret" option-keys so that they are passed on to Vim
        as the key pressed plus the option modifier.

        Has anybody else any comments on this? I'm not sure what the best
        solution is here.

        Thanks,
        Björn

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Jeremy Conlin
        ... In Terminal there is a check box to do just this. When selected, the option key becomes the meta key. For example option-b; when selected, this just
        Message 3 of 21 , Oct 8, 2008
        • 0 Attachment


          On Wed, Oct 8, 2008 at 4:31 PM, björn <bjorn.winckler@...> wrote:

          Hi Jeremy,

          2008/10/8 Jeremy Conlin <jeremit0@...>:
          > I use the latex-suite in MacVim.  There are several shortcuts/mappings that
          > use the meta key.  On the Mac, the meta key is the option key.  In MacVim
          > when I press option and then a letter I get some symbol instead of using the
          > map defined in latex-suite.  Is there some hidden preference I can change to
          > use the option key as a modifier key?

          It would be possible to make option-key presses being sent directly on
          to Vim which would (I think) fix the problem you are having.
          But...then it would be impossible to type characters that are only
          accessible by pressing option-key.  This probably won't make a
          difference if you are programming and only accessing ASCII characters,
          but on many non-English keyboards some very essential characters are
          "hiding" behind an option-key.  That is the reason why MacVim works
          the way it does now.

          I guess it would be possible to implement a setting which, when turned
          on, doesn't "interpret" option-keys so that they are passed on to Vim
          as the key pressed plus the option modifier.

          In Terminal there is a check box to do just this.  When selected, the option key becomes the meta key.  For example option-b; when selected, this just allows one to move one word backward on the command line.  When not selected, pushing option-b just puts a little integral symbol.  

          I recognize there are many people who need to use not ASCII characters.  I almost never do and would like the option of turning it off.  I am also curious to know anybody else's opinion.

          Thanks,
          Jeremy



          Has anybody else any comments on this?  I'm not sure what the best
          solution is here.

          Thanks,
          Björn




          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---

        • ntiozymandias
          ... As Jeremy Conlin mentioned, a checkbox is probably the ideal way to toggle the interpretation of the option key. For the benefit of non- (US) English
          Message 4 of 21 , Oct 8, 2008
          • 0 Attachment
            > It would be possible to make option-key presses being sent directly on
            > to Vim which would (I think) fix the problem you are having.
            > But...then it would be impossible to type characters that are only
            > accessible by pressing option-key.  This probably won't make a
            > difference if you are programming and only accessing ASCII characters,
            > but on many non-English keyboards some very essential characters are
            > "hiding" behind an option-key.  That is the reason why MacVim works
            > the way it does now.

            As Jeremy Conlin mentioned, a checkbox is probably the ideal way to
            toggle the interpretation of the option key. For the benefit of non-
            (US) English users, you might simply include a warning in the
            preferences window that they should either remap the appropriate keys,
            or switch to a US layout.

            If users find that enabling the option makes Vim unusable, they can
            always turn it off again.


            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • ntiozymandias
            ... As Jeremy Conlin mentioned, a checkbox is probably the ideal way to toggle the interpretation of the option key. For the benefit of non- (US) English
            Message 5 of 21 , Oct 8, 2008
            • 0 Attachment
              > It would be possible to make option-key presses being sent directly on
              > to Vim which would (I think) fix the problem you are having.
              > But...then it would be impossible to type characters that are only
              > accessible by pressing option-key.  This probably won't make a
              > difference if you are programming and only accessing ASCII characters,
              > but on many non-English keyboards some very essential characters are
              > "hiding" behind an option-key.  That is the reason why MacVim works
              > the way it does now.

              As Jeremy Conlin mentioned, a checkbox is probably the ideal way to
              toggle the interpretation of the option key. For the benefit of non-
              (US) English users, you might simply include a warning in the
              preferences window that they should either remap the appropriate keys,
              or switch to a US layout.

              If users find that enabling the option makes Vim unusable, they can
              always turn it off again.


              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Ben Schmidt
              ... Yes. I think that is what should be done. X11 and Terminal both have settings for this, I believe, and many Vimmers will use Vim keymaps rather than the
              Message 6 of 21 , Oct 8, 2008
              • 0 Attachment
                > I guess it would be possible to implement a setting which, when turned
                > on, doesn't "interpret" option-keys so that they are passed on to Vim
                > as the key pressed plus the option modifier.

                Yes. I think that is what should be done. X11 and Terminal both have
                settings for this, I believe, and many Vimmers will use Vim keymaps
                rather than the Option key for insertion of special characters. That
                said, a nice thing about MacVim is being able to type characters with
                Option as you can in the rest of the OS. I think there's tremendous
                value in both approaches and this warrants an option, as Apple also
                seems to think it does.

                I think a Vim option would be better than a MacVim preference, if you
                know what I mean. Then different instances can have different settings,
                so if you're using Latex Suite or whatever, you can use the Meta maps,
                but if you're writing an email, you can type international characters
                and symbols.

                Ben.




                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • Steven Michalske
                I like the idea of double tapping toggles the mode you choose. Example in standard os x mode a double tap of option would turn off the special keys and pass
                Message 7 of 21 , Oct 8, 2008
                • 0 Attachment
                  I like the idea of double tapping toggles the mode you choose.

                  Example in standard os x mode a double tap of option would turn off
                  the special keys and pass the meta key, and vice versa

                  thus allowing the special chars and passing the meta with out having
                  to click the checkbox.

                  quicksilver allows a double tap of command to toggle its entry
                  window, so the double tap could cause the toggle.

                  Steve


                  On Oct 8, 2008, at 3:27 PM, Ben Schmidt wrote:

                  >
                  >> I guess it would be possible to implement a setting which, when
                  >> turned
                  >> on, doesn't "interpret" option-keys so that they are passed on to Vim
                  >> as the key pressed plus the option modifier.
                  >
                  > Yes. I think that is what should be done. X11 and Terminal both have
                  > settings for this, I believe, and many Vimmers will use Vim keymaps
                  > rather than the Option key for insertion of special characters. That
                  > said, a nice thing about MacVim is being able to type characters with
                  > Option as you can in the rest of the OS. I think there's tremendous
                  > value in both approaches and this warrants an option, as Apple also
                  > seems to think it does.
                  >
                  > I think a Vim option would be better than a MacVim preference, if you
                  > know what I mean. Then different instances can have different
                  > settings,
                  > so if you're using Latex Suite or whatever, you can use the Meta maps,
                  > but if you're writing an email, you can type international characters
                  > and symbols.
                  >
                  > Ben.
                  >
                  >
                  >
                  >
                  > >


                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_mac" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • ntiozymandias
                  ... Well in that case, why not interpret a modifier tap as a pseudo- keypress of some kind ( , , etc.) and allow the user to map it to
                  Message 8 of 21 , Oct 8, 2008
                  • 0 Attachment
                    On Oct 8, 8:41 pm, Steven Michalske <smichal...@...> wrote:
                    > I like the idea of double tapping toggles the mode you choose.

                    Well in that case, why not interpret a modifier tap as a pseudo-
                    keypress of some kind (<T-Command>, <T-Option>, etc.) and allow the
                    user to map it to whatever they want? This could, for example,
                    generalize the idea someone had of mapping caps lock to escape, or
                    emulate TextMate's use of option for toggling between character-wise
                    and rectangular selection (v and <C-v> in Vim, respectively).
                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_mac" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  • Ben Schmidt
                    ... As long as it could be turned off, I wouldn t mind that. I often tap keys for no apparent reason (OK, so I play drums...) and that would really annoy me,
                    Message 9 of 21 , Oct 8, 2008
                    • 0 Attachment
                      Steven Michalske wrote:
                      > I like the idea of double tapping toggles the mode you choose.

                      As long as it could be turned off, I wouldn't mind that. I often tap
                      keys for no apparent reason (OK, so I play drums...) and that would
                      really annoy me, 'cause I'd keep changing the mode when I didn't want
                      to. I also would probably have difficulty knowing which mode I was in
                      without some pretty conspicuous indicator. A changeable but static
                      option would suit my workflow better (or, to be honest, just the current
                      MacVim behaviour--with command, control and shift, I think I have enough
                      keys I can map, and can just map some unused key to a plugin's key if I
                      need to; I just keep removing bindings from the MacVim menus that I
                      don't use...).

                      Smiles,

                      Ben.




                      --~--~---------~--~----~------------~-------~--~----~
                      You received this message from the "vim_mac" maillist.
                      For more information, visit http://www.vim.org/maillist.php
                      -~----------~----~----~----~------~----~------~--~---
                    • björn
                      Thanks for the all the feedback so far. To begin with I will implement a (boolean) Vim option to use option as meta (like in Terminal.app), which I d call
                      Message 10 of 21 , Oct 9, 2008
                      • 0 Attachment
                        Thanks for the all the feedback so far.

                        To begin with I will implement a (boolean) Vim option to "use option
                        as meta" (like in Terminal.app), which I'd call 'macmeta' (or give me
                        a better suggestion -- it should start with "mac"). This way it would
                        be possible to set it depending on file type (like Ben outlined) and
                        to bind it to some key-combo (e.g. ":map <D-d> :set invmacmeta<CR>")
                        in case you want to quickly switch while typing.

                        The idea to tap a key to turn this option on/off would require more
                        work and doesn't seem to improve the above solution, so I'll take that
                        into consideration for some other time. Generalizing further with
                        <T-Cmd> etc. seems like overkill and somewhat out of place.

                        Björn

                        --~--~---------~--~----~------------~-------~--~----~
                        You received this message from the "vim_mac" maillist.
                        For more information, visit http://www.vim.org/maillist.php
                        -~----------~----~----~----~------~----~------~--~---
                      • Jeremy Conlin
                        ... This sounds like a good way to handle this. Let me know when this gets implemented as I m excited to try it out. I am currently using Snapshot 36 and
                        Message 11 of 21 , Oct 9, 2008
                        • 0 Attachment


                          On Thu, Oct 9, 2008 at 10:28 AM, björn <bjorn.winckler@...> wrote:

                          Thanks for the all the feedback so far.

                          To begin with I will implement a (boolean) Vim option to "use option
                          as meta" (like in Terminal.app), which I'd call 'macmeta' (or give me
                          a better suggestion -- it should start with "mac").  This way it would
                          be possible to set it depending on file type (like Ben outlined) and
                          to bind it to some key-combo (e.g. ":map <D-d> :set invmacmeta<CR>")
                          in case you want to quickly switch while typing.

                          The idea to tap a key to turn this option on/off would require more
                          work and doesn't seem to improve the above solution, so I'll take that
                          into consideration for some other time.  Generalizing further with
                          <T-Cmd> etc. seems like overkill and somewhat out of place.

                          This sounds like a good way to handle this.  Let me know when this gets implemented as I'm excited to try it out.  I am currently using Snapshot 36 and have never compiled MacVim on my own.  

                          Jeremy



                          Björn




                          --~--~---------~--~----~------------~-------~--~----~
                          You received this message from the "vim_mac" maillist.
                          For more information, visit http://www.vim.org/maillist.php
                          -~----------~----~----~----~------~----~------~--~---

                        • björn
                          I ve pushed a patch which adds support for the macmeta option. This option is buffer local so it is possible to have it automatically set for some filetypes
                          Message 12 of 21 , Oct 12, 2008
                          • 0 Attachment
                            I've pushed a patch which adds support for the 'macmeta' option. This
                            option is buffer local so it is possible to have it automatically set
                            for some filetypes but not for others while editing different types of
                            files. If you want to be able to switch this option on/off add a
                            mapping like:

                            :imap <D-j> <C-O>:set invmmta<CR>
                            :map <D-j> :set invmmta<CR>

                            I hope this implementation will cover all the different use-cases
                            people may have.

                            Björn

                            --~--~---------~--~----~------------~-------~--~----~
                            You received this message from the "vim_mac" maillist.
                            For more information, visit http://www.vim.org/maillist.php
                            -~----------~----~----~----~------~----~------~--~---
                          • Jeremy Conlin
                            ... Thanks for implementing this feature. I downloaded the latest git version and compiled. However I couldn t figure out how to use this. I can do ...
                            Message 13 of 21 , Oct 13, 2008
                            • 0 Attachment


                              On Sun, Oct 12, 2008 at 8:17 AM, björn <bjorn.winckler@...> wrote:

                              I've pushed a patch which adds support for the 'macmeta' option.  This
                              option is buffer local so it is possible to have it automatically set
                              for some filetypes but not for others while editing different types of
                              files.  If you want to be able to switch this option on/off add a
                              mapping like:

                              :imap <D-j> <C-O>:set invmmta<CR>
                              :map <D-j> :set invmmta<CR>

                              I hope this implementation will cover all the different use-cases
                              people may have.

                              Björn

                              --~--~--

                              Thanks for implementing this feature.  I downloaded the latest git version and compiled.  However I couldn't figure out how to use this.  I can do

                              :set invmmta

                              manually, but I haven't found no changes.   

                              (Disclaimer: I usually wait until the snapshot is released rather than compile the latest version myself.)  My MacVim seems to be rather bare bones as it doesn't have any colorscheme files or help files.  More than likely this is my problem and not a problem with MacVim.  Perhaps someone else can try this and see if it works.

                              Thanks,
                              Jeremy


                              --~--~---------~--~----~------------~-------~--~----~
                              You received this message from the "vim_mac" maillist.
                              For more information, visit http://www.vim.org/maillist.php
                              -~----------~----~----~----~------~----~------~--~---

                            • björn
                              ... Did you follow the instructions? You can find them here: http://code.google.com/p/macvim/wiki/Building ... It does sound like something went wrong while
                              Message 14 of 21 , Oct 13, 2008
                              • 0 Attachment
                                2008/10/13 Jeremy Conlin <jeremit0@...>:
                                >
                                > Thanks for implementing this feature. I downloaded the latest git version
                                > and compiled. However I couldn't figure out how to use this. I can do
                                > :set invmmta
                                > manually, but I haven't found no changes.

                                Did you follow the instructions? You can find them here:

                                http://code.google.com/p/macvim/wiki/Building

                                > (Disclaimer: I usually wait until the snapshot is released rather than
                                > compile the latest version myself.) My MacVim seems to be rather bare bones
                                > as it doesn't have any colorscheme files or help files. More than likely
                                > this is my problem and not a problem with MacVim. Perhaps someone else can
                                > try this and see if it works.

                                It does sound like something went wrong while building. Follow the
                                instructions above to the letter -- if you still can't get it to work
                                let me know.

                                Björn

                                --~--~---------~--~----~------------~-------~--~----~
                                You received this message from the "vim_mac" maillist.
                                For more information, visit http://www.vim.org/maillist.php
                                -~----------~----~----~----~------~----~------~--~---
                              • Jeremy Conlin
                                ... Those were the instructions I used when I built MacVim. It appears that it may open two instances of MacVim, neither of them are very useful and one of
                                Message 15 of 21 , Oct 13, 2008
                                • 0 Attachment


                                  On Mon, Oct 13, 2008 at 12:12 PM, björn <bjorn.winckler@...> wrote:

                                  2008/10/13 Jeremy Conlin <jeremit0@...>:
                                  >
                                  > Thanks for implementing this feature.  I downloaded the latest git version
                                  > and compiled.  However I couldn't figure out how to use this.  I can do
                                  > :set invmmta
                                  > manually, but I haven't found no changes.

                                  Did you follow the instructions?  You can find them here:

                                  http://code.google.com/p/macvim/wiki/Building

                                  > (Disclaimer: I usually wait until the snapshot is released rather than
                                  > compile the latest version myself.)  My MacVim seems to be rather bare bones
                                  > as it doesn't have any colorscheme files or help files.  More than likely
                                  > this is my problem and not a problem with MacVim.  Perhaps someone else can
                                  > try this and see if it works.

                                  It does sound like something went wrong while building.  Follow the
                                  instructions above to the letter -- if you still can't get it to work
                                  let me know.


                                  Those were the instructions I used when I built MacVim.   It appears that it may open two instances of MacVim, neither of them are very useful and one of them doesn't have any menus.

                                  Sorry for the newbie problems.

                                  Jeremy


                                  --~--~---------~--~----~------------~-------~--~----~
                                  You received this message from the "vim_mac" maillist.
                                  For more information, visit http://www.vim.org/maillist.php
                                  -~----------~----~----~----~------~----~------~--~---

                                • björn
                                  ... Hmmm...have you tried cleaning the project and rebuilding? In the src/ folder type make clean , followed by make . Then go to the src/MacVim folder
                                  Message 16 of 21 , Oct 13, 2008
                                  • 0 Attachment
                                    2008/10/13 Jeremy Conlin <jeremit0@...>:
                                    >
                                    > Those were the instructions I used when I built MacVim. It appears that it
                                    > may open two instances of MacVim, neither of them are very useful and one of
                                    > them doesn't have any menus.

                                    Hmmm...have you tried cleaning the project and rebuilding? In the
                                    "src/" folder type "make clean", followed by "make". Then go to the
                                    "src/MacVim" folder and type "xcodebuild clean" followed by
                                    "xcodebuild".

                                    If that still doesn't do it and you just want a binary to try out the
                                    'macmeta' option I can upload one to RapidShare for you (I just need
                                    to know if you have PPC or Intel) -- although that would be a binary
                                    without all the bells and whistles (no ruby, python, etc...).

                                    Björn

                                    --~--~---------~--~----~------------~-------~--~----~
                                    You received this message from the "vim_mac" maillist.
                                    For more information, visit http://www.vim.org/maillist.php
                                    -~----------~----~----~----~------~----~------~--~---
                                  • Jeremy Conlin
                                    ... I did: xcodebuild clean cd .. make clean make cd MacVim xcodebuild but still have the same problem. I m guessing my problem has something to do with the
                                    Message 17 of 21 , Oct 13, 2008
                                    • 0 Attachment


                                      On Mon, Oct 13, 2008 at 2:42 PM, björn <bjorn.winckler@...> wrote:

                                      2008/10/13 Jeremy Conlin <jeremit0@...>:
                                      >
                                      > Those were the instructions I used when I built MacVim.   It appears that it
                                      > may open two instances of MacVim, neither of them are very useful and one of
                                      > them doesn't have any menus.

                                      Hmmm...have you tried cleaning the project and rebuilding?  In the
                                      "src/" folder type "make clean", followed by "make".  Then go to the
                                      "src/MacVim" folder and type "xcodebuild clean" followed by
                                      "xcodebuild".

                                      I did:

                                      xcodebuild clean
                                      cd ..
                                      make clean
                                      make
                                      cd MacVim
                                      xcodebuild

                                      but still have the same problem.  I'm guessing my problem has something to do with the existence of another version of MacVim in /Applications/.  See screen shot attachment to see the error message I got when trying :help  I tried changing the CFBundleIdentifier as instructed on the wiki, but that didn't seem to help.  



                                      If that still doesn't do it and you just want a binary to try out the
                                      'macmeta' option I can upload one to RapidShare for you (I just need
                                      to know if you have PPC or Intel) -- although that would be a binary
                                      without all the bells and whistles (no ruby, python, etc...).

                                      This might be the best option.  I'm willing to try out the new patch, but clearly don't know how to build it.  I can wait until the next snapshot to have all the bells and whistles.

                                      Thanks,
                                      Jeremy 

                                      --~--~---------~--~----~------------~-------~--~----~
                                      You received this message from the "vim_mac" maillist.
                                      For more information, visit http://www.vim.org/maillist.php
                                      -~----------~----~----~----~------~----~------~--~---

                                    • björn
                                      ... Hmmm...judging from the screenshot you seem to have passed the wrong flags to the configure script. At least, it seems to be looking for the resources
                                      Message 18 of 21 , Oct 13, 2008
                                      • 0 Attachment
                                        2008/10/13 Jeremy Conlin <jeremit0@...>:
                                        >
                                        > I did:
                                        > xcodebuild clean
                                        > cd ..
                                        > make clean
                                        > make
                                        > cd MacVim
                                        > xcodebuild
                                        > but still have the same problem. I'm guessing my problem has something to
                                        > do with the existence of another version of MacVim in /Applications/. See
                                        > screen shot attachment to see the error message I got when trying :help I
                                        > tried changing the CFBundleIdentifier as instructed on the wiki, but that
                                        > didn't seem to help.

                                        Hmmm...judging from the screenshot you seem to have passed the wrong
                                        flags to the "configure" script. At least, it seems to be looking for
                                        the resources folder inside the "/Applications/Vim.app" bundle but
                                        that's the name the old Carbon port uses -- it should be
                                        "/Applications/MacVim.app" for MacVim. Try the following in the
                                        "src/" folder:

                                        ./configure --enable-gui=macvim
                                        make clean
                                        make

                                        (copy and paste one line at a time and hit enter). The first line is
                                        crucial! Then go

                                        cd MacVim
                                        xcodebuild

                                        >> If that still doesn't do it and you just want a binary to try out the
                                        >> 'macmeta' option I can upload one to RapidShare for you (I just need
                                        >> to know if you have PPC or Intel) -- although that would be a binary
                                        >> without all the bells and whistles (no ruby, python, etc...).
                                        >
                                        > This might be the best option. I'm willing to try out the new patch, but
                                        > clearly don't know how to build it. I can wait until the next snapshot to
                                        > have all the bells and whistles.

                                        Ok, but you forgot to tell me if you have a PPC or Intel though... ;-)

                                        Björn

                                        --~--~---------~--~----~------------~-------~--~----~
                                        You received this message from the "vim_mac" maillist.
                                        For more information, visit http://www.vim.org/maillist.php
                                        -~----------~----~----~----~------~----~------~--~---
                                      • Jeremy Conlin
                                        ... I must have mistyped something, but now it seems to work on my *Intel* :P MacBook Pro. I m not exactly sure if it did what I expected. As I explained in a
                                        Message 19 of 21 , Oct 13, 2008
                                        • 0 Attachment


                                          On Mon, Oct 13, 2008 at 3:20 PM, björn <bjorn.winckler@...> wrote:

                                          2008/10/13 Jeremy Conlin <jeremit0@...>:
                                          >
                                          > I did:
                                          > xcodebuild clean
                                          > cd ..
                                          > make clean
                                          > make
                                          > cd MacVim
                                          > xcodebuild
                                          > but still have the same problem.  I'm guessing my problem has something to
                                          > do with the existence of another version of MacVim in /Applications/.  See
                                          > screen shot attachment to see the error message I got when trying :help  I
                                          > tried changing the CFBundleIdentifier as instructed on the wiki, but that
                                          > didn't seem to help.

                                          Hmmm...judging from the screenshot you seem to have passed the wrong
                                          flags to the "configure" script.  At least, it seems to be looking for
                                          the resources folder inside the "/Applications/Vim.app" bundle but
                                          that's the name the old Carbon port uses -- it should be
                                          "/Applications/MacVim.app" for MacVim.  Try the following in the
                                          "src/" folder:

                                          ./configure --enable-gui=macvim
                                          make clean
                                          make

                                          (copy and paste one line at a time and hit enter).  The first line is
                                          crucial!  Then go

                                          cd MacVim
                                          xcodebuild

                                          >> If that still doesn't do it and you just want a binary to try out the
                                          >> 'macmeta' option I can upload one to RapidShare for you (I just need
                                          >> to know if you have PPC or Intel) -- although that would be a binary
                                          >> without all the bells and whistles (no ruby, python, etc...).
                                          >
                                          > This might be the best option.  I'm willing to try out the new patch, but
                                          > clearly don't know how to build it.  I can wait until the next snapshot to
                                          > have all the bells and whistles.

                                          Ok, but you forgot to tell me if you have a PPC or Intel though... ;-)

                                          I must have mistyped something, but now it seems to work on my *Intel* :P MacBook Pro.  

                                          I'm not exactly sure if it did what I expected.  As I explained in a previous email, my intention for this was to use some of the built-in maps provided with latex-suite.  I haven't yet gotten these to work, but it's not necessarily the fault of MacVim.  I have attached a screen shot of the new MacVim.  When macmeta is on and I press option-b I get the "a" with a hat; with macmeta off (default) I get the little integral symbol which is what I got before.  I'm not familiar enough with Unicode and everything else that is involved here to know if an a with a hat is what should show up.  Does anyone else know?

                                          Thanks,
                                          Jeremy

                                          --~--~---------~--~----~------------~-------~--~----~
                                          You received this message from the "vim_mac" maillist.
                                          For more information, visit http://www.vim.org/maillist.php
                                          -~----------~----~----~----~------~----~------~--~---

                                        • björn
                                          ... Good! :-) ... It seems to me that you don t have bound to anything. Pressing Alt-key will still insert text unless you bind the key to something.
                                          Message 20 of 21 , Oct 13, 2008
                                          • 0 Attachment
                                            2008/10/13 Jeremy Conlin <jeremit0@...>:
                                            >
                                            > I must have mistyped something, but now it seems to work on my *Intel* :P
                                            > MacBook Pro.

                                            Good! :-)

                                            > I'm not exactly sure if it did what I expected. As I explained in a
                                            > previous email, my intention for this was to use some of the built-in maps
                                            > provided with latex-suite. I haven't yet gotten these to work, but it's not
                                            > necessarily the fault of MacVim. I have attached a screen shot of the new
                                            > MacVim. When macmeta is on and I press option-b I get the "a" with a hat;
                                            > with macmeta off (default) I get the little integral symbol which is what I
                                            > got before. I'm not familiar enough with Unicode and everything else that
                                            > is involved here to know if an a with a hat is what should show up. Does
                                            > anyone else know?

                                            It seems to me that you don't have <M-a> bound to anything. Pressing
                                            Alt-key will still insert text unless you bind the key to something.
                                            All the patch does is that it allows you to bind to e.g. <M-a>. Try

                                            :imap <M-a> M-a

                                            Then enter insert mode and hit alt-a, exit insert mode and toggle
                                            'macmeta' (:set invmmta), enter insert mode and hit alt-a again and
                                            you'll see what I am talking about.

                                            In your screenshot you are editing a file without the ".tex" extension
                                            so the latex suite maps won't have been loaded. Open a .tex file and
                                            try the alt-keys that you want and see how that goes.

                                            Björn

                                            --~--~---------~--~----~------------~-------~--~----~
                                            You received this message from the "vim_mac" maillist.
                                            For more information, visit http://www.vim.org/maillist.php
                                            -~----------~----~----~----~------~----~------~--~---
                                          • Jeremy Conlin
                                            ... You re right, the file I was editing was not a tex file. It was a poor example. Now that I try it again (on a tex file) it is working as expected. Thanks
                                            Message 21 of 21 , Oct 13, 2008
                                            • 0 Attachment


                                              On Mon, Oct 13, 2008 at 4:12 PM, björn <bjorn.winckler@...> wrote:

                                              2008/10/13 Jeremy Conlin <jeremit0@...>:
                                              >
                                              > I must have mistyped something, but now it seems to work on my *Intel* :P
                                              > MacBook Pro.

                                              Good! :-)

                                              > I'm not exactly sure if it did what I expected.  As I explained in a
                                              > previous email, my intention for this was to use some of the built-in maps
                                              > provided with latex-suite.  I haven't yet gotten these to work, but it's not
                                              > necessarily the fault of MacVim.  I have attached a screen shot of the new
                                              > MacVim.  When macmeta is on and I press option-b I get the "a" with a hat;
                                              > with macmeta off (default) I get the little integral symbol which is what I
                                              > got before.  I'm not familiar enough with Unicode and everything else that
                                              > is involved here to know if an a with a hat is what should show up.  Does
                                              > anyone else know?

                                              It seems to me that you don't have <M-a> bound to anything.  Pressing
                                              Alt-key will still insert text unless you bind the key to something.
                                              All the patch does is that it allows you to bind to e.g. <M-a>.  Try

                                              :imap <M-a> M-a

                                              Then enter insert mode and hit alt-a, exit insert mode and toggle
                                              'macmeta' (:set invmmta), enter insert mode and hit alt-a again and
                                              you'll see what I am talking about.

                                              In your screenshot you are editing a file without the ".tex" extension
                                              so the latex suite maps won't have been loaded.  Open a .tex file and
                                              try the alt-keys that you want and see how that goes.

                                              You're right, the file I was editing was not a tex file.  It was a poor example.  Now that I try it again (on a tex file) it is working as expected.   Thanks a lot Björn for the quick patch and for walking me through all my mistakes.

                                              Jeremy 

                                              --~--~---------~--~----~------------~-------~--~----~
                                              You received this message from the "vim_mac" maillist.
                                              For more information, visit http://www.vim.org/maillist.php
                                              -~----------~----~----~----~------~----~------~--~---

                                            Your message has been successfully submitted and would be delivered to recipients shortly.