Loading ...
Sorry, an error occurred while loading the content.

Re: [PATCH] Don't drop characters while typing

Expand Messages
  • Steve Huff
    ... seems to address the issue for me; thanks! if anybody would like a patched PPC build (with a bunch of extra Vim features turned on), you can grab it from:
    Message 1 of 6 , Oct 2, 2008
    • 0 Attachment
      On Oct 1, 2008, at 5:57 PM, björn wrote:

      > I've put together a tentative patch to fix the problem with snap 35
      > dropping characters. Can those of you experiencing problems please
      > test the patch and confirm that it fixes this problem? As far as I
      > can tell it does, but I have no good test case for this particular bug
      > so I'm not 100% sure this patch fixes it.
      >
      > If I get some confirmation that it works, I'll polish it a bit and
      > push it.

      seems to address the issue for me; thanks!

      if anybody would like a patched PPC build (with a bunch of extra Vim
      features turned on), you can grab it from:

      http://www.vecna.org/vim/MacVim_no-drop-keys_PPC.dmg

      i'll see if i can get a patched Intel build up this evening, in the
      same directory. i tried to make sure that the build process wasn't
      pulling in any third-party dependencies; if i missed any, i apologize.

      -steve
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Nico Weber
      ... Seems to fix it over here. Nico --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_mac maillist. For more
      Message 2 of 6 , Oct 2, 2008
      • 0 Attachment
        > I've put together a tentative patch to fix the problem with snap 35
        > dropping characters. Can those of you experiencing problems please
        > test the patch and confirm that it fixes this problem? As far as I
        > can tell it does, but I have no good test case for this particular bug
        > so I'm not 100% sure this patch fixes it.
        >
        > If I get some confirmation that it works, I'll polish it a bit and
        > push it.

        Seems to fix it over here.

        Nico

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.