Loading ...
Sorry, an error occurred while loading the content.

Re: [PATCH] Don't drop characters while typing

Expand Messages
  • Ted Pavlic
    I should mention that I m running OS X 10.4.11 on a 1.67 GHz PowerBook G4. My setup is pretty slow, and so I suspect that it s a good sign that it works for
    Message 1 of 6 , Oct 2, 2008
    • 0 Attachment
      I should mention that I'm running OS X 10.4.11 on a 1.67 GHz PowerBook
      G4. My setup is pretty slow, and so I suspect that it's a good sign that
      it works for me.

      Thanks --
      Ted

      Ted Pavlic wrote:
      >
      > Seems to work for me. "/Of course" is "/Of course". :) That's nice.
      >
      > Thanks --
      > Ted
      >
      > björn wrote:
      >> Hi,
      >>
      >> I've put together a tentative patch to fix the problem with snap 35
      >> dropping characters. Can those of you experiencing problems please
      >> test the patch and confirm that it fixes this problem? As far as I
      >> can tell it does, but I have no good test case for this particular bug
      >> so I'm not 100% sure this patch fixes it.
      >>
      >> If I get some confirmation that it works, I'll polish it a bit and push it.
      >>
      >> Thanks,
      >> Björn
      >>
      >

      --
      Ted Pavlic <ted@...>

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • björn
      ... Thanks for the confirmation Ted. I m about to push the patch tonight. I ll probably release a new snapshot this weekend because of this bug. Björn
      Message 2 of 6 , Oct 2, 2008
      • 0 Attachment
        2008/10/2 Ted Pavlic <ted@...>:
        >
        > I should mention that I'm running OS X 10.4.11 on a 1.67 GHz PowerBook
        > G4. My setup is pretty slow, and so I suspect that it's a good sign that
        > it works for me.

        Thanks for the confirmation Ted. I'm about to push the patch tonight.
        I'll probably release a new snapshot this weekend because of this
        bug.

        Björn

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Steve Huff
        ... seems to address the issue for me; thanks! if anybody would like a patched PPC build (with a bunch of extra Vim features turned on), you can grab it from:
        Message 3 of 6 , Oct 2, 2008
        • 0 Attachment
          On Oct 1, 2008, at 5:57 PM, björn wrote:

          > I've put together a tentative patch to fix the problem with snap 35
          > dropping characters. Can those of you experiencing problems please
          > test the patch and confirm that it fixes this problem? As far as I
          > can tell it does, but I have no good test case for this particular bug
          > so I'm not 100% sure this patch fixes it.
          >
          > If I get some confirmation that it works, I'll polish it a bit and
          > push it.

          seems to address the issue for me; thanks!

          if anybody would like a patched PPC build (with a bunch of extra Vim
          features turned on), you can grab it from:

          http://www.vecna.org/vim/MacVim_no-drop-keys_PPC.dmg

          i'll see if i can get a patched Intel build up this evening, in the
          same directory. i tried to make sure that the build process wasn't
          pulling in any third-party dependencies; if i missed any, i apologize.

          -steve
          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Nico Weber
          ... Seems to fix it over here. Nico --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_mac maillist. For more
          Message 4 of 6 , Oct 2, 2008
          • 0 Attachment
            > I've put together a tentative patch to fix the problem with snap 35
            > dropping characters. Can those of you experiencing problems please
            > test the patch and confirm that it fixes this problem? As far as I
            > can tell it does, but I have no good test case for this particular bug
            > so I'm not 100% sure this patch fixes it.
            >
            > If I get some confirmation that it works, I'll polish it a bit and
            > push it.

            Seems to fix it over here.

            Nico

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          Your message has been successfully submitted and would be delivered to recipients shortly.