Loading ...
Sorry, an error occurred while loading the content.

Re: Keyboard input ignored when mouse is moving

Expand Messages
  • björn
    ... Huh?! Can you send the crash log directly to me? It can be found under ~/Library/Logs/CrashReporter and will be called something starting with
    Message 1 of 9 , Sep 25, 2008
    • 0 Attachment
      2008/9/25 James William Pye <james.pye@...>:
      >
      > On Sep 25, 2008, at 8:37 AM, björn wrote:
      >>
      >> http://rapidshare.com/files/148306436/MacVim-080925.tbz.html
      >>
      >> Could (both of) you perhaps download that version and see if it cures
      >> the problem? (Please note that this build is Intel-only.)
      >
      > This didn't work for me. It would open up, but died when an editor
      > window was opened(cmd-n).

      Huh?! Can you send the crash log directly to me? It can be found
      under "~/Library/Logs/CrashReporter" and will be called something
      starting with "MacVim_". (Please zip it first if the file is large.)

      > I tried the latest snapshot as well, and it is certainly an
      > improvement. However, it is evident that the issue is diminished or
      > altered as opposed to completely corrected.
      >
      > To identify that the issue persists, I held a key in insert mode and
      > continually moved the mouse. Occasionally, the text flow would "lag",
      > and shortly catch up.

      Ok, it sounds more and more like a DO problem which I believe the
      latest source code version should fix (but I cannot explain why the
      snapshot would work better than the stable version). Could you
      possibly compile the latest source code version yourself and try
      (since my binary didn't work)?

      Thanks,
      Björn

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • James William Pye
      ... Process: Vim [81625] Path: /Users/jwp/Desktop/MacVim.app/Contents/MacOS/Vim Identifier: Vim Version: ??? (???) Code Type:
      Message 2 of 9 , Sep 25, 2008
      • 0 Attachment
        On Sep 25, 2008, at 11:24 AM, björn wrote:
        > Huh?! Can you send the crash log directly to me? It can be found
        > under "~/Library/Logs/CrashReporter" and will be called something
        > starting with "MacVim_". (Please zip it first if the file is large.)

        Process: Vim [81625]
        Path: /Users/jwp/Desktop/MacVim.app/Contents/MacOS/Vim
        Identifier: Vim
        Version: ??? (???)
        Code Type: X86 (Native)
        Parent Process: MacVim [81623]

        Date/Time: 2008-09-25 09:29:59.691 -0700
        OS Version: Mac OS X 10.5.5 (9F33)
        Report Version: 6

        Exception Type: EXC_BREAKPOINT (SIGTRAP)
        Exception Codes: 0x0000000000000002, 0x0000000000000000
        Crashed Thread: 0

        Dyld Error Message:
        Library not loaded: /usr/local/lib/libintl.3.dylib
        Referenced from: /Users/jwp/Desktop/MacVim.app/Contents/MacOS/Vim
        Reason: image not found


        > Ok, it sounds more and more like a DO problem which I believe the
        > latest source code version should fix (but I cannot explain why the
        > snapshot would work better than the stable version). Could you
        > possibly compile the latest source code version yourself and try
        > (since my binary didn't work)?


        I made a symlink to fink's libintl.3.dylib, and that worked. That
        build, http://rapidshare.com/files/148306436/MacVim-080925.tbz.html,
        seems to have fixed the issue.
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.