Loading ...
Sorry, an error occurred while loading the content.

Re: "o/" string with "ProFont" font displays as "ø"

Expand Messages
  • björn
    ... Hmmm...ProFont exhibits the same strange behavior in TextEdit which makes me think there is perhaps something wrong with the font? Maybe you can contact
    Message 1 of 5 , Aug 25, 2008
    • 0 Attachment
      2008/8/26 björn <bjorn.winckler@...>:
      > Hi Aitor,
      >
      > 2008/8/25 Aitor Garay-Romero <aitorgr@...>:
      >> I just switched to MacVim from MacPort's Vim and i'm getting a weird
      >> display effect with the string "o/". Wherever it appears (let it be
      >> buffers, ex command line, menus (nerdtree...)) the "o/" string is
      >> replaced with the "ø" character. AFAIK, this happens only with the
      >> ProFont font (http://www.tobias-jung.de/seekingprofont/).
      >>
      >> This didn't happen in standard gvim. Any idea about what's going
      >> on?
      >
      > I can reproduce the problem using ProFont over here so I'll look into
      > it very soon.

      Hmmm...ProFont exhibits the same strange behavior in TextEdit which
      makes me think there is perhaps something "wrong" with the font?
      Maybe you can contact the guy who provides the download and ask if he
      knows what's going on.

      In any case, this is _not_ a MacVim problem but I'd still be
      interested to know why ProFont turns "o/" into "ø".

      Björn

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • björn
      ... After a bit of looking around I stumbled across this: http://www.faisal.com/software/profontx/ The font provided on that page works for me with o/ . It
      Message 2 of 5 , Aug 25, 2008
      • 0 Attachment
        2008/8/26 björn <bjorn.winckler@...>:
        > 2008/8/26 björn <bjorn.winckler@...>:
        >> Hi Aitor,
        >>
        >> 2008/8/25 Aitor Garay-Romero <aitorgr@...>:
        >>> I just switched to MacVim from MacPort's Vim and i'm getting a weird
        >>> display effect with the string "o/". Wherever it appears (let it be
        >>> buffers, ex command line, menus (nerdtree...)) the "o/" string is
        >>> replaced with the "ø" character. AFAIK, this happens only with the
        >>> ProFont font (http://www.tobias-jung.de/seekingprofont/).
        >>>
        >>> This didn't happen in standard gvim. Any idea about what's going
        >>> on?
        >>
        >> I can reproduce the problem using ProFont over here so I'll look into
        >> it very soon.
        >
        > Hmmm...ProFont exhibits the same strange behavior in TextEdit which
        > makes me think there is perhaps something "wrong" with the font?
        > Maybe you can contact the guy who provides the download and ask if he
        > knows what's going on.
        >
        > In any case, this is _not_ a MacVim problem but I'd still be
        > interested to know why ProFont turns "o/" into "ø".

        After a bit of looking around I stumbled across this:

        http://www.faisal.com/software/profontx/

        The font provided on that page works for me with "o/". It mentions
        that ligatures have been removed, but Jiang recently patched MacVim to
        disable all use of ligatures so it is strange that these are still
        causing problems.

        Anyway, install ProFontX and everything should be fine.

        Björn

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Aitor Garay-Romero
        Hi Björn! It works perfectly with ProFontX. Thanks for your support. Thanks too to the MacVim project team for this great Vim port! /AITOR ...
        Message 3 of 5 , Aug 26, 2008
        • 0 Attachment
          Hi Björn!

          It works perfectly with ProFontX.

          Thanks for your support. Thanks too to the MacVim project team for
          this great Vim port!

          /AITOR

          On Aug 26, 2:01 am, "björn" <bjorn.winck...@...> wrote:
          > 2008/8/26 björn <bjorn.winck...@...>:
          >
          >
          >
          > > 2008/8/26 björn <bjorn.winck...@...>:
          > >> Hi Aitor,
          >
          > >> 2008/8/25 Aitor Garay-Romero <aito...@...>:
          > >>>  I just switched to MacVim from MacPort's Vim and i'm getting a weird
          > >>> display effect with the string "o/".  Wherever it appears (let it be
          > >>> buffers, ex command line,  menus (nerdtree...)) the "o/" string is
          > >>> replaced with the "ø" character.  AFAIK, this happens only with the
          > >>> ProFont font (http://www.tobias-jung.de/seekingprofont/).
          >
          > >>>  This didn't happen in standard gvim.  Any idea about what's going
          > >>> on?
          >
          > >> I can reproduce the problem using ProFont over here so I'll look into
          > >> it very soon.
          >
          > > Hmmm...ProFont exhibits the same strange behavior in TextEdit which
          > > makes me think there is perhaps something "wrong" with the font?
          > > Maybe you can contact the guy who provides the download and ask if he
          > > knows what's going on.
          >
          > > In any case, this is _not_ a MacVim problem but I'd still be
          > > interested to know why ProFont turns "o/" into "ø".
          >
          > After a bit of looking around I stumbled across this:
          >
          > http://www.faisal.com/software/profontx/
          >
          > The font provided on that page works for me with "o/".  It mentions
          > that ligatures have been removed, but Jiang recently patched MacVim to
          > disable all use of ligatures so it is strange that these are still
          > causing problems.
          >
          > Anyway, install ProFontX and everything should be fine.
          >
          > Björn
          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.