Loading ...
Sorry, an error occurred while loading the content.

Re: new vim binary for OS X (Jaguar)

Expand Messages
  • The Shrubber
    Hi, I just wanted to note that this still has the problem that hitting Ctrl-C while running a shell script causes all processes to die, and for me to return to
    Message 1 of 16 , Feb 11 10:37 AM
    • 0 Attachment
      Hi,

      I just wanted to note that this still has the problem that hitting
      Ctrl-C while running a shell script causes all processes to die,
      and for me to return to the Mac OS X login screen.

      If i run Vim from the command line, it behaves propertly, so my
      workaround is to write an alias, and never launch Vim from the dock or
      by double-clicking the icon, but this is not ideal.

      Cheers,

      (-S-)

      On Mon, Feb 03, 2003 at 12:26:04 -0500, Benji Fisher benji-at-member.AMS.org |vim-mac@.../1.0-Allow| wrote:
      > Vim Mac users:
      >
      > I have just uploaded a nre version of vim for OS X 10.2 (Jaguar) at
      >
      > http://macvim.swdev.org/OSX
    • Gregory Seidman
      Benji Fisher sez: } Rain Dog wrote: [...] } Note that the patch doesn t address the problem of Vim not forking } when it is launched from the command
      Message 2 of 16 , Feb 11 12:37 PM
      • 0 Attachment
        Benji Fisher sez:
        } Rain Dog wrote:
        [...]
        } >Note that the patch doesn't address the problem of Vim not forking
        } >when it is launched from the command line--that is, Vim launched as
        } >"/Applications/vim/Vim.app/Contents/MacOS/Vim -g" behaves like
        } >"/Applications/vim/Vim.app/Contents/MacOS/Vim -fg".
        }
        } Maybe I do not understand the problem correctly. In :help
        } gui-fork, it says something about running vim in the foreground; maybe I
        } read too much into this. It does seem that -gf and -g give the same
        } results. Perhaps the question of focus is not related to forking, as I
        } thought it was.

        The problem is that they give the same results. They shouldn't. By
        default, GUI vim should background itself (i.e. fork), but the -f flag
        suppresses that behavior.

        } If I run vim in the background, with
        }
        } % /Applications/vim/Vim.app/Contents/MacOS/Vim -g &
        }
        } then the Terminal is ready for new commands, and Vim comes into focus,
        } which is what I usually want. If I do not run it in the background,

        But you shouldn't need the &, it should Just Do It. This is the expected
        behavior withou the -f flag.

        } % /Applications/vim/Vim.app/Contents/MacOS/Vim -g
        }
        } then the terminal waits for Vim to finish. Is this different from not
        } forking? More to the point: is there a problem? For example, I have
        } not tried calling Vim from a mail program or anything that expects Vim
        } to finish before doing more work.

        This is exactly not forking. This is the expected behavior with the -f
        flag.

        } --Benji Fisher
        --Greg
      • Jason Alexander
        In the new binary, if I set the font to be Monaco (regular) at 12pt, the display looks rather different from my terminal window, which also has the font set to
        Message 3 of 16 , Feb 12 4:03 AM
        • 0 Attachment
          In the new binary, if I set the font to be Monaco (regular) at 12pt,
          the display looks rather different from my terminal window, which also
          has the font set to be Monaco (regular) at 12pt. The fonts in the
          terminal window are less ugly and a bit thicker, making them easier to
          read. What accounts for the difference in the two displays, and is it
          possible to get the displayed fonts in vim to match the appearance of
          those same fonts in the Terminal?

          Thanks,

          Jason

          >> I have just uploaded a nre version of vim for OS X 10.2 (Jaguar)
          >> at
          >>
          >> http://macvim.swdev.org/OSX
          >>
          --
          J. McKenzie Alexander
          Department of Philosophy, Logic and Scientific Method
          London School of Economics and Political Science
          Houghton Street, London WC2A 2AE
        • Benji Fisher
          ... This is probably because Vim uses the older Quicktime rendering instead of Quartz. Peter Cucka is working on enabling Quartz in Vim. --Benji Fisher
          Message 4 of 16 , Feb 14 7:36 AM
          • 0 Attachment
            Jason Alexander wrote:
            > In the new binary, if I set the font to be Monaco (regular) at 12pt, the
            > display looks rather different from my terminal window, which also has
            > the font set to be Monaco (regular) at 12pt. The fonts in the terminal
            > window are less ugly and a bit thicker, making them easier to read.
            > What accounts for the difference in the two displays, and is it possible
            > to get the displayed fonts in vim to match the appearance of those same
            > fonts in the Terminal?

            This is probably because Vim uses the older Quicktime rendering
            instead of Quartz. Peter Cucka is working on enabling Quartz in Vim.

            --Benji Fisher
          Your message has been successfully submitted and would be delivered to recipients shortly.