Loading ...
Sorry, an error occurred while loading the content.

new vim binary for OS X (Jaguar)

Expand Messages
  • Benji Fisher
    Vim Mac users: I have just uploaded a nre version of vim for OS X 10.2 (Jaguar) at http://macvim.swdev.org/OSX This version includes all the latest official
    Message 1 of 16 , Feb 3, 2003
    • 0 Attachment
      Vim Mac users:

      I have just uploaded a nre version of vim for OS X 10.2 (Jaguar) at

      http://macvim.swdev.org/OSX

      This version includes all the latest official patches and Peter Cucka's
      scroll.diff (recently posted to this list). Please test this: if I do
      not hear of any problems, I will recommend making this an official
      patch. (In the older version, I could cause a crash by :set go+=b and
      then clicking on the arrow to scroll horizontally; dragging the scroll
      bar did not cause a problem.)

      I do not see the problem that some users reported when first using
      10.2: when the 'fileformats' option includes "mac", vim does not
      recognize unix-style line endings properly. I am not sure why I do not
      see the problem and others did. The version I posted includes "mac" in
      the 'fileformats' option; let me know if this causes problems.

      I think I can still compile a version for 10.1, using the backup I
      made before upgrading to 10.2. If anyone wants to see this happen
      sooner rather than later, send me a note.

      Happy vimming!

      --Benji Fisher
    • Jay Lawrence
      Thanks for the new binary! ... Not a huge problem but possible source of user confusion (firstly mine). Open Vim, then resize window and now grab a scroll bar.
      Message 2 of 16 , Feb 3, 2003
      • 0 Attachment
        Thanks for the new binary!

        > This version includes all the latest official patches and Peter
        > Cucka's scroll.diff (recently posted to this list). Please test this:
        > if I do not hear of any problems, I will recommend making this an
        > official patch.

        Not a huge problem but possible source of user confusion (firstly
        mine). Open Vim, then resize window and now grab a scroll bar. It won't
        work. Click in window and then it works beautifully! :))

        Other observations:
        - Toggle left scroll bar does not cause scroll bar to appear until
        window is resized.
        - Toggle left scroll bar again does not seem to make it go away.
        - Bottom scroll bar seems broken ( not visible ) but toggling does
        create / remove the space where it would reside.

        FWIW I open Vim thusly:
        /Applications/vim/Vim.app/Contents/MacOS/Vim -g lib/foo.pm &

        Thanks for your contributions. OS X Vim is a very useful tool for me
        and my friends smart enough to have a Mac. ;-)

        Jay
      • Jay Lawrence
        ... Oh - and this occurred to me - any chance of getting mouse scroll wheel support? That would be really cool. I have to ask rather than patch as I have
        Message 3 of 16 , Feb 3, 2003
        • 0 Attachment
          > This version includes all the latest official patches and Peter
          > Cucka's scroll.diff (recently posted to this list). Please test this:
          > if I do not hear of any problems, I will recommend making this an
          > official patch. (In the older version, I could cause a crash by :set
          > go+=b and then clicking on the arrow to scroll horizontally; dragging
          > the scroll bar did not cause a problem.)

          Oh - and this occurred to me - any chance of getting mouse scroll wheel
          support? That would be really cool. I have to ask rather than patch as
          I have absolutely know idea where or how all this code works.

          TIA,
          J
        • Benji Fisher
          ... You are welcome. Thanks for the testing. It looks as if some of us keyboard junkies are not very good at testing GUI features. ... I
          Message 4 of 16 , Feb 7, 2003
          • 0 Attachment
            Jay Lawrence wrote:
            > Thanks for the new binary!

            You are welcome. Thanks for the testing. <sheepish>It looks as if
            some of us keyboard junkies are not very good at testing GUI
            features.</sheepish>

            >> This version includes all the latest official patches and Peter
            >> Cucka's scroll.diff (recently posted to this list). Please test this:
            >> if I do not hear of any problems, I will recommend making this an
            >> official patch.
            >
            > Not a huge problem but possible source of user confusion (firstly mine).
            > Open Vim, then resize window and now grab a scroll bar. It won't work.
            > Click in window and then it works beautifully! :))
            >
            > Other observations:
            > - Toggle left scroll bar does not cause scroll bar to appear until
            > window is resized.
            > - Toggle left scroll bar again does not seem to make it go away.
            > - Bottom scroll bar seems broken ( not visible ) but toggling does
            > create / remove the space where it would reside.
            >
            > FWIW I open Vim thusly:
            > /Applications/vim/Vim.app/Contents/MacOS/Vim -g lib/foo.pm &

            I get the same behavior when I open Vim from the finder. I tested
            these on the new version and also an older version. It looks to me as
            if these bugs were already there, so they are not caused by the latest
            patch. So far, the patch still looks good to me.

            TODO: update the bugs list on http://macvim.swdev.org/OSX .

            --Benji Fisher
          • Jay Lawrence
            ... If you re routing around on focus code - one other thing that I would really really appreciate is when Vim starts up can it become the top window and be
            Message 5 of 16 , Feb 8, 2003
            • 0 Attachment
              > I get the same behavior when I open Vim from the finder. I
              > tested these on the new version and also an older version. It looks
              > to me as if these bugs were already there, so they are not caused by
              > the latest patch. So far, the patch still looks good to me.
              >
              > TODO: update the bugs list on http://macvim.swdev.org/OSX .

              If you're routing around on focus code - one other thing that I would
              really really appreciate is when Vim starts up can it become the top
              window and be focused? As of now it starts at a much lower Z-level and
              I have to click to raise and focus.

              Oooh, and one other thing that would be super helpful is setting the
              application's name while in the dock. Personally I run several
              instances of Vim all the time. I get confused as to which is which. It
              would be excellent to see the same name as in the title bar... This,
              however, does not appear to be a Dock feature....

              So my wishlist to date:

              a - set application to current and raise at app startup
              b - set dock label to filename like in title bar - if Dock can do it
              c - scroll mouse support

              Cheers,
              J
            • Rain Dog
              ... The horizontal scroll bar doesn t appear while line wrapping is enabled. Did you try :set nowrap? ... Attached is a patch that should fix this. Peter
              Message 6 of 16 , Feb 8, 2003
              • 0 Attachment
                Jay Lawrence wrote:

                > - Bottom scroll bar seems broken ( not visible ) but toggling does
                > create / remove the space where it would reside.

                The horizontal scroll bar doesn't appear while line wrapping is enabled.
                Did you try :set nowrap?

                > If you're routing around on focus code - one other thing that I would
                > really really appreciate is when Vim starts up can it become the top
                > window and be focused? As of now it starts at a much lower Z-level and
                > I have to click to raise and focus.

                Attached is a patch that should fix this.

                Peter
              • Rain Dog
                ... *************** ... if (gui_win_x != -1 && gui_win_y != -1) gui_mch_set_winpos(gui_win_x, gui_win_y); + + #ifdef USE_CARBONIZED + /* + * Make the
                Message 7 of 16 , Feb 8, 2003
                • 0 Attachment
                  On Saturday, February 8, 2003, at 10:57 AM, Rain Dog wrote:

                  > Jay Lawrence wrote:
                  >
                  >> If you're routing around on focus code - one other thing that I would
                  >> really really appreciate is when Vim starts up can it become the top
                  >> window and be focused? As of now it starts at a much lower Z-level
                  >> and I have to click to raise and focus.
                  >
                  > Attached is a patch that should fix this.

                  No luck with Mail.app attachments. Here's the patch:

                  ---------- 8< ---------- 8< ---------- 8< ---------- 8< ---------- 8<
                  ----------

                  *** src/gui_mac.c Sat Nov 30 12:21:04 2002
                  --- src/gui_mac.c Sat Dec 28 18:21:12 2002
                  ***************
                  *** 2816,2821 ****
                  --- 2816,2834 ----

                  if (gui_win_x != -1 && gui_win_y != -1)
                  gui_mch_set_winpos(gui_win_x, gui_win_y);
                  +
                  + #ifdef USE_CARBONIZED
                  + /*
                  + * Make the GUI the foreground process (in case it was launched
                  + * from the Terminal or via :gui).
                  + */
                  + {
                  + ProcessSerialNumber psn;
                  + if (GetCurrentProcess(&psn) == noErr)
                  + SetFrontProcess(&psn);
                  + }
                  + #endif
                  +
                  return OK;
                  }
                • Benji Fisher
                  ... Perhaps I should remind everybody: my ability to code on the Mac is limited to make and variants. I maintain the binaries and the web page at
                  Message 8 of 16 , Feb 10, 2003
                  • 0 Attachment
                    Rain Dog wrote:
                    > On Saturday, February 8, 2003, at 10:57 AM, Rain Dog wrote:
                    >
                    >> Jay Lawrence wrote:
                    >>
                    >>> If you're routing around on focus code - one other thing that I would
                    >>> really really appreciate is when Vim starts up can it become the top
                    >>> window and be focused? As of now it starts at a much lower Z-level
                    >>> and I have to click to raise and focus.

                    Perhaps I should remind everybody: my ability to code on the Mac
                    is limited to "make" and variants. I maintain the binaries and the web
                    page at http://macvim.swdev.org/OSX but all the credit for improving the
                    code goes to others.

                    >> Attached is a patch that should fix this.
                    [snip]

                    This is great news! This has been at the top of my bug list for
                    as long as I have had a bug list! <hint>
                    http://macvim.swdev.org/OSX/#Bugs </hint>

                    With this patch, it is much easier for other programs to
                    communicate with vim. For example, a TeX previewer can call Vim with
                    +222 to start at line 222 of the source file. I think I am now ready to
                    ask Apple to post Vim on http://www.apple.com/downloads/macosx/ .

                    There is only one minor problem I notice. It is not directly
                    related to this patch: it happens any time I start vim from the command
                    line, which I never do without this patch. (Actually, it is not a
                    problem when I start Vim from the command line with "open -a Vim" .) I
                    get and "Error 254: cannot allocate color grey90" when I try

                    :hi Normal guibg=grey90

                    Any idea how to fix this? If not, I may modify the gvimrc_example.vim
                    that I distribute, but I would rather not.

                    --Benji Fisher
                  • Rain Dog
                    ... Note that the patch doesn t address the problem of Vim not forking when it is launched from the command line--that is, Vim launched as
                    Message 9 of 16 , Feb 10, 2003
                    • 0 Attachment
                      On Monday, February 10, 2003, at 07:36 AM, Benji Fisher wrote:
                      > Rain Dog wrote:
                      >> Jay Lawrence wrote:
                      >>
                      >>> If you're routing around on focus code - one other thing that I
                      >>> would really really
                      >>> appreciate is when Vim starts up can it become the top window and be
                      >>> focused?
                      >>> As of now it starts at a much lower Z-level and I have to click to
                      >>> raise and focus.
                      >>
                      >> Attached is a patch that should fix this.
                      >
                      > This is great news! This has been at the top of my bug list for as
                      > long as I have had
                      > a bug list! <hint> http://macvim.swdev.org/OSX/#Bugs </hint>

                      Note that the patch doesn't address the problem of Vim not forking
                      when it is launched from the command line--that is, Vim launched as
                      "/Applications/vim/Vim.app/Contents/MacOS/Vim -g" behaves like
                      "/Applications/vim/Vim.app/Contents/MacOS/Vim -fg".

                      Peter
                    • Rain Dog
                      ... Looks like your $VIMRUNTIME isn t getting set correctly. Vim looks up colors in the file $VIMRUNTIME/rgb.txt, which should be
                      Message 10 of 16 , Feb 10, 2003
                      • 0 Attachment
                        On Monday, February 10, 2003, at 07:36 AM, Benji Fisher wrote:

                        > There is only one minor problem I notice. It is not directly
                        > related to this patch: it happens any time I start vim from the
                        > command line, which I never do without this patch. (Actually, it is
                        > not a problem when I start Vim from the command line with "open -a
                        > Vim" .) I get and "Error 254: cannot allocate color grey90" when I
                        > try
                        >
                        > :hi Normal guibg=grey90
                        >
                        > Any idea how to fix this? If not, I may modify the gvimrc_example.vim
                        > that I distribute, but I would rather not.

                        Looks like your $VIMRUNTIME isn't getting set correctly. Vim looks up
                        colors
                        in the file $VIMRUNTIME/rgb.txt, which should be
                        /Applications/vim/vim61/rgb.txt.

                        Peter
                      • Benji Fisher
                        ... Good call. I was setting $VIM from my .cshrc . I removed that line, and it works fine now. Thanks. --Benji Fisher
                        Message 11 of 16 , Feb 11, 2003
                        • 0 Attachment
                          Rain Dog wrote:
                          > On Monday, February 10, 2003, at 07:36 AM, Benji Fisher wrote:
                          >
                          >> There is only one minor problem I notice. It is not directly
                          >> related to this patch: it happens any time I start vim from the
                          >> command line, which I never do without this patch. (Actually, it is
                          >> not a problem when I start Vim from the command line with "open -a
                          >> Vim" .) I get and "Error 254: cannot allocate color grey90" when I try
                          >>
                          >> :hi Normal guibg=grey90
                          >>
                          >> Any idea how to fix this? If not, I may modify the gvimrc_example.vim
                          >> that I distribute, but I would rather not.
                          >
                          >
                          > Looks like your $VIMRUNTIME isn't getting set correctly. Vim looks up
                          > colors
                          > in the file $VIMRUNTIME/rgb.txt, which should be
                          > /Applications/vim/vim61/rgb.txt.

                          Good call. I was setting $VIM from my .cshrc . I removed that
                          line, and it works fine now. Thanks.

                          --Benji Fisher
                        • Benji Fisher
                          ... Maybe I do not understand the problem correctly. In :help gui-fork, it says something about running vim in the foreground; maybe I read too much into
                          Message 12 of 16 , Feb 11, 2003
                          • 0 Attachment
                            Rain Dog wrote:
                            > On Monday, February 10, 2003, at 07:36 AM, Benji Fisher wrote:
                            >
                            >> This is great news! This has been at the top of my bug list for as
                            >> long as I have had
                            >> a bug list! <hint> http://macvim.swdev.org/OSX/#Bugs </hint>
                            >
                            >
                            > Note that the patch doesn't address the problem of Vim not forking
                            > when it is launched from the command line--that is, Vim launched as
                            > "/Applications/vim/Vim.app/Contents/MacOS/Vim -g" behaves like
                            > "/Applications/vim/Vim.app/Contents/MacOS/Vim -fg".

                            Maybe I do not understand the problem correctly. In :help
                            gui-fork, it says something about running vim in the foreground; maybe I
                            read too much into this. It does seem that -gf and -g give the same
                            results. Perhaps the question of focus is not related to forking, as I
                            thought it was.

                            If I run vim in the background, with

                            % /Applications/vim/Vim.app/Contents/MacOS/Vim -g &

                            then the Terminal is ready for new commands, and Vim comes into focus,
                            which is what I usually want. If I do not run it in the background,

                            % /Applications/vim/Vim.app/Contents/MacOS/Vim -g

                            then the terminal waits for Vim to finish. Is this different from not
                            forking? More to the point: is there a problem? For example, I have
                            not tried calling Vim from a mail program or anything that expects Vim
                            to finish before doing more work.

                            --Benji Fisher
                          • The Shrubber
                            Hi, I just wanted to note that this still has the problem that hitting Ctrl-C while running a shell script causes all processes to die, and for me to return to
                            Message 13 of 16 , Feb 11, 2003
                            • 0 Attachment
                              Hi,

                              I just wanted to note that this still has the problem that hitting
                              Ctrl-C while running a shell script causes all processes to die,
                              and for me to return to the Mac OS X login screen.

                              If i run Vim from the command line, it behaves propertly, so my
                              workaround is to write an alias, and never launch Vim from the dock or
                              by double-clicking the icon, but this is not ideal.

                              Cheers,

                              (-S-)

                              On Mon, Feb 03, 2003 at 12:26:04 -0500, Benji Fisher benji-at-member.AMS.org |vim-mac@.../1.0-Allow| wrote:
                              > Vim Mac users:
                              >
                              > I have just uploaded a nre version of vim for OS X 10.2 (Jaguar) at
                              >
                              > http://macvim.swdev.org/OSX
                            • Gregory Seidman
                              Benji Fisher sez: } Rain Dog wrote: [...] } Note that the patch doesn t address the problem of Vim not forking } when it is launched from the command
                              Message 14 of 16 , Feb 11, 2003
                              • 0 Attachment
                                Benji Fisher sez:
                                } Rain Dog wrote:
                                [...]
                                } >Note that the patch doesn't address the problem of Vim not forking
                                } >when it is launched from the command line--that is, Vim launched as
                                } >"/Applications/vim/Vim.app/Contents/MacOS/Vim -g" behaves like
                                } >"/Applications/vim/Vim.app/Contents/MacOS/Vim -fg".
                                }
                                } Maybe I do not understand the problem correctly. In :help
                                } gui-fork, it says something about running vim in the foreground; maybe I
                                } read too much into this. It does seem that -gf and -g give the same
                                } results. Perhaps the question of focus is not related to forking, as I
                                } thought it was.

                                The problem is that they give the same results. They shouldn't. By
                                default, GUI vim should background itself (i.e. fork), but the -f flag
                                suppresses that behavior.

                                } If I run vim in the background, with
                                }
                                } % /Applications/vim/Vim.app/Contents/MacOS/Vim -g &
                                }
                                } then the Terminal is ready for new commands, and Vim comes into focus,
                                } which is what I usually want. If I do not run it in the background,

                                But you shouldn't need the &, it should Just Do It. This is the expected
                                behavior withou the -f flag.

                                } % /Applications/vim/Vim.app/Contents/MacOS/Vim -g
                                }
                                } then the terminal waits for Vim to finish. Is this different from not
                                } forking? More to the point: is there a problem? For example, I have
                                } not tried calling Vim from a mail program or anything that expects Vim
                                } to finish before doing more work.

                                This is exactly not forking. This is the expected behavior with the -f
                                flag.

                                } --Benji Fisher
                                --Greg
                              • Jason Alexander
                                In the new binary, if I set the font to be Monaco (regular) at 12pt, the display looks rather different from my terminal window, which also has the font set to
                                Message 15 of 16 , Feb 12, 2003
                                • 0 Attachment
                                  In the new binary, if I set the font to be Monaco (regular) at 12pt,
                                  the display looks rather different from my terminal window, which also
                                  has the font set to be Monaco (regular) at 12pt. The fonts in the
                                  terminal window are less ugly and a bit thicker, making them easier to
                                  read. What accounts for the difference in the two displays, and is it
                                  possible to get the displayed fonts in vim to match the appearance of
                                  those same fonts in the Terminal?

                                  Thanks,

                                  Jason

                                  >> I have just uploaded a nre version of vim for OS X 10.2 (Jaguar)
                                  >> at
                                  >>
                                  >> http://macvim.swdev.org/OSX
                                  >>
                                  --
                                  J. McKenzie Alexander
                                  Department of Philosophy, Logic and Scientific Method
                                  London School of Economics and Political Science
                                  Houghton Street, London WC2A 2AE
                                • Benji Fisher
                                  ... This is probably because Vim uses the older Quicktime rendering instead of Quartz. Peter Cucka is working on enabling Quartz in Vim. --Benji Fisher
                                  Message 16 of 16 , Feb 14, 2003
                                  • 0 Attachment
                                    Jason Alexander wrote:
                                    > In the new binary, if I set the font to be Monaco (regular) at 12pt, the
                                    > display looks rather different from my terminal window, which also has
                                    > the font set to be Monaco (regular) at 12pt. The fonts in the terminal
                                    > window are less ugly and a bit thicker, making them easier to read.
                                    > What accounts for the difference in the two displays, and is it possible
                                    > to get the displayed fonts in vim to match the appearance of those same
                                    > fonts in the Terminal?

                                    This is probably because Vim uses the older Quicktime rendering
                                    instead of Quartz. Peter Cucka is working on enabling Quartz in Vim.

                                    --Benji Fisher
                                  Your message has been successfully submitted and would be delivered to recipients shortly.