Loading ...
Sorry, an error occurred while loading the content.

Re: Command-mode tab completion doesn't work, produces "^I" output

Expand Messages
  • Nico Weber
    Hi, ... this is usually the result of running in vi-compatible mode. What s the output of `:set compatible?`? (should be nocompatible ). Put `set compatible`
    Message 1 of 6 , Jul 2, 2008
    • 0 Attachment
      Hi,

      > When attempting to tab-complete paths and commands in command mode in
      > the latest build of MacVim, the expected behavior does not happen.
      > Instead, every press of the tab key outputs "^I" (ctrl-I), the
      > equivalent to the tab key. Nothing in my .vimrc or .gvimrc remaps
      > this key.

      this is usually the result of running in vi-compatible mode. What's
      the output of `:set compatible?`? (should be 'nocompatible'). Put `set
      compatible` as first line into your .vimrc to fix this.

      HTH,
      Nico


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Alex Payne
      With set compatible as the first line of my .vimrc I m able to tab- complete command names in command mode but not filesystem paths. ...
      Message 2 of 6 , Jul 2, 2008
      • 0 Attachment
        With "set compatible" as the first line of my .vimrc I'm able to tab-
        complete command names in command mode but not filesystem paths.

        On Jul 2, 12:44 pm, Nico Weber <nicolaswe...@...> wrote:
        > Hi,
        >
        > > When attempting to tab-complete paths and commands in command mode in
        > > the latest build of MacVim, the expected behavior does not happen.
        > > Instead, every press of the tab key outputs "^I" (ctrl-I), the
        > > equivalent to the tab key.  Nothing in my .vimrc or .gvimrc remaps
        > > this key.
        >
        > this is usually the result of running in vi-compatible mode. What's  
        > the output of `:set compatible?`? (should be 'nocompatible'). Put `set  
        > compatible` as first line into your .vimrc to fix this.
        >
        > HTH,
        > Nico
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Nico Weber
        ... Oh, I m sorry, it has to be `set nocompatible` of course. Does that help? ... --~--~---------~--~----~------------~-------~--~----~ You received this
        Message 3 of 6 , Jul 2, 2008
        • 0 Attachment
          > With "set compatible" as the first line of my .vimrc I'm able to tab-
          > complete command names in command mode but not filesystem paths.

          Oh, I'm sorry, it has to be `set nocompatible` of course. Does that
          help?

          > On Jul 2, 12:44 pm, Nico Weber <nicolaswe...@...> wrote:
          >> Hi,
          >>
          >>> When attempting to tab-complete paths and commands in command mode
          >>> in
          >>> the latest build of MacVim, the expected behavior does not happen.
          >>> Instead, every press of the tab key outputs "^I" (ctrl-I), the
          >>> equivalent to the tab key. Nothing in my .vimrc or .gvimrc remaps
          >>> this key.
          >>
          >> this is usually the result of running in vi-compatible mode. What's
          >> the output of `:set compatible?`? (should be 'nocompatible'). Put
          >> `set
          >> compatible` as first line into your .vimrc to fix this.
          >>
          >> HTH,
          >> Nico
          >

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Alex Payne
          Unfortunately, no. My previous setting was set nocompatible . As I said in my previous post, set compatible allowed me to tab-complete commands, but not
          Message 4 of 6 , Jul 3, 2008
          • 0 Attachment
            Unfortunately, no. My previous setting was "set nocompatible". As I
            said in my previous post, "set compatible" allowed me to tab-complete
            commands, but not filesystem paths.

            On Jul 2, 10:52 pm, Nico Weber <nicolaswe...@...> wrote:
            > > With "set compatible" as the first line of my .vimrc I'm able to tab-
            > > complete command names in command mode but not filesystem paths.
            >
            > Oh, I'm sorry, it has to be `set nocompatible` of course. Does that  
            > help?
            >
            > > On Jul 2, 12:44 pm, Nico Weber <nicolaswe...@...> wrote:
            > >> Hi,
            >
            > >>> When attempting to tab-complete paths and commands in command mode  
            > >>> in
            > >>> the latest build of MacVim, the expected behavior does not happen.
            > >>> Instead, every press of the tab key outputs "^I" (ctrl-I), the
            > >>> equivalent to the tab key.  Nothing in my .vimrc or .gvimrc remaps
            > >>> this key.
            >
            > >> this is usually the result of running in vi-compatible mode. What's
            > >> the output of `:set compatible?`? (should be 'nocompatible'). Put  
            > >> `set
            > >> compatible` as first line into your .vimrc to fix this.
            >
            > >> HTH,
            > >> Nico
            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Nico Weber
            ... Strange. Does it work if you launch MacVim with `mvim -u NONE -U NONE - N` (that tells it to skip your .vimrc, your .gvimrc, your plugins, but _does_ start
            Message 5 of 6 , Jul 3, 2008
            • 0 Attachment
              > Unfortunately, no. My previous setting was "set nocompatible". As I
              > said in my previous post, "set compatible" allowed me to tab-complete
              > commands, but not filesystem paths.

              Strange. Does it work if you launch MacVim with `mvim -u NONE -U NONE -
              N` (that tells it to skip your .vimrc, your .gvimrc, your plugins, but
              _does_ start MacVim in nocompatible mode)? If so, please post
              your .vimrc/.gvimrc files.

              Where do you try to complete file system paths? This only works in
              places where vim expects a file (e.g. behind `:e `). If you try it
              after e.g. `:echo` for testing, it won't work.

              Nico

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            Your message has been successfully submitted and would be delivered to recipients shortly.