Loading ...
Sorry, an error occurred while loading the content.

Re: Vim 6.1 for Jaguar

Expand Messages
  • ewitness - Ben Fowler
    ... Check your path. If your vim executable is /usr/local/bin/vim then you will either need to have /usr/local/bin on you path, or call vim with the full path.
    Message 1 of 5 , Oct 7, 2002
    • 0 Attachment
      At 12:33 am -0400 8/10/02, S. Raelynne Becerra wrote:
      >Greetings all!
      >
      >I used to have VIM 6.0 on my machine, and it was configured with all the
      >syntax colors that I enjoy and everything, then it stopped working. So I
      >have just installed VIM 6.1 for Jaguar on my machine, yet every time I
      >try to run it, I get the following error:
      > vim: command not found

      Check your path.

      If your vim executable is /usr/local/bin/vim then you will either
      need to have /usr/local/bin on you path, or call vim with the
      full path.

      >However, when I browse through my files in Terminal, I see the vim files
      >present. What could be the problem?

      Try doing

      % which vim

      to check that the system can 'see' the vim files.

      Ben
      --
      Privileged/Confidential Information may be contained in this message.
      If you are not the addressee indicated in this message (or responsible
      for delivery of the message to such person), you may not copy or deliver
      this message to anyone. In such case, you should destroy this message
      and kindly notify the sender by reply email. Please advise immediately
      if you or your employer do not consent to Internet email messages of this
      kind. Opinions, conclusions and other information in this message that
      do not relate to the official business of ewitness Limited shall be
      understood as neither given nor endorsed by it.

      eWitness Limited, Alpha House, Redvers Close, Lawnswood Business Park, Leeds, LS16 6QY
      Telephone: 0113 2951112 Fax: 0113 2951114
    • Benji Fisher
      ... How did you install vim? ... See the FAQ at http://macvim.swdev.org/OSX . HTH --Benji Fisher
      Message 2 of 5 , Oct 8, 2002
      • 0 Attachment
        On Tuesday, October 8, 2002, at 12:33 AM, S. Raelynne Becerra wrote:

        > Greetings all!
        >
        > I used to have VIM 6.0 on my machine, and it was configured with all the
        > syntax colors that I enjoy and everything, then it stopped working.
        > So I
        > have just installed VIM 6.1 for Jaguar on my machine, yet every time I
        > try to run it, I get the following error:
        > vim: command not found
        >
        > However, when I browse through my files in Terminal, I see the vim files
        > present. What could be the problem?

        How did you install vim?

        > Also, does anyone have any ideas for .vimrc for syntax colors?
        > (assuming
        > I get my VIM running)?

        See the FAQ at http://macvim.swdev.org/OSX .

        HTH --Benji Fisher
      • Benji Fisher
        ... They do some strange things... ... Thanks for the reply (and the package). I would have tested it myself, but my Jaguar disks are still in the box. (I
        Message 3 of 5 , Oct 8, 2002
        • 0 Attachment
          On Tuesday, October 8, 2002, at 04:59 PM, Marc Liyanage wrote:

          > Hi all,
          >
          >>> and it installs like a packaged software bundle, but it still says
          >>> vim:
          >>> command not found...
          >
          > That is because Apple unfortunately removed /usr/local/bin from their
          > default command search path.
          >
          > You either have to start vim as
          >
          > /usr/local/bin/vim
          >
          > or add /usr/local/bin to your command search path. Check out my mysql
          > page for an example of how to do this in the default tcsh shell...

          They do some strange things...

          > There's nothing wrong with the package... It has been up there for a
          > while and I am sure it works on 10.2 because I use it heavily all the
          > time myself. I was able to compile soon after 10.2 was out it by using
          > gcc2 instead of the default gcc3. Interesting to hear about the 200+
          > patches though. I guess they enable a clean gcc3 compile?
          > Marc Liyanage                                  liyanage@...
          >                                             http://www.entropy.ch

          Thanks for the reply (and the package). I would have tested it
          myself, but my Jaguar disks are still in the box. (I backed up the
          system yesterday, so I will try it Real Soon Now.) Others are compiling
          vim (for Terminal.app and the Carbon version) with gcc3. I think there
          are some problems, not very serious, with configure. A couple of the
          patches are aimed at fixing these; you may still have to add -lncurses
          or something to the compile options. Only a few of the patches are
          mac-specific; most are aimed at fixing problems with the many new
          features added to vim 6.0.

          --Benji Fisher
        Your message has been successfully submitted and would be delivered to recipients shortly.