Loading ...
Sorry, an error occurred while loading the content.

Re: help file problems

Expand Messages
  • Kenichi Asai
    Half a year ago: On Wed, Apr 17, 2002 at 10:05:43AM -0500, ... The similar problem occured to me yesterday (after installing Vim 5.8.9 on MacOS 9). It seems
    Message 1 of 5 , Sep 29 11:56 PM
    • 0 Attachment
      Half a year ago:

      On Wed, Apr 17, 2002 at 10:05:43AM -0500,
      arigold@... wrote:

      > hello hello,
      >
      > i was having trouble with an error message popping up whenever i started vim.
      > but this stopped after i put the vimrc file in the same folder as the page.
      > (maybe someone should correct this for the distribution, no?) the problem now
      > is that i cant access the help file, although it exists.. im running vim6.0.17
      > this is the error message i get:
      >
      > E433: No tags file
      > E426: tag not found: help.txt
      > Hit ENTER or type command to continue
      >
      > any ideas would be much appreciated as simpletext just isnt cutting it
      > anymore...

      The similar problem occured to me yesterday (after installing Vim
      5.8.9 on MacOS 9). It seems that the problem comes from the format of
      tags file (located in runtime:doc:tags). By default, it is in UNIX
      format, but after converting it to Mac format, I received no error
      message. But wasn't this problem solved long time ago? Or does the
      tags file still have to be in Mac format?

      Sincerely,

      ---
      Kenichi Asai
    • Axel Kielhorn
      ... According to the docs the vimrc file can be Unix or Mac. It doesn t say anything about tag files. I have just tried my version of 6.1 and it handles Mac
      Message 2 of 5 , Sep 30 10:13 AM
      • 0 Attachment
        At 15:56 Uhr +0900 2002-09-30, Kenichi Asai wrote:

        >The similar problem occured to me yesterday (after installing Vim
        >5.8.9 on MacOS 9). It seems that the problem comes from the format of
        >tags file (located in runtime:doc:tags). By default, it is in UNIX
        >format, but after converting it to Mac format, I received no error
        >message. But wasn't this problem solved long time ago? Or does the
        >tags file still have to be in Mac format?
        >

        According to the docs the vimrc file can be Unix or Mac. It doesn't
        say anything about tag files.

        I have just tried my version of 6.1 and it handles Mac and Unix tags files.
        The difference between my version and the "official" version is, that
        i don't use fgets_cr anymore.

        So far I have seen no negative side effect, maybe we should make that official.
        It is only used 3 times in the source and it's removal will help to
        clean up the code. This may cause problems with older
        compilers/libraries, but works fine with CW Pro2.

        If this works for you I will prepare a patch for 5.8 and 6.1 and send
        it to Bram to make the change official.

        I'm not sure if we can get rid of USE_CR as well, but I will look
        into it over the long weekend.

        Axel
      • Kenichi Asai
        On Mon, Sep 30, 2002 at 07:13:58PM +0200, ... Could you please send me the patch for 5.8? I will compile with it and test. I have tags file in both Unix and
        Message 3 of 5 , Oct 2, 2002
        • 0 Attachment
          On Mon, Sep 30, 2002 at 07:13:58PM +0200,
          Axel Kielhorn wrote:

          > If this works for you I will prepare a patch for 5.8 and 6.1 and send
          > it to Bram to make the change official.

          Could you please send me the patch for 5.8? I will compile with it
          and test. I have tags file in both Unix and Mac formats, now.

          Sincerely,

          ---
          Kenichi Asai
        • Axel Kielhorn
          ... After some more testing I discovered that my version of 6.1 only works sometimes when the tags file is in Unix format. This means we have to document that
          Message 4 of 5 , Oct 4, 2002
          • 0 Attachment
            At 10:23 Uhr +0900 2002-10-03, Kenichi Asai wrote:
            >On Mon, Sep 30, 2002 at 07:13:58PM +0200,
            > Axel Kielhorn wrote:
            >
            >> If this works for you I will prepare a patch for 5.8 and 6.1 and send
            >> it to Bram to make the change official.
            >
            >Could you please send me the patch for 5.8? I will compile with it
            >and test. I have tags file in both Unix and Mac formats, now.

            After some more testing I discovered that my version of 6.1 only
            works sometimes when the tags file is in Unix format.

            This means we have to document that the tags file has to be in Mac format.

            Sorry. Things will hopefully get better in OS X which has Unix format
            as a default. I'm currently in the painfull process of migration.

            Axel


            --
            The Mac Vim page is now at:
            macvim.swdev.org/OSX for MacOS X
            macvim.swdev.org/MacClassic
            My e-mail address has changed to: macvim@...
          Your message has been successfully submitted and would be delivered to recipients shortly.