Loading ...
Sorry, an error occurred while loading the content.

AZERTY key mapping

Expand Messages
  • nykacho
    Hello, I m trying to use MacVim with a french AZERTY keyboard and I don t have access to the , like , or even the backslash . I tricked
    Message 1 of 10 , Apr 7, 2008
    • 0 Attachment
      Hello,
      I'm trying to use MacVim with a french AZERTY keyboard and I don't
      have access to the <Meta-keys>, like <[>, <]> or even the backslash <
      \>.
      I tricked it by manually mapping the keys that I need with their ASCII
      code:

      map! <D-)> <Char-93>

      Still, is there any config variable to set in order to have all the
      meta-keys work propely ?

      Thank you
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • björn
      ... I don t understand exactly what it is you are trying to achieve. Is it the the Cmd-key combinations on the menus that you want to change (such as Next
      Message 2 of 10 , Apr 8, 2008
      • 0 Attachment
        On 07/04/2008, nykacho <email.de.nicolas.martin@...> wrote:
        >
        > Hello,
        > I'm trying to use MacVim with a french AZERTY keyboard and I don't
        > have access to the <Meta-keys>, like <[>, <]> or even the backslash <
        > \>.
        > I tricked it by manually mapping the keys that I need with their ASCII
        > code:
        >
        > map! <D-)> <Char-93>
        >
        > Still, is there any config variable to set in order to have all the
        > meta-keys work propely ?

        I don't understand exactly what it is you are trying to achieve. Is
        it the the Cmd-key combinations on the menus that you want to change
        (such as Next Tab)? If not, can you give us an example of what you
        are trying to do?

        /Björn

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Ben Schmidt
        ... I believe the problem is this: on many international keyboards a number of keys are used to type accented characters. Making space for these accented
        Message 3 of 10 , Apr 8, 2008
        • 0 Attachment
          björn wrote:
          > On 07/04/2008, nykacho <email.de.nicolas.martin@...> wrote:
          >> Hello,
          >> I'm trying to use MacVim with a french AZERTY keyboard and I don't
          >> have access to the <Meta-keys>, like <[>, <]> or even the backslash <
          >> \>.
          >> I tricked it by manually mapping the keys that I need with their ASCII
          >> code:
          >>
          >> map! <D-)> <Char-93>
          >>
          >> Still, is there any config variable to set in order to have all the
          >> meta-keys work propely ?
          >
          > I don't understand exactly what it is you are trying to achieve. Is
          > it the the Cmd-key combinations on the menus that you want to change
          > (such as Next Tab)? If not, can you give us an example of what you
          > are trying to do?

          I believe the problem is this: on many international keyboards a number of keys
          are used to type accented characters. Making space for these accented letters
          displaces other characters, usually punctuation, and to type them, one must use
          the option key. It seems this includes the square brackets and backslash on French
          AZERTY--you have to use the option key to type them--and it seems MacVim isn't
          picking this up. I presume this would affect insert mode as well as normal mode.

          (This is just my interpretation of the post, along with a little prior knowledge.
          I haven't tried it out.)

          This seems strange to me, as does the Dvorak z and ; issue mentioned in another
          thread. Maybe they are related issues.

          Ben.





          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • nykacho
          To sum up and to give some todo to the developpers :) : AZERTY keyboards not fully supported on MacVim ( all the key combinations are not available
          Message 4 of 10 , Apr 15, 2008
          • 0 Attachment
            To sum up and to give some todo to the developpers :) :

            AZERTY keyboards not fully supported on MacVim ( all the <Meta-X> key
            combinations are not available which is very problematic because they
            give access to \,},] chars )

            Thank you

            On Apr 8, 8:31 pm, Ben Schmidt <mail_ben_schm...@...> wrote:
            > björn wrote:
            > > On 07/04/2008, nykacho <email.de.nicolas.mar...@...> wrote:
            > >>  Hello,
            > >>  I'm trying to use MacVim with a french AZERTY keyboard and I don't
            > >>  have access to the <Meta-keys>, like <[>, <]> or even the backslash <
            > >>  \>.
            > >>  I tricked it by manually mapping the keys that I need with their ASCII
            > >>  code:
            >
            > >>  map! <D-)> <Char-93>
            >
            > >>  Still, is there any config variable to set in order to have all the
            > >>  meta-keys work propely ?
            >
            > > I don't understand exactly what it is you are trying to achieve.  Is
            > > it the the Cmd-key combinations on the menus that you want to change
            > > (such as Next Tab)?  If not, can you give us an example of what you
            > > are trying to do?
            >
            > I believe the problem is this: on many international keyboards a number of keys
            > are used to type accented characters. Making space for these accented letters
            > displaces other characters, usually punctuation, and to type them, one must use
            > the option key. It seems this includes the square brackets and backslash on French
            > AZERTY--you have to use the option key to type them--and it seems MacVim isn't
            > picking this up. I presume this would affect insert mode as well as normal mode.
            >
            > (This is just my interpretation of the post, along with a little prior knowledge.
            > I haven't tried it out.)
            >
            > This seems strange to me, as does the Dvorak z and ; issue mentioned in another
            > thread. Maybe they are related issues.
            >
            > Ben.
            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • björn
            ... What exactly happens when you press Option-key...nothing at all? Or something else? Bjorn --~--~---------~--~----~------------~-------~--~----~ You
            Message 5 of 10 , Apr 16, 2008
            • 0 Attachment
              On 15/04/2008, nykacho <email.de.nicolas.martin@...> wrote:
              >
              > To sum up and to give some todo to the developpers :) :
              >
              > AZERTY keyboards not fully supported on MacVim ( all the <Meta-X> key
              > combinations are not available which is very problematic because they
              > give access to \,},] chars )

              What exactly happens when you press Option-key...nothing at all? Or
              something else?

              Bjorn

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • nykacho
              When I press , which should get a backslash , I get a normal slash / , as if I didn t press the Option key. It seems like
              Message 6 of 10 , Apr 18, 2008
              • 0 Attachment
                When I press <Shit - Option - :>, which should get a backslash ' \ ',
                I get a normal slash '/', as if I didn't press the Option key.

                It seems like <Shit - Option - X> combinations don't work

                This happens in all modes so it's impossible to call <Leader>XXX
                commands with an AZERY keyboard

                Thank you

                On 17 avr, 00:37, "björn" <bjorn.winck...@...> wrote:
                > On 15/04/2008, nykacho <email.de.nicolas.mar...@...> wrote:
                >
                >
                >
                > >  To sum up and to give some todo to the developpers :) :
                >
                > >  AZERTY keyboards not fully supported on MacVim ( all the <Meta-X> key
                > >  combinations are not available which is very problematic because they
                > >  give access to \,},] chars )
                >
                > What exactly happens when you press Option-key...nothing at all?  Or
                > something else?
                >
                > Bjorn
                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • björn
                ... I hope you mean Shift ;-) Anyway, thanks for letting me know about this...I will look into it as soon as I get a chance. /Björn
                Message 7 of 10 , Apr 24, 2008
                • 0 Attachment
                  On 18/04/2008, nykacho <email.de.nicolas.martin@...> wrote:
                  >
                  > On 17 avr, 00:37, "björn" <bjorn.winck...@...> wrote:
                  >
                  > > On 15/04/2008, nykacho <email.de.nicolas.mar...@...> wrote:
                  > >
                  > >
                  > >
                  > > > To sum up and to give some todo to the developpers :) :
                  > >
                  > > > AZERTY keyboards not fully supported on MacVim ( all the <Meta-X> key
                  > > > combinations are not available which is very problematic because they
                  > > > give access to \,},] chars )
                  > >
                  > > What exactly happens when you press Option-key...nothing at all? Or
                  > > something else?
                  > >
                  >
                  > When I press <Shit - Option - :>, which should get a backslash ' \ ',
                  > I get a normal slash '/', as if I didn't press the Option key.
                  >
                  > It seems like <Shit - Option - X> combinations don't work
                  >
                  > This happens in all modes so it's impossible to call <Leader>XXX
                  > commands with an AZERY keyboard

                  I hope you mean "Shift" ;-)

                  Anyway, thanks for letting me know about this...I will look into it as
                  soon as I get a chance.

                  /Björn

                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_mac" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • Morel David
                  ... I use azerty (French layout) as well and it works fine here. Not sure what the problem could be ??? David
                  Message 8 of 10 , Apr 25, 2008
                  • 0 Attachment
                    Le 7 avr. 08 à 09:21, nykacho a écrit :

                    >
                    > Hello,
                    > I'm trying to use MacVim with a french AZERTY keyboard and I don't
                    > have access to the <Meta-keys>, like <[>, <]> or even the backslash <
                    > \>.
                    > I tricked it by manually mapping the keys that I need with their ASCII
                    > code:

                    I use azerty (French layout) as well and it works fine here.

                    Not sure what the problem could be ???

                    David


                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_mac" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  • björn
                    ... I see...it could be that nykacho uses a customized ~/Library/KeyBindings/DefaultKeyBinding.dict. Nykacho, can you check if you do have such a file, and if
                    Message 9 of 10 , Apr 26, 2008
                    • 0 Attachment
                      2008/4/25 Morel David <dmorel69@...>:
                      > > Hello,
                      > > I'm trying to use MacVim with a french AZERTY keyboard and I don't
                      > > have access to the <Meta-keys>, like <[>, <]> or even the backslash <
                      > > \>.
                      > > I tricked it by manually mapping the keys that I need with their ASCII
                      > > code:
                      >
                      > I use azerty (French layout) as well and it works fine here.
                      >
                      > Not sure what the problem could be ???

                      I see...it could be that nykacho uses a customized
                      ~/Library/KeyBindings/DefaultKeyBinding.dict. Nykacho, can you check
                      if you do have such a file, and if so can you temporarily move it and
                      restart MacVim (maybe log in/out as well) and see if the problem
                      persists.

                      Thanks,
                      Björn

                      --~--~---------~--~----~------------~-------~--~----~
                      You received this message from the "vim_mac" maillist.
                      For more information, visit http://www.vim.org/maillist.php
                      -~----------~----~----~----~------~----~------~--~---
                    • nykacho
                      I started from scratch and downloaded the last MacVim snapshot. It now works perfectly with my AZERTY layout. I think I was using the cocoa port of gvim, or
                      Message 10 of 10 , Apr 30, 2008
                      • 0 Attachment
                        I started from scratch and downloaded the last MacVim snapshot.
                        It now works perfectly with my AZERTY layout.
                        I think I was using the cocoa port of gvim, or some other version as I
                        downloaded all of them.
                        Thanks again everyone.


                        On 26 avr, 22:16, "björn" <bjorn.winck...@...> wrote:
                        > 2008/4/25 Morel David <dmore...@...>:
                        >
                        > > > Hello,
                        > > > I'm trying to use MacVim with a frenchAZERTYkeyboard and I don't
                        > > > have access to the <Meta-keys>, like <[>, <]> or even the backslash <
                        > > > \>.
                        > > > I tricked it by manually mapping the keys that I need with their ASCII
                        > > > code:
                        >
                        > > I useazerty(French layout) as well and it works fine here.
                        >
                        > > Not sure what the problem could be ???
                        >
                        > I see...it could be that nykacho uses a customized
                        > ~/Library/KeyBindings/DefaultKeyBinding.dict. Nykacho, can you check
                        > if you do have such a file, and if so can you temporarily move it and
                        > restart MacVim (maybe log in/out as well) and see if the problem
                        > persists.
                        >
                        > Thanks,
                        > Björn
                        --~--~---------~--~----~------------~-------~--~----~
                        You received this message from the "vim_mac" maillist.
                        For more information, visit http://www.vim.org/maillist.php
                        -~----------~----~----~----~------~----~------~--~---
                      Your message has been successfully submitted and would be delivered to recipients shortly.