Loading ...
Sorry, an error occurred while loading the content.

Latexsuite + MacVim: No View rule defined for target pdf

Expand Messages
  • krisse
    This is driving me bonkers a t m. If I open a tex-file with macvim, I get a error message stating that No View rule [is] defined for target pdf , and advises
    Message 1 of 21 , Apr 2, 2008
    • 0 Attachment
      This is driving me bonkers a t m.

      If I open a tex-file with macvim, I get a error message stating that
      "No View rule [is] defined for target pdf", and advises me to "specify
      a rule in $VIMRUNTIME/ftplugin/tex/texrc".

      Allrighty. I add the following to that very file ($HOME/.vim/
      ftpl...):
      let g:Tex_ViewRule_pdf = ''

      Nothing changes; same error. Hmh. Oh well; I add it to $HOME/.vimrc
      --- but still no go! Frustrated, I try to add it to .gvimrc as well,
      but no, no go; same error continue to pop up.

      I don't get it if I use (10.5) native vim.

      I have checked that .vim is in $VIMRUNTIME, and yes it is.

      Tried to google this, but no luck there either.

      Do you have any ideas? I really don't need this ViewRule. Everything
      works fine, except for that annoying error-message.

      Any and every thought is appreciated. Thanks!


      /Kristian
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Ted Pavlic
      ... What happens when you ... from inside vim? Compare to what happens when you type ... Here s a related note:
      Message 2 of 21 , Apr 2, 2008
      • 0 Attachment
        > Do you have any ideas? I really don't need this ViewRule. Everything
        > works fine, except for that annoying error-message.

        What happens when you

        :echo g:Tex_ViewRule_pdf

        from inside vim? Compare to what happens when you type

        :echo g:blahblahblah


        Here's a related note:

        http://phaseportrait.blogspot.com/2007/07/vim-latex-modification-forward.html


        --
        Ted Pavlic <ted@...>

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • krisse
        Thanks. Right, it does seem that the variable *is* set, as I have it set to nothing, and nothing happens when I try to echo it -- as opposed to what happens
        Message 3 of 21 , Apr 2, 2008
        • 0 Attachment
          Thanks.

          Right, it does seem that the variable *is* set, as I have it set to
          nothing, and nothing happens when I try to echo it -- as opposed to
          what happens when echoing a non-existing variable (e g blah or some
          such). So, then, why does it keep complaining?

          Bonkers, I tell you, it's driving me bonkers! x-D

          I don't really care about forward searching; I don't use it (as far as
          I know, and I think I would've noticed, though you never know). I just
          want to be able to start macvim without it throwing that at me.


          Thanks again for your suggestion. At least I know g:Tex_ViewRule_pdf
          is set.


          /Kristian

          On 2 Apr, 18:53, Ted Pavlic <t...@...> wrote:
          > > Do you have any ideas? I really don't need this ViewRule. Everything
          > > works fine, except for that annoying error-message.
          >
          > What happens when you
          >
          > :echo g:Tex_ViewRule_pdf
          >
          > from inside vim? Compare to what happens when you type
          >
          > :echo g:blahblahblah
          >
          > Here's a related note:
          >
          > http://phaseportrait.blogspot.com/2007/07/vim-latex-modification-forw...
          >
          > --
          > Ted Pavlic <t...@...>
          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Nico Weber
          Hi, ... perhaps this thread can help you: http://groups.google.com/group/vim_mac/browse_thread/thread/20eee82425719106/603ae961635814f2?#603ae961635814f2
          Message 4 of 21 , Apr 3, 2008
          • 0 Attachment
            Hi,

            > Right, it does seem that the variable *is* set, as I have it set to
            > nothing, and nothing happens when I try to echo it -- as opposed to
            > what happens when echoing a non-existing variable (e g blah or some
            > such). So, then, why does it keep complaining?

            perhaps this thread can help you: http://groups.google.com/group/vim_mac/browse_thread/thread/20eee82425719106/603ae961635814f2?#603ae961635814f2
            (gist: check the "Launch vim processes in login shell" in the
            preferences.

            Hm, perhaps there should be an entry about MacVim and tex in the faq,
            this comes up rather frequently.

            HTH,
            Nico

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Ted Pavlic
            Nico -- I really don t think that s going to help. I have never had the problem described by Kristian, and I have never had that setting checked. The variable
            Message 5 of 21 , Apr 3, 2008
            • 0 Attachment
              Nico --

              I really don't think that's going to help. I have never had the problem
              described by Kristian, and I have never had that setting checked.

              The variable in the error message is not an environment variable. It's
              a Vim variable set by Vim-LaTeX. I'm pretty sure it's not a VIMRUNTIME
              problem because Vim-LaTeX *IS* getting loaded.

              There's something else going on here.

              --Ted



              Nico Weber wrote:
              > Hi,
              >
              >> Right, it does seem that the variable *is* set, as I have it set to
              >> nothing, and nothing happens when I try to echo it -- as opposed
              >> to what happens when echoing a non-existing variable (e g blah or
              >> some such). So, then, why does it keep complaining?
              >
              > perhaps this thread can help you:
              > http://groups.google.com/group/vim_mac/browse_thread/thread/20eee82425719106/603ae961635814f2?#603ae961635814f2
              > (gist: check the "Launch vim processes in login shell" in the
              > preferences.
              >
              > Hm, perhaps there should be an entry about MacVim and tex in the faq,
              > this comes up rather frequently.
              >
              > HTH, Nico
              >
              > >
              >

              --
              Ted Pavlic <ted@...>

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • björn
              ... Good idea. Could somebody please compile a short FAQ entry for me to put on the MacVim project page (with links to relevant pages on Ted s site etc.)?
              Message 6 of 21 , Apr 3, 2008
              • 0 Attachment
                On 03/04/2008, Nico Weber <nicolasweber@...> wrote:
                >
                > Hi,
                >
                >
                > > Right, it does seem that the variable *is* set, as I have it set to
                > > nothing, and nothing happens when I try to echo it -- as opposed to
                > > what happens when echoing a non-existing variable (e g blah or some
                > > such). So, then, why does it keep complaining?
                >
                >
                > perhaps this thread can help you: http://groups.google.com/group/vim_mac/browse_thread/thread/20eee82425719106/603ae961635814f2?#603ae961635814f2
                > (gist: check the "Launch vim processes in login shell" in the
                > preferences.
                >
                > Hm, perhaps there should be an entry about MacVim and tex in the faq,
                > this comes up rather frequently.

                Good idea. Could somebody please compile a short FAQ entry for me to
                put on the MacVim project page (with links to relevant pages on Ted's
                site etc.)? I'm not using LaTeX suite myself at the moment so I'm not
                the ideal person to write such an entry.

                Thanks,
                Björn

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • krisse
                As Ted guessed, it did not help. (To check the Launch vim processes in login shell in the preferences.) I have the variable set in .vimrc (and in the file
                Message 7 of 21 , Apr 3, 2008
                • 0 Attachment
                  As Ted guessed, it did not help. (To check the "Launch vim processes
                  in login shell" in the
                  preferences.)

                  I have the variable set in .vimrc (and in the file the error msg
                  suggests as well; and no, I haven't always had it in both places, I've
                  switched and shifted and commente in and out and... bonkers). The
                  variable is fine, as troubleshooting per Teds initial suggestion
                  showed. ... Although it can't be, given the error-message. *sigh*

                  Yes, vim-latex is getting loaded. Everything works just fine. That is,
                  except for that error that gets thrown in my face every time I load a
                  TEX-file... :-)


                  Thanks for your efforts.


                  /Kristian

                  On 3 Apr, 16:20, Ted Pavlic <t...@...> wrote:
                  > Nico --
                  >
                  >         I really don't think that's going to help. I have never had the problem
                  > described by Kristian, and I have never had that setting checked.
                  >
                  >         The variable in the error message is not an environment variable. It's
                  > a Vim variable set by Vim-LaTeX. I'm pretty sure it's not a VIMRUNTIME
                  > problem because Vim-LaTeX *IS* getting loaded.
                  >
                  >         There's something else going on here.
                  >
                  >         --Ted
                  >
                  >
                  >
                  > Nico Weber wrote:
                  > > Hi,
                  >
                  > >> Right, it does seem that the variable *is* set, as I have it set to
                  > >>  nothing, and nothing happens when I try to echo it -- as opposed
                  > >> to what happens when echoing a non-existing variable (e g blah or
                  > >> some such). So, then, why does it keep complaining?
                  >
                  > > perhaps this thread can help you:
                  > >http://groups.google.com/group/vim_mac/browse_thread/thread/20eee8242...
                  > >  (gist: check the "Launch vim processes in login shell" in the
                  > > preferences.
                  >
                  > > Hm, perhaps there should be an entry about MacVim and tex in the faq,
                  > >  this comes up rather frequently.
                  >
                  > > HTH, Nico
                  >
                  > --
                  > Ted Pavlic <t...@...>
                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_mac" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • aireydc
                  I would be very interested in an FAQ on installing MacVim and Vim- LaTeX on my OS X 10.5.2 system. I am hesitating at the moment without be able to follow a
                  Message 8 of 21 , Apr 3, 2008
                  • 0 Attachment
                    I would be very interested in an FAQ on installing MacVim and Vim-
                    LaTeX on my OS X 10.5.2 system. I am hesitating at the moment without
                    be able to follow a guide or tips on troubleshooting. Currently I have
                    MacPorts Vim installed and I am just learning the basics of Vim. I had
                    headaches installing TeXlive, because of bugs in that package with
                    regard to installing correct PATHs on an upgraded Leopard system. That
                    is all resolved and a trail of the fix is online at the mac latex
                    listserv. TexShop is fine, but I'd like to try MacVim + Vim-Latex.

                    Cheers,

                    -Dave

                    On Apr 3, 10:59 am, "björn" <bjorn.winck...@...> wrote:
                    > On 03/04/2008, Nico Weber <nicolaswe...@...> wrote:
                    >
                    >
                    >
                    >
                    >
                    > >  Hi,
                    >
                    > >  > Right, it does seem that the variable *is* set, as I have it set to
                    > >  > nothing, and nothing happens when I try to echo it -- as opposed to
                    > >  > what happens when echoing a non-existing variable (e g blah or some
                    > >  > such). So, then, why does it keep complaining?
                    >
                    > > perhaps this thread can help you:http://groups.google.com/group/vim_mac/browse_thread/thread/20eee8242...
                    > >   (gist: check the "Launch vim processes in login shell" in the
                    > >  preferences.
                    >
                    > >  Hm, perhaps there should be an entry about MacVim and tex in the faq,
                    > >  this comes up rather frequently.
                    >
                    > Good idea.  Could somebody please compile a short FAQ entry for me to
                    > put on the MacVim project page (with links to relevant pages on Ted's
                    > site etc.)?  I'm not using LaTeX suite myself at the moment so I'm not
                    > the ideal person to write such an entry.
                    >
                    > Thanks,
                    > Björn
                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_mac" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  • Ted Pavlic
                    On a related note, you should *NOT* be installing TeXLive from fink or MacPorts. I *suppose* that you might be able to get LaTeX package updates easier that
                    Message 9 of 21 , Apr 3, 2008
                    • 0 Attachment
                      On a related note, you should *NOT* be installing TeXLive from fink or
                      MacPorts. I *suppose* that you might be able to get LaTeX package
                      updates easier that way, but overall I have a feeling it's a bad idea.

                      Instead, use MacTeX from TUG or gwTeX.

                      MacTeX: http://www.tug.org/mactex/

                      gwTeX: http://ii2.sourceforge.net/tex-index.html

                      You can install them both. You'll get a "System Preferences" pane that
                      allows yourself to switch from one to the other as needed (it changes a
                      symlink).

                      --Ted


                      aireydc wrote:
                      > I would be very interested in an FAQ on installing MacVim and Vim-
                      > LaTeX on my OS X 10.5.2 system. I am hesitating at the moment without
                      > be able to follow a guide or tips on troubleshooting. Currently I
                      > have MacPorts Vim installed and I am just learning the basics of Vim.
                      > I had headaches installing TeXlive, because of bugs in that package
                      > with regard to installing correct PATHs on an upgraded Leopard
                      > system. That is all resolved and a trail of the fix is online at the
                      > mac latex listserv. TexShop is fine, but I'd like to try MacVim +
                      > Vim-Latex.
                      >
                      > Cheers,
                      >
                      > -Dave
                      >
                      > On Apr 3, 10:59 am, "björn" <bjorn.winck...@...> wrote:
                      >> On 03/04/2008, Nico Weber <nicolaswe...@...> wrote:
                      >>
                      >>
                      >>
                      >>
                      >>
                      >>> Hi,
                      >>>> Right, it does seem that the variable *is* set, as I have it
                      >>>> set to nothing, and nothing happens when I try to echo it -- as
                      >>>> opposed to what happens when echoing a non-existing variable (e
                      >>>> g blah or some such). So, then, why does it keep complaining?
                      >>> perhaps this thread can help
                      >>> you:http://groups.google.com/group/vim_mac/browse_thread/thread/20eee8242...
                      >>> (gist: check the "Launch vim processes in login shell" in the
                      >>> preferences. Hm, perhaps there should be an entry about MacVim
                      >>> and tex in the faq, this comes up rather frequently.
                      >> Good idea. Could somebody please compile a short FAQ entry for me
                      >> to put on the MacVim project page (with links to relevant pages on
                      >> Ted's site etc.)? I'm not using LaTeX suite myself at the moment
                      >> so I'm not the ideal person to write such an entry.
                      >>
                      >> Thanks, Björn
                      > >
                      >

                      --
                      Ted Pavlic <ted@...>

                      --~--~---------~--~----~------------~-------~--~----~
                      You received this message from the "vim_mac" maillist.
                      For more information, visit http://www.vim.org/maillist.php
                      -~----------~----~----~----~------~----~------~--~---
                    • Ben Schmidt
                      ... Where/how did you get latex-suite, Kristian? I downloaded the version from the sourceforge download site to try it out (haven t really got around to it
                      Message 10 of 21 , Apr 4, 2008
                      • 0 Attachment
                        krisse wrote:
                        > This is driving me bonkers a t m.
                        >
                        > If I open a tex-file with macvim, I get a error message stating that
                        > "No View rule [is] defined for target pdf", and advises me to "specify
                        > a rule in $VIMRUNTIME/ftplugin/tex/texrc".

                        Where/how did you get latex-suite, Kristian? I downloaded the version from the
                        sourceforge download site to try it out (haven't really got around to it yet), but
                        can't even find that error message in the distribution!

                        Still, googling, I found this page which might help

                        http://www.mail-archive.com/vim-latex-devel@.../msg00006.html

                        Looks like the solution is...use vim-latex from its svn, not its tarball, or "put
                        something like let Tex_ViewRule_pdf = '/path/to/acrobat/reader $*.pdf' in your
                        ~/vimfiles/ftplugin/tex.vim or .vimrc"

                        Though to me this seems basically equivalent to what you did already, except that
                        it contains something real. I guess I would probably do

                        let Tex_ViewRule_pdf = '/usr/bin/open -a Preview $*.pdf'

                        Where do you get your latex-suite, Ted?

                        Also, Kristian, since this seems to be MacVim specific...which version of MacVim
                        are you using? I agree this is quite strange.

                        Ben.



                        > Allrighty. I add the following to that very file ($HOME/.vim/
                        > ftpl...):
                        > let g:Tex_ViewRule_pdf = ''
                        >
                        > Nothing changes; same error. Hmh. Oh well; I add it to $HOME/.vimrc
                        > --- but still no go! Frustrated, I try to add it to .gvimrc as well,
                        > but no, no go; same error continue to pop up.
                        >
                        > I don't get it if I use (10.5) native vim.
                        >
                        > I have checked that .vim is in $VIMRUNTIME, and yes it is.
                        >
                        > Tried to google this, but no luck there either.
                        >
                        > Do you have any ideas? I really don't need this ViewRule. Everything
                        > works fine, except for that annoying error-message.
                        >
                        > Any and every thought is appreciated. Thanks!
                        >
                        >
                        > /Kristian




                        --~--~---------~--~----~------------~-------~--~----~
                        You received this message from the "vim_mac" maillist.
                        For more information, visit http://www.vim.org/maillist.php
                        -~----------~----~----~----~------~----~------~--~---
                      • Kristian Niemi
                        Hi, Thanks for chiming in! I downloaded latex-suite from their website [1] (it s version 20060325). MacVim from [2] (snapshot 24). I ll give the svn version of
                        Message 11 of 21 , Apr 4, 2008
                        • 0 Attachment
                          Hi,

                          Thanks for chiming in!

                          I downloaded latex-suite from their website [1] (it's version 20060325).
                          MacVim from [2] (snapshot 24).

                          I'll give the svn version of latex-suite a twirl!

                          Just for the heck of it, I'll put that exact line in my .vimrc,
                          although I already have a line there (and in the location the error
                          message suggests) which should be equivalent. And, as has been
                          previously stated, the variable _is_ set. It's like MacVim just
                          doesn't like the answer. ;-) Maybe including a target ($*.pdf) in the
                          command, that the var consists of, makes it happier. Who knows.


                          Thanks for your help!

                          /Kristian

                          [1] http://vim-latex.sourceforge.net/index.php?subject=download&title=Download
                          [2] http://code.google.com/p/macvim/downloads/list


                          On Fri, Apr 4, 2008 at 1:16 PM, Ben Schmidt
                          <mail_ben_schmidt@...> wrote:
                          >
                          > krisse wrote:
                          > > This is driving me bonkers a t m.
                          > >
                          > > If I open a tex-file with macvim, I get a error message stating that
                          > > "No View rule [is] defined for target pdf", and advises me to "specify
                          > > a rule in $VIMRUNTIME/ftplugin/tex/texrc".
                          >
                          > Where/how did you get latex-suite, Kristian? I downloaded the version from the
                          > sourceforge download site to try it out (haven't really got around to it yet), but
                          > can't even find that error message in the distribution!
                          >
                          > Still, googling, I found this page which might help
                          >
                          > http://www.mail-archive.com/vim-latex-devel@.../msg00006.html
                          >
                          > Looks like the solution is...use vim-latex from its svn, not its tarball, or "put
                          > something like let Tex_ViewRule_pdf = '/path/to/acrobat/reader $*.pdf' in your
                          > ~/vimfiles/ftplugin/tex.vim or .vimrc"
                          >
                          > Though to me this seems basically equivalent to what you did already, except that
                          > it contains something real. I guess I would probably do
                          >
                          > let Tex_ViewRule_pdf = '/usr/bin/open -a Preview $*.pdf'
                          >
                          > Where do you get your latex-suite, Ted?
                          >
                          > Also, Kristian, since this seems to be MacVim specific...which version of MacVim
                          > are you using? I agree this is quite strange.
                          >
                          > Ben.
                          >
                          >

                          --~--~---------~--~----~------------~-------~--~----~
                          You received this message from the "vim_mac" maillist.
                          For more information, visit http://www.vim.org/maillist.php
                          -~----------~----~----~----~------~----~------~--~---
                        • Ben Schmidt
                          ... Odd. That s the version of latex-suite I downloaded too. Maybe I m doing something wrong! This link seems to offer another more reliable solution...
                          Message 12 of 21 , Apr 4, 2008
                          • 0 Attachment
                            Kristian Niemi wrote:
                            > Hi,
                            >
                            > Thanks for chiming in!
                            >
                            > I downloaded latex-suite from their website [1] (it's version 20060325).
                            > MacVim from [2] (snapshot 24).
                            >
                            > I'll give the svn version of latex-suite a twirl!
                            >
                            > Just for the heck of it, I'll put that exact line in my .vimrc,
                            > although I already have a line there (and in the location the error
                            > message suggests) which should be equivalent. And, as has been
                            > previously stated, the variable _is_ set. It's like MacVim just
                            > doesn't like the answer. ;-) Maybe including a target ($*.pdf) in the
                            > command, that the var consists of, makes it happier. Who knows.
                            >
                            >
                            > Thanks for your help!
                            >
                            > /Kristian

                            Odd. That's the version of latex-suite I downloaded too. Maybe I'm doing something
                            wrong! This link seems to offer another more reliable solution...

                            http://www.mail-archive.com/vim-latex-devel@.../msg00093.html

                            Ben.




                            --~--~---------~--~----~------------~-------~--~----~
                            You received this message from the "vim_mac" maillist.
                            For more information, visit http://www.vim.org/maillist.php
                            -~----------~----~----~----~------~----~------~--~---
                          • Ben Schmidt
                            ... Aha! I found the error message, too! Line 43 of compiler.vim. Looks like setting that variable to blank would *cause* the error! It seems the previous
                            Message 13 of 21 , Apr 4, 2008
                            • 0 Attachment
                              Ben Schmidt wrote:
                              > Kristian Niemi wrote:
                              >> Hi,
                              >>
                              >> Thanks for chiming in!
                              >>
                              >> I downloaded latex-suite from their website [1] (it's version 20060325).
                              >> MacVim from [2] (snapshot 24).
                              >>
                              >> I'll give the svn version of latex-suite a twirl!
                              >>
                              >> Just for the heck of it, I'll put that exact line in my .vimrc,
                              >> although I already have a line there (and in the location the error
                              >> message suggests) which should be equivalent. And, as has been
                              >> previously stated, the variable _is_ set. It's like MacVim just
                              >> doesn't like the answer. ;-) Maybe including a target ($*.pdf) in the
                              >> command, that the var consists of, makes it happier. Who knows.
                              >>
                              >>
                              >> Thanks for your help!
                              >>
                              >> /Kristian
                              >
                              > Odd. That's the version of latex-suite I downloaded too. Maybe I'm doing something
                              > wrong! This link seems to offer another more reliable solution...
                              >
                              > http://www.mail-archive.com/vim-latex-devel@.../msg00093.html

                              Aha! I found the error message, too! Line 43 of compiler.vim. Looks like setting
                              that variable to blank would *cause* the error!

                              It seems the previous bugfix was slightly buggy, too! This may be more robust:

                              let Tex_ViewRuleComplete_pdf = '/usr/bin/open -a Preview $*.pdf'

                              or such. Interesting. It will be fun getting my hands on some Tex stuff at some
                              stage. One day...

                              Ben.




                              --~--~---------~--~----~------------~-------~--~----~
                              You received this message from the "vim_mac" maillist.
                              For more information, visit http://www.vim.org/maillist.php
                              -~----------~----~----~----~------~----~------~--~---
                            • Kristian Niemi
                              That looks promising!! Having high hopes it ll be fixed swiftly once I get to that comp and can give it a go. Thanks! /Kristian On Fri, Apr 4, 2008 at 1:45 PM,
                              Message 14 of 21 , Apr 4, 2008
                              • 0 Attachment
                                That looks promising!! Having high hopes it'll be fixed swiftly once I
                                get to that comp and can give it a go.

                                Thanks!


                                /Kristian

                                On Fri, Apr 4, 2008 at 1:45 PM, Ben Schmidt
                                <mail_ben_schmidt@...> wrote:
                                >
                                > Ben Schmidt wrote:
                                > > Kristian Niemi wrote:
                                > >> Hi,
                                > >>
                                > >> Thanks for chiming in!
                                > >>
                                > >> I downloaded latex-suite from their website [1] (it's version 20060325).
                                > >> MacVim from [2] (snapshot 24).
                                > >>
                                > >> I'll give the svn version of latex-suite a twirl!
                                > >>
                                > >> Just for the heck of it, I'll put that exact line in my .vimrc,
                                > >> although I already have a line there (and in the location the error
                                > >> message suggests) which should be equivalent. And, as has been
                                > >> previously stated, the variable _is_ set. It's like MacVim just
                                > >> doesn't like the answer. ;-) Maybe including a target ($*.pdf) in the
                                > >> command, that the var consists of, makes it happier. Who knows.
                                > >>
                                > >>
                                > >> Thanks for your help!
                                > >>
                                > >> /Kristian
                                > >
                                > > Odd. That's the version of latex-suite I downloaded too. Maybe I'm doing something
                                > > wrong! This link seems to offer another more reliable solution...
                                > >
                                > > http://www.mail-archive.com/vim-latex-devel@.../msg00093.html
                                >
                                > Aha! I found the error message, too! Line 43 of compiler.vim. Looks like setting
                                > that variable to blank would *cause* the error!
                                >
                                > It seems the previous bugfix was slightly buggy, too! This may be more robust:
                                >
                                > let Tex_ViewRuleComplete_pdf = '/usr/bin/open -a Preview $*.pdf'
                                >
                                > or such. Interesting. It will be fun getting my hands on some Tex stuff at some
                                > stage. One day...
                                >
                                >
                                >
                                > Ben.
                                >
                                >
                                >
                                >
                                > >
                                >

                                --~--~---------~--~----~------------~-------~--~----~
                                You received this message from the "vim_mac" maillist.
                                For more information, visit http://www.vim.org/maillist.php
                                -~----------~----~----~----~------~----~------~--~---
                              • Ted Pavlic
                                A few things... 1.) Setting your ViewRule to something nonempty will fix the problem. I set mine to be empty and got the error, and so keeping it nonempty
                                Message 15 of 21 , Apr 4, 2008
                                • 0 Attachment
                                  A few things...

                                  1.) Setting your ViewRule to something nonempty will fix the problem. I
                                  set mine to be empty and got the error, and so keeping it nonempty fixes it.

                                  2.) I had checked compiler.vim earlier, but I dismissed the empty string
                                  solution because

                                  2.a) It's perfectly fine to set it empty once Vim is started; that just
                                  causes Vim to use the system default to open the file

                                  2.b) I was *SURE* I used to leave mine blank exactly for that reason. In
                                  fact, if you look at the ~/.vim/ftplugin/latex-suite/texrc that comes
                                  with the suite, they're blank by default on OS/X

                                  So, I think that this is one of the many compiler.vim bugs plaguing the
                                  suite when it is run on OS/X. I've patched many of them (see a previous
                                  message in this thread).

                                  In defense of the suite, I think you should view the "error" as more of
                                  a "warning." If you leave things blank, it should just execute an "open"
                                  without any application.

                                  --Ted

                                  Kristian Niemi wrote:
                                  > That looks promising!! Having high hopes it'll be fixed swiftly once
                                  > I get to that comp and can give it a go.
                                  >
                                  > Thanks!
                                  >
                                  >
                                  > /Kristian
                                  >
                                  > On Fri, Apr 4, 2008 at 1:45 PM, Ben Schmidt
                                  > <mail_ben_schmidt@...> wrote:
                                  >> Ben Schmidt wrote:
                                  >>> Kristian Niemi wrote:
                                  >>>> Hi,
                                  >>>>
                                  >>>> Thanks for chiming in!
                                  >>>>
                                  >>>> I downloaded latex-suite from their website [1] (it's version
                                  >>>> 20060325). MacVim from [2] (snapshot 24).
                                  >>>>
                                  >>>> I'll give the svn version of latex-suite a twirl!
                                  >>>>
                                  >>>> Just for the heck of it, I'll put that exact line in my .vimrc,
                                  >>>> although I already have a line there (and in the location the
                                  >>>> error message suggests) which should be equivalent. And, as has
                                  >>>> been previously stated, the variable _is_ set. It's like MacVim
                                  >>>> just doesn't like the answer. ;-) Maybe including a target
                                  >>>> ($*.pdf) in the command, that the var consists of, makes it
                                  >>>> happier. Who knows.
                                  >>>>
                                  >>>>
                                  >>>> Thanks for your help!
                                  >>>>
                                  >>>> /Kristian
                                  >>>
                                  >>> Odd. That's the version of latex-suite I downloaded too. Maybe
                                  >>> I'm doing something wrong! This link seems to offer another more
                                  >>> reliable solution...
                                  >>>
                                  >>> http://www.mail-archive.com/vim-latex-devel@.../msg00093.html
                                  >>>
                                  >>
                                  >> Aha! I found the error message, too! Line 43 of compiler.vim. Looks
                                  >> like setting that variable to blank would *cause* the error!
                                  >>
                                  >> It seems the previous bugfix was slightly buggy, too! This may be
                                  >> more robust:
                                  >>
                                  >> let Tex_ViewRuleComplete_pdf = '/usr/bin/open -a Preview $*.pdf'
                                  >>
                                  >> or such. Interesting. It will be fun getting my hands on some Tex
                                  >> stuff at some stage. One day...
                                  >>
                                  >>
                                  >>
                                  >> Ben.
                                  >>
                                  >>
                                  >>
                                  >>
                                  >>>
                                  >>
                                  >
                                  > >
                                  >

                                  --
                                  Ted Pavlic <ted@...>

                                  --~--~---------~--~----~------------~-------~--~----~
                                  You received this message from the "vim_mac" maillist.
                                  For more information, visit http://www.vim.org/maillist.php
                                  -~----------~----~----~----~------~----~------~--~---
                                • Ted Pavlic
                                  The line that *SHOULD* be there is (all one line): if !(has( win32 ) || has( macunix )) && (!Tex_GetVarValue( Tex_UseMakefile ) || (glob( makefile* ) == &&
                                  Message 16 of 21 , Apr 4, 2008
                                  • 0 Attachment
                                    The line that *SHOULD* be there is (all one line):

                                    if !(has('win32') || has('macunix')) &&
                                    (!Tex_GetVarValue('Tex_UseMakefile') || (glob('makefile*') == '' &&
                                    glob('Makefile*') == ''))

                                    That will fix the problem. Both macunix and win32 have a way of opening
                                    those files without needing a specified viewer.

                                    --Ted

                                    Ted Pavlic wrote:
                                    > A few things...
                                    >
                                    > 1.) Setting your ViewRule to something nonempty will fix the problem.
                                    > I set mine to be empty and got the error, and so keeping it nonempty
                                    > fixes it.
                                    >
                                    > 2.) I had checked compiler.vim earlier, but I dismissed the empty
                                    > string solution because
                                    >
                                    > 2.a) It's perfectly fine to set it empty once Vim is started; that
                                    > just causes Vim to use the system default to open the file
                                    >
                                    > 2.b) I was *SURE* I used to leave mine blank exactly for that reason.
                                    > In fact, if you look at the ~/.vim/ftplugin/latex-suite/texrc that
                                    > comes with the suite, they're blank by default on OS/X
                                    >
                                    > So, I think that this is one of the many compiler.vim bugs plaguing
                                    > the suite when it is run on OS/X. I've patched many of them (see a
                                    > previous message in this thread).
                                    >
                                    > In defense of the suite, I think you should view the "error" as more
                                    > of a "warning." If you leave things blank, it should just execute an
                                    > "open" without any application.
                                    >
                                    > --Ted
                                    >
                                    > Kristian Niemi wrote:
                                    >> That looks promising!! Having high hopes it'll be fixed swiftly
                                    >> once I get to that comp and can give it a go.
                                    >>
                                    >> Thanks!
                                    >>
                                    >>
                                    >> /Kristian
                                    >>
                                    >> On Fri, Apr 4, 2008 at 1:45 PM, Ben Schmidt
                                    >> <mail_ben_schmidt@...> wrote:
                                    >>> Ben Schmidt wrote:
                                    >>>> Kristian Niemi wrote:
                                    >>>>> Hi,
                                    >>>>>
                                    >>>>> Thanks for chiming in!
                                    >>>>>
                                    >>>>> I downloaded latex-suite from their website [1] (it's version
                                    >>>>> 20060325). MacVim from [2] (snapshot 24).
                                    >>>>>
                                    >>>>> I'll give the svn version of latex-suite a twirl!
                                    >>>>>
                                    >>>>> Just for the heck of it, I'll put that exact line in my
                                    >>>>> .vimrc, although I already have a line there (and in the
                                    >>>>> location the error message suggests) which should be
                                    >>>>> equivalent. And, as has been previously stated, the variable
                                    >>>>> _is_ set. It's like MacVim just doesn't like the answer. ;-)
                                    >>>>> Maybe including a target ($*.pdf) in the command, that the
                                    >>>>> var consists of, makes it happier. Who knows.
                                    >>>>>
                                    >>>>>
                                    >>>>> Thanks for your help!
                                    >>>>>
                                    >>>>> /Kristian
                                    >>>> Odd. That's the version of latex-suite I downloaded too. Maybe
                                    >>>> I'm doing something wrong! This link seems to offer another
                                    >>>> more reliable solution...
                                    >>>>
                                    >>>> http://www.mail-archive.com/vim-latex-devel@.../msg00093.html
                                    >>>>
                                    >>>>
                                    >>> Aha! I found the error message, too! Line 43 of compiler.vim.
                                    >>> Looks like setting that variable to blank would *cause* the
                                    >>> error!
                                    >>>
                                    >>> It seems the previous bugfix was slightly buggy, too! This may be
                                    >>> more robust:
                                    >>>
                                    >>> let Tex_ViewRuleComplete_pdf = '/usr/bin/open -a Preview $*.pdf'
                                    >>>
                                    >>> or such. Interesting. It will be fun getting my hands on some Tex
                                    >>> stuff at some stage. One day...
                                    >>>
                                    >>>
                                    >>>
                                    >>> Ben.
                                    >>>
                                    >>>
                                    >>>
                                    >>>
                                    >

                                    --
                                    Ted Pavlic <ted@...>

                                    --~--~---------~--~----~------------~-------~--~----~
                                    You received this message from the "vim_mac" maillist.
                                    For more information, visit http://www.vim.org/maillist.php
                                    -~----------~----~----~----~------~----~------~--~---
                                  • Ben Schmidt
                                    ... 1. Thanks for communicating that. Do you have a way to get this and your other fixes included in vim-latex svn? Surely that would be worthwhile,
                                    Message 17 of 21 , Apr 4, 2008
                                    • 0 Attachment
                                      Ted Pavlic wrote:
                                      > The line that *SHOULD* be there is (all one line):
                                      >
                                      > if !(has('win32') || has('macunix')) &&
                                      > (!Tex_GetVarValue('Tex_UseMakefile') || (glob('makefile*') == '' &&
                                      > glob('Makefile*') == ''))
                                      >
                                      > That will fix the problem. Both macunix and win32 have a way of opening
                                      > those files without needing a specified viewer.

                                      1. Thanks for communicating that. Do you have a way to get this and your other
                                      fixes included in vim-latex svn? Surely that would be worthwhile, particularly
                                      considering the number of vim-latex questions we get on these lists!

                                      2. I wonder why I don't get the error. I have no Makefile and my Tex_ViewRule_pdf
                                      seems to be empty, and Tex_ViewRuleComplete_pdf seems to be undefined. The error
                                      should simply have occured when opening a .tex file, yeah?

                                      3. Do you have any comment on the patch to compiler.vim suggested here?:
                                      http://www.mail-archive.com/vim-latex-devel@.../msg00093.html
                                      It doesn't seem quite right to me, though it is a bit ambiguous. I guess the docs
                                      should be consulted--it seems like you're somehow meant to set viewer to an app
                                      name "Preview" rather than path to a binary, but the patch suggests changing it so
                                      you give a binary name, but I'm not sure this would work so well as what was
                                      originally there.

                                      Ben.




                                      --~--~---------~--~----~------------~-------~--~----~
                                      You received this message from the "vim_mac" maillist.
                                      For more information, visit http://www.vim.org/maillist.php
                                      -~----------~----~----~----~------~----~------~--~---
                                    • Kristian Niemi
                                      Still not at my comp, so can t confirm it worked for me -- though I m sure it will! --, but just wanted to jolt down that I *did* have the ViewRule set to
                                      Message 18 of 21 , Apr 4, 2008
                                      • 0 Attachment
                                        Still not at my comp, so can't confirm it worked for me -- though I'm
                                        sure it will! --, but just wanted to jolt down that I *did* have the
                                        ViewRule set to something not-empty originally. I even tried with
                                        different apps. Having it set to non-empty/empty did not matter for
                                        me.

                                        *However*, in none of my attempts did I have a target specified
                                        ($*.pdf or some such) in the variable. Perhaps that would have made a
                                        difference; I don't know. I'll get back to you, though you all seem to
                                        have this figured down to its core now. :-)

                                        By the way, I wrote on this list instead of some other list/forum --
                                        like the vim-latex one, or some such --, since I only got this with
                                        the VimMac, not with native vim. (Though I didn't try console VimMac.)


                                        /Kristian

                                        On Fri, Apr 4, 2008 at 3:50 PM, Ben Schmidt
                                        <mail_ben_schmidt@...> wrote:
                                        >
                                        > Ted Pavlic wrote:
                                        > > The line that *SHOULD* be there is (all one line):
                                        > >
                                        > > if !(has('win32') || has('macunix')) &&
                                        > > (!Tex_GetVarValue('Tex_UseMakefile') || (glob('makefile*') == '' &&
                                        > > glob('Makefile*') == ''))
                                        > >
                                        > > That will fix the problem. Both macunix and win32 have a way of opening
                                        > > those files without needing a specified viewer.
                                        >
                                        > 1. Thanks for communicating that. Do you have a way to get this and your other
                                        > fixes included in vim-latex svn? Surely that would be worthwhile, particularly
                                        > considering the number of vim-latex questions we get on these lists!
                                        >
                                        > 2. I wonder why I don't get the error. I have no Makefile and my Tex_ViewRule_pdf
                                        > seems to be empty, and Tex_ViewRuleComplete_pdf seems to be undefined. The error
                                        > should simply have occured when opening a .tex file, yeah?
                                        >
                                        > 3. Do you have any comment on the patch to compiler.vim suggested here?:
                                        >
                                        > http://www.mail-archive.com/vim-latex-devel@.../msg00093.html
                                        > It doesn't seem quite right to me, though it is a bit ambiguous. I guess the docs
                                        > should be consulted--it seems like you're somehow meant to set viewer to an app
                                        > name "Preview" rather than path to a binary, but the patch suggests changing it so
                                        > you give a binary name, but I'm not sure this would work so well as what was
                                        > originally there.
                                        >
                                        > Ben.
                                        >
                                        >
                                        >
                                        >
                                        >
                                        >
                                        > >
                                        >

                                        --~--~---------~--~----~------------~-------~--~----~
                                        You received this message from the "vim_mac" maillist.
                                        For more information, visit http://www.vim.org/maillist.php
                                        -~----------~----~----~----~------~----~------~--~---
                                      • Ted Pavlic
                                        ... Eventually, I d like to download the vanilla distribution and organize some patches, and try to put everything on-line. Is there a Vim-LaTeX SVN? I never
                                        Message 19 of 21 , Apr 4, 2008
                                        • 0 Attachment
                                          > 1. Thanks for communicating that. Do you have a way to get this and
                                          > your other fixes included in vim-latex svn? Surely that would be
                                          > worthwhile, particularly considering the number of vim-latex
                                          > questions we get on these lists!

                                          Eventually, I'd like to download the vanilla distribution and organize
                                          some patches, and try to put everything on-line.

                                          Is there a Vim-LaTeX SVN? I never thought of that. I downloaded it from
                                          vim.org, I think, and it didn't hit me until now that the
                                          Vim-latex-devel list is a SourceForge list, so it's probably all SVN
                                          managed.

                                          I've never checked anything into SF (I avoid anyone or anything even
                                          distantly related to CVS). I'm sure the process is probably pretty
                                          straight-forward. Someday...

                                          > 2. I wonder why I don't get the error. I have no Makefile and my
                                          > Tex_ViewRule_pdf seems to be empty, and Tex_ViewRuleComplete_pdf
                                          > seems to be undefined. The error should simply have occured when
                                          > opening a .tex file, yeah?

                                          I think that function is only called when the target changes... Maybe. I
                                          know that the "default" target for macosx is pdf, and I explicitly
                                          change mine to 'dvi'. Maybe that has something to do with it.

                                          I get the error if I simply do

                                          vi blah.tex

                                          That is, right on the load of the suite. Though I *think* if I changed
                                          the ViewRule during runtime and then change my target, I don't get the
                                          error... On the other hand, when I did that spot check, I may have
                                          grabbed a TeX file I was working on, in which case there was probably a
                                          Makefile in the directory.

                                          So... it's possible that the error will also occur when you change the
                                          target (through the menu).


                                          > 3. Do you have any comment on the patch to compiler.vim suggested
                                          > here?:
                                          > http://www.mail-archive.com/vim-latex-devel@.../msg00093.html

                                          It makes absolutely no sense.

                                          With or without Tex_ViewRule_* defined, I have no trouble executing \lv.

                                          Additionally, applying that patch completely screws you over if you want
                                          to open your target with something that isn't your system's default.


                                          > It doesn't seem quite right to me, though it is a bit ambiguous. I
                                          > guess the docs should be consulted--it seems like you're somehow
                                          > meant to set viewer to an app name "Preview" rather than path to a
                                          > binary, but the patch suggests changing it so you give a binary name,
                                          > but I'm not sure this would work so well as what was originally
                                          > there.

                                          open blah.pdf

                                          works fine (opens in Skim for me), but so does:

                                          open -a Preview blah.pdf

                                          (which opens in Preview). Likewise, I can make ViewRule empty to get my
                                          default action or set it to something to get my not-so-default action.

                                          --Ted


                                          >
                                          > Ben.
                                          >
                                          >
                                          >
                                          >
                                          > >
                                          >

                                          --
                                          Ted Pavlic <ted@...>

                                          --~--~---------~--~----~------------~-------~--~----~
                                          You received this message from the "vim_mac" maillist.
                                          For more information, visit http://www.vim.org/maillist.php
                                          -~----------~----~----~----~------~----~------~--~---
                                        • Kristian Niemi
                                          Aaaah! The sweet view Vim without an error in my face! The following (in .vimrc) did *not* work: let g:Tex_ViewRule_pdf = /usr/bin/open -a Preview $*.pdf let
                                          Message 20 of 21 , Apr 4, 2008
                                          • 0 Attachment
                                            Aaaah! The sweet view Vim without an error in my face!

                                            The following (in .vimrc) did *not* work:
                                            let g:Tex_ViewRule_pdf = '/usr/bin/open -a Preview $*.pdf'
                                            let Tex_ViewRule_pdf = '/usr/bin/open -a Preview $*.pdf'
                                            let g:Tex_ViewRule_pdf = '/usr/bin/open -a Preview'
                                            let g:Tex_ViewRule_pdf = ''

                                            This *did* work:
                                            let Tex_ViewRuleComplete_pdf = '/usr/bin/open -a Preview $*.pdf'


                                            Thanks for all of your efforts and ideas!


                                            /Kristian

                                            On Fri, Apr 4, 2008 at 1:45 PM, Ben Schmidt
                                            <mail_ben_schmidt@...> wrote:
                                            >
                                            > Ben Schmidt wrote:
                                            > > Kristian Niemi wrote:
                                            > >> Hi,
                                            > >>
                                            > >> Thanks for chiming in!
                                            > >>
                                            > >> I downloaded latex-suite from their website [1] (it's version 20060325).
                                            > >> MacVim from [2] (snapshot 24).
                                            > >>
                                            > >> I'll give the svn version of latex-suite a twirl!
                                            > >>
                                            > >> Just for the heck of it, I'll put that exact line in my .vimrc,
                                            > >> although I already have a line there (and in the location the error
                                            > >> message suggests) which should be equivalent. And, as has been
                                            > >> previously stated, the variable _is_ set. It's like MacVim just
                                            > >> doesn't like the answer. ;-) Maybe including a target ($*.pdf) in the
                                            > >> command, that the var consists of, makes it happier. Who knows.
                                            > >>
                                            > >>
                                            > >> Thanks for your help!
                                            > >>
                                            > >> /Kristian
                                            > >
                                            > > Odd. That's the version of latex-suite I downloaded too. Maybe I'm doing something
                                            > > wrong! This link seems to offer another more reliable solution...
                                            > >
                                            > > http://www.mail-archive.com/vim-latex-devel@.../msg00093.html
                                            >
                                            > Aha! I found the error message, too! Line 43 of compiler.vim. Looks like setting
                                            > that variable to blank would *cause* the error!
                                            >
                                            > It seems the previous bugfix was slightly buggy, too! This may be more robust:
                                            >
                                            > let Tex_ViewRuleComplete_pdf = '/usr/bin/open -a Preview $*.pdf'
                                            >
                                            > or such. Interesting. It will be fun getting my hands on some Tex stuff at some
                                            > stage. One day...
                                            >
                                            >
                                            >
                                            > Ben.
                                            >
                                            >
                                            >
                                            >
                                            > >
                                            >

                                            --~--~---------~--~----~------------~-------~--~----~
                                            You received this message from the "vim_mac" maillist.
                                            For more information, visit http://www.vim.org/maillist.php
                                            -~----------~----~----~----~------~----~------~--~---
                                          • Alan
                                            Thanks for your post, it helps a lot. By the way, I still cannot open my pdf file until I found out it was corrupt. At last, I tried a utility called Advanced
                                            Message 21 of 21 , Apr 22, 2008
                                            • 0 Attachment
                                              Thanks for your post, it helps a lot. By the way, I still cannot open
                                              my pdf file until I found out it was corrupt. At last, I tried a
                                              utility called Advanced PDF Repair to repair my PDF file. It works
                                              rather well. Its web address is http://www.datanumen.com/apdfr/ Hope
                                              this will help, too.

                                              Alan


                                              On Apr 4, 11:56 pm, "Kristian Niemi" <kristian.ni...@...> wrote:
                                              > Aaaah! The sweet view Vim without anerrorin my face!
                                              >
                                              > The following (in .vimrc) did *not* work:
                                              > let g:Tex_ViewRule_pdf = '/usr/bin/open-a Preview $*.pdf'
                                              > let Tex_ViewRule_pdf = '/usr/bin/open-a Preview $*.pdf'
                                              > let g:Tex_ViewRule_pdf = '/usr/bin/open-a Preview'
                                              > let g:Tex_ViewRule_pdf = ''
                                              >
                                              > This *did* work:
                                              > let Tex_ViewRuleComplete_pdf = '/usr/bin/open-a Preview $*.pdf'
                                              >
                                              > Thanks for all of your efforts and ideas!
                                              >
                                              > /Kristian
                                              >
                                              > On Fri, Apr 4, 2008 at 1:45 PM, Ben Schmidt
                                              >
                                              >
                                              >
                                              > <mail_ben_schm...@...> wrote:
                                              >
                                              > >  Ben Schmidt wrote:
                                              > >  > Kristian Niemi wrote:
                                              > >  >> Hi,
                                              >
                                              > >  >> Thanks for chiming in!
                                              >
                                              > >  >> I downloaded latex-suite from their website [1] (it's version 20060325).
                                              > >  >> MacVim from [2] (snapshot 24).
                                              >
                                              > >  >> I'll give the svn version of latex-suite a twirl!
                                              >
                                              > >  >> Just for the heck of it, I'll put that exact line in my .vimrc,
                                              > >  >> although I already have a line there (and in the location theerror
                                              > >  >> message suggests) which should be equivalent. And, as has been
                                              > >  >> previously stated, the variable _is_ set. It's like MacVim just
                                              > >  >> doesn't like the answer. ;-) Maybe including a target ($*.pdf) in the
                                              > >  >> command, that the var consists of, makes it happier. Who knows.
                                              >
                                              > >  >> Thanks for your help!
                                              >
                                              > >  >> /Kristian
                                              >
                                              > >  > Odd. That's the version of latex-suite I downloaded too. Maybe I'm doing something
                                              > >  > wrong! This link seems to offer another more reliable solution...
                                              >
                                              > >  > http://www.mail-archive.com/vim-latex-de...@.../msg00093.html
                                              >
                                              > >  Aha! I found theerrormessage, too! Line 43 of compiler.vim. Looks like setting
                                              > >  that variable to blank would *cause* theerror!
                                              >
                                              > >  It seems the previous bugfix was slightly buggy, too! This may be more robust:
                                              >
                                              > >  let Tex_ViewRuleComplete_pdf = '/usr/bin/open-a Preview $*.pdf'
                                              >
                                              > >  or such. Interesting. It will be fun getting my hands on some Tex stuff at some
                                              > >  stage. One day...
                                              >
                                              > >  Ben.- Hide quoted text -
                                              >
                                              > - Show quoted text -
                                              --~--~---------~--~----~------------~-------~--~----~
                                              You received this message from the "vim_mac" maillist.
                                              For more information, visit http://www.vim.org/maillist.php
                                              -~----------~----~----~----~------~----~------~--~---
                                            Your message has been successfully submitted and would be delivered to recipients shortly.