Loading ...
Sorry, an error occurred while loading the content.

Re: vim for Jaguar

Expand Messages
  • David Johnston
    ... I just ran into this problem this morning. Commenting out the set fileformats+=mac line in the system vimrc file fixes it for me. ... david -- David
    Message 1 of 5 , Sep 7 7:02 PM
    • 0 Attachment
      On Sat, Sep 07, 2002 at 09:50:02PM -0400, Benji Fisher wrote:
      >
      > OK, this is the second report I have received. The first time, it
      > was suggested (and I accepted) that the culprit was the "set ffs+=mac"
      > that I added to the system vimrc file. Now, I tried this with my copy
      > of vim (6.1.141 on OSX 10.1.5) and loaded $VIMRUNTIME/filetype.vim
      > (certainly with Unix-style line endings) without any problem. Can
      > anyone diagnose this problem? I can think of three things that might
      > affect this, perhaps in combination:
      >
      > 1. the vim binary for OSX 10.2
      >
      > 2. the 'fileformats' ('ffs') option

      I just ran into this problem this morning.

      Commenting out the 'set fileformats+=mac' line in the system vimrc file
      fixes it for me.

      > 3. the particular files being edited, if they have some strange
      > combination of <CR> and <NL> characters.

      david

      --
      David Johnston
      Email: david@...
    • Benji Fisher
      ... Does it happen with every file having unix-style line endings? If, for example, you have a problem with one of the files in the vim distribution, it will
      Message 2 of 5 , Sep 7 7:45 PM
      • 0 Attachment
        On Saturday, September 7, 2002, at 10:02 PM, David Johnston wrote:

        > On Sat, Sep 07, 2002 at 09:50:02PM -0400, Benji Fisher wrote:
        >>
        >> OK, this is the second report I have received. The first time,
        >> it
        >> was suggested (and I accepted) that the culprit was the "set ffs+=mac"
        >> that I added to the system vimrc file. Now, I tried this with my copy
        >> of vim (6.1.141 on OSX 10.1.5) and loaded $VIMRUNTIME/filetype.vim
        >> (certainly with Unix-style line endings) without any problem. Can
        >> anyone diagnose this problem? I can think of three things that might
        >> affect this, perhaps in combination:
        >>
        >> 1. the vim binary for OSX 10.2
        >>
        >> 2. the 'fileformats' ('ffs') option
        >
        > I just ran into this problem this morning.
        >
        > Commenting out the 'set fileformats+=mac' line in the system vimrc file
        > fixes it for me.
        >
        >> 3. the particular files being edited, if they have some strange
        >> combination of <CR> and <NL> characters.

        Does it happen with every file having unix-style line endings? If,
        for example, you have a problem with one of the files in the vim
        distribution, it will make the problem easier to reproduce. Since that
        line is not in the old system vimrc file, I assume you are using 10.2.

        Thanks for the help.

        --Benji Fisher
      • David Johnston
        ... Yes - including my .vimrc file :-) I created a few test files with the version of vi which ships with 10.2, and the problem happened with them as well. I
        Message 3 of 5 , Sep 7 8:16 PM
        • 0 Attachment
          On Sat, Sep 07, 2002 at 10:45:13PM -0400, Benji Fisher wrote:
          > On Saturday, September 7, 2002, at 10:02 PM, David Johnston wrote:
          >
          > Does it happen with every file having unix-style line endings?

          Yes - including my .vimrc file :-)

          I created a few test files with the version of vi which ships with 10.2,
          and the problem happened with them as well. I verified (on another unix box)
          that there weren't any strange characters in the files.

          > If,
          > for example, you have a problem with one of the files in the vim
          > distribution, it will make the problem easier to reproduce. Since that
          > line is not in the old system vimrc file, I assume you are using 10.2.

          Yep (I should have said). I upgraded to 10.2 yesterday.

          david

          --
          David Johnston
          Email: david@...
        • Benji Fisher
          ... OK, this seems to be a problem involving with (1) the binary of vim compiled for OSX 10.2 (2) any file with unix-style line endings (3) the ffs option
          Message 4 of 5 , Sep 8 11:46 AM
          • 0 Attachment
            On Saturday, September 7, 2002, at 11:16 PM, David Johnston wrote:

            > On Sat, Sep 07, 2002 at 10:45:13PM -0400, Benji Fisher wrote:
            >> On Saturday, September 7, 2002, at 10:02 PM, David Johnston wrote:
            >>
            >> Does it happen with every file having unix-style line endings?
            >
            > Yes - including my .vimrc file :-)
            >
            > I created a few test files with the version of vi which ships with 10.2,
            > and the problem happened with them as well. I verified (on another unix
            > box)
            > that there weren't any strange characters in the files.
            >
            >> If,
            >> for example, you have a problem with one of the files in the vim
            >> distribution, it will make the problem easier to reproduce. Since that
            >> line is not in the old system vimrc file, I assume you are using 10.2.
            >
            > Yep (I should have said). I upgraded to 10.2 yesterday.

            OK, this seems to be a problem involving with

            (1) the binary of vim compiled for OSX 10.2

            (2) any file with unix-style line endings

            (3) the 'ffs' option contains "mac".

            I'll add a note to the bugs list now, and I will (when I get to it)
            remove the "set ffs+=mac" line from the system vimrc file packaged with
            the Jaguar binary.

            --Benji Fisher
          Your message has been successfully submitted and would be delivered to recipients shortly.