Loading ...
Sorry, an error occurred while loading the content.

Re: Vim on Jag

Expand Messages
  • Paul Tomblin
    ... These files come from a project where the development is being (mostly) done on Linux and Windows. There particular files are from Linux, so they have a
    Message 1 of 3 , Aug 25, 2002
    View Source
    • 0 Attachment
      Quoting Benji Fisher (benji@...):
      > Paul Tomblin wrote:
      > > from a Linux box), I get one long line with a bunch of ^Js in it where
      > > the line breaks should be. Doing the old :%s/^V^M/^V^M/g fixes it, of
      > > course, but I don't want to have to do that every time. It appears the
      > > problem is in the vimrc he provides - I comment out the "set
      > > fileformats+=mac", and it works fine.
      >
      > The change to the vimrc file is my fault. This is supposed to make it more
      > convenient to edit files with (old) mac-style line endings. Did these files
      > have DOS-style line endings? Does anyone have an "ideal" setting for the
      > 'fileformats' option? If ":set ffs+=mac" causes as many problems as it solves,

      These files come from a project where the development is being (mostly)
      done on Linux and Windows. There particular files are from Linux, so they
      have a \n line ending.


      --
      Paul Tomblin <ptomblin@...>, not speaking for anybody
      "I think there is a world market for maybe five computers."
      --Thomas Watson, chairman of IBM, 1943.
    • Gregory Seidman
      Benji Fisher sez: [...] } The change to the vimrc file is my fault. This is supposed to make it } more convenient to edit files with (old) mac-style line
      Message 2 of 3 , Aug 25, 2002
      View Source
      • 0 Attachment
        Benji Fisher sez: [...]
        } The change to the vimrc file is my fault. This is supposed to make it
        } more convenient to edit files with (old) mac-style line endings. Did
        } these files have DOS-style line endings? Does anyone have an "ideal"
        } setting for the 'fileformats' option? If ":set ffs+=mac" causes as many
        } problems as it solves, I will not include it in future vimrc files.

        One of the first things I did upon installing vim/macvim is to change the
        line in the vimrc to set fileformats=unix,mac,dos and it has been working
        just fine for my purposes. I don't know if it's ideal, but I haven't had
        line-ending problems with anything. As a matter of fact, I set fileformats
        the same on every system on which I use vim. There is no reason why it
        shouldn't recognize any of the three line-ending schemes, and since the
        first in the list is what new files use by default, I choose unix.

        } --Benji Fisher
        --Greg
      Your message has been successfully submitted and would be delivered to recipients shortly.