Loading ...
Sorry, an error occurred while loading the content.

cross one off the macvim voiceover bugs list

Expand Messages
  • yvonne thomson
    Hi all As a matter of interest, if anyone was keeping track of these things, one of the Voiceover macvim bugs in the list I came up with, well, isn t. the
    Message 1 of 3 , Mar 1, 2008
    • 0 Attachment
      Hi all

      As a matter of interest, if anyone was keeping track of these things,
      one of
      the Voiceover macvim bugs in the list I came up with, well, isn't.

      the problem I was having was that, in anything other than insert mode,
      when
      arrowing to the end of the line I couldn't hear the last character on
      that
      line.

      The thing is, this happens on console Vim as well, both the version that
      comes with OS X Leopard, and the version that comes with the latest
      Ubuntu, which was
      all I have easy access to.

      I guess now the only question I can't answer is, is this a Voiceover
      bug,
      ornot? I don't have easy access to another screen reader at the moment
      to test
      this, so I'll have to forget that unless I can recruit another blind bug
      tester, <grin>.

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Nico Weber
      Hi, ... That s intentional vim behaviour. If you put set virtualedit+=onemore in your _vimrc, it works. By the way, when you hit ⌘F5 in a MacVim window to
      Message 2 of 3 , Mar 2, 2008
      • 0 Attachment
        Hi,

        > the problem I was having was that, in anything other than insert mode,
        > when
        > arrowing to the end of the line I couldn't hear the last character on
        > that
        > line.
        >
        > The thing is, this happens on console Vim as well, both the version
        > that
        > comes with OS X Leopard, and the version that comes with the latest
        > Ubuntu, which was
        > all I have easy access to.
        >
        > I guess now the only question I can't answer is, is this a Voiceover
        > bug,
        > ornot?

        That's intentional vim behaviour. If you put

        set virtualedit+=onemore

        in your _vimrc, it works.

        By the way, when you hit ⌘F5 in a MacVim window to turn on Voiceover
        and wait, the reading gets strange after the title of the current
        window has been read (it enters some strange loop). Is this a known
        bug? Why does this happen?

        Nico


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • yvonne thomson
        ... Life is always a bit strange affter you first enter Voiceover. Admittedly, it s not something that happens to me often, because I m always running it,
        Message 3 of 3 , Mar 2, 2008
        • 0 Attachment
          On 02/03/2008, at 9:14 PM, Nico Weber wrote:

          >
          > Hi,
          >
          >> the problem I was having was that, in anything other than insert
          >> mode,
          >> when
          >> arrowing to the end of the line I couldn't hear the last character on
          >> that
          >> line.
          >>
          >> The thing is, this happens on console Vim as well, both the version
          >> that
          >> comes with OS X Leopard, and the version that comes with the latest
          >> Ubuntu, which was
          >> all I have easy access to.
          >>
          >> I guess now the only question I can't answer is, is this a Voiceover
          >> bug,
          >> ornot?
          >
          > That's intentional vim behaviour. If you put
          >
          > set virtualedit+=onemore
          >> in your _vimrc, it works.

          > Wow, you're completely right. I could have sworn I tried that at
          > some point in my testing, but I must have messed up the command
          > somehow. This will make my life a bit easier, I think, <grin>.


          >
          >
          > By the way, when you hit ⌘F5 in a MacVim window to turn on Voiceover
          > and wait, the reading gets strange after the title of the current
          > window has been read (it enters some strange loop). Is this a known
          > bug? Why does this happen?
          Life is always a bit strange affter you first enter Voiceover.
          Admittedly, it's not something that happens to me often, because I'm
          always running it, <grin>. I think it tries to read the whole window,
          or something like that. Just hit the control key as soon as it starts
          babbling, and it shuts up. Trust me on this, the first thing any
          speech user learns is how to make the computer *stop* talking.
          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.