Loading ...
Sorry, an error occurred while loading the content.
 

transparency not working in gvimrc

Expand Messages
  • dv1445@wayne.edu
    Hello all, Setting up transparency works real nicely when I do it by hitting colon. When I put something like set transparency=10 in my .gvimrc, it doesn t
    Message 1 of 8 , Feb 3, 2008
      Hello all,

      Setting up transparency works real nicely when I do it by hitting colon. When I put something like "set transparency=10" in my .gvimrc, it doesn't get picked up by MacVim. I am, however, able to then set this manually once the window opens.

      Am I doing something wrong? I tried moving the "set" line to different spots in my .gvimrc, including the beginning and very end.

      Thanks!
      -GMN


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Nico Weber
      Hi, ... it works just fine over here. Can you try to rename your .vimrc and .gvimrc and use a gvimrc with only `set transparency=10`? If that doesn t work,
      Message 2 of 8 , Feb 4, 2008
        Hi,

        > Setting up transparency works real nicely when I do it by hitting
        > colon. When I put something like "set transparency=10" in
        > my .gvimrc, it doesn't get picked up by MacVim. I am, however, able
        > to then set this manually once the window opens.

        it works just fine over here. Can you try to rename your .vimrc
        and .gvimrc and use a gvimrc with only `set transparency=10`? If that
        doesn't work, does it work if you do `:source ~/.gvimrc` later? Are
        you using the latest version?

        Nico

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • dv1445@wayne.edu
        ... Yep, I m using a version built from git about two days ago. I did the experiments you suggested, and found that: 1. With the fresh .gvimrc that has only
        Message 3 of 8 , Feb 4, 2008
          Thus spake Nico Weber [02/04/08 @ 15.05.35 +0100]:
          > > Setting up transparency works real nicely when I do it by hitting
          > > colon. When I put something like "set transparency=10" in
          > > my .gvimrc, it doesn't get picked up by MacVim. I am, however, able
          > > to then set this manually once the window opens.
          >
          > it works just fine over here. Can you try to rename your .vimrc
          > and .gvimrc and use a gvimrc with only `set transparency=10`? If that
          > doesn't work, does it work if you do `:source ~/.gvimrc` later? Are
          > you using the latest version?

          Yep, I'm using a version built from git about two days ago. I did the experiments you suggested, and found that:

          1. With the fresh .gvimrc that has only the transparency command, it works.
          2. With my normal .gvimrc, if I say `:source ~/.gvimrc', then no transparency happens *until* I then do `:e foo.txt'; when foo.txt is opened, transparency magically appears. Nothing special about foo.txt, the same thing happens when I do `:E' to get the file explorer.

          So a manual source of the .gvimrc file results in delayed transparency.
          -GMN

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Nico Weber
          ... Can you try to uncomment parts of your normal .gvimrc and see what part needs to be uncommented to make it work? Do you have autocommands in there? ...
          Message 4 of 8 , Feb 4, 2008
            > Yep, I'm using a version built from git about two days ago. I did
            > the experiments you suggested, and found that:
            >
            > 1. With the fresh .gvimrc that has only the transparency command, it
            > works.

            Can you try to uncomment parts of your normal .gvimrc and see what
            part needs to be uncommented to make it work? Do you have autocommands
            in there?

            > 2. With my normal .gvimrc, if I say `:source ~/.gvimrc', then no
            > transparency happens *until* I then do `:e foo.txt'; when foo.txt is
            > opened, transparency magically appears. Nothing special about
            > foo.txt, the same thing happens when I do `:E' to get the file
            > explorer.

            Weird.

            Nico

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • dv1445@wayne.edu
            ... Transparency in the .gvimrc works great with only that line commented out. -GMN --~--~---------~--~----~------------~-------~--~----~ You received this
            Message 5 of 8 , Feb 4, 2008
              Thus spake Nico Weber [02/04/08 @ 15.51.30 +0100]:
              >
              > > Yep, I'm using a version built from git about two days ago. I did
              > > the experiments you suggested, and found that:
              > >
              > > 1. With the fresh .gvimrc that has only the transparency command, it
              > > works.
              >
              > Can you try to uncomment parts of your normal .gvimrc and see what
              > part needs to be uncommented to make it work? Do you have autocommands
              > in there?

              I do have an autocmd, but it wasn't the culprit. The culprit was:

              :set nocompatible

              Transparency in the .gvimrc works great with only that line commented out.

              -GMN


              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Nico Weber
              ... This is probably by design. From `:h nocompatible `: This is a special kind of option, because when it s set or reset, other options are also changed as a
              Message 6 of 8 , Feb 4, 2008
                > I do have an autocmd, but it wasn't the culprit. The culprit was:
                >
                > :set nocompatible
                >
                > Transparency in the .gvimrc works great with only that line
                > commented out.


                This is probably by design. From `:h 'nocompatible'`:

                This is a special kind of option, because when it's set or reset,
                other options are also changed as a side effect. CAREFUL: Setting or
                resetting this option can have a lot of unexpected effects: Mappings
                are interpreted in another way, undo behaves differently, etc. If you
                set this option in your vimrc file, you should probably put it at the
                very start.

                Indeed, if you do

                :set transparency=30
                :set ncompatible
                ⌘-t
                ⌘-{

                , you end up with a non-transparent tabpage, so 'transparency' is
                reset by setting nocompatible. However, MacVim gets a bit confused by
                that, and it keeps some lines transparent and some opaque after that
                (which is a bug. Not a very serious one, but… ;-) ).

                Nico

                unrelated ps: After I `:wq`d this message in MacVim, it appeared
                quoted in Mail. Looks like a bug in the inputmanager code…I'll see if
                I can reproduce it.
                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • Nico Weber
                ... If you edit a mail message that has as its first character in MacVim via the InputManager and then :wq it, Mail.app adds one quote level to it. Is this
                Message 7 of 8 , Feb 4, 2008
                  > unrelated ps: After I `:wq`d this message in MacVim, it appeared
                  > quoted in Mail. Looks like a bug in the inputmanager code…I'll see if
                  > I can reproduce it.

                  If you edit a mail message that has '>' as its first character in
                  MacVim via the InputManager and then :wq it, Mail.app adds one quote
                  level to it. Is this a MacVim, Mail or InputManager problem?

                  Nico


                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_mac" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • björn
                  ... Sounds like Mail would be the culprit, but that is just a guess... /Björn --~--~---------~--~----~------------~-------~--~----~ You received this message
                  Message 8 of 8 , Feb 4, 2008
                    On 04/02/2008, Nico Weber <nicolasweber@...> wrote:
                    >
                    > > unrelated ps: After I `:wq`d this message in MacVim, it appeared
                    > > quoted in Mail. Looks like a bug in the inputmanager code…I'll see if
                    > > I can reproduce it.
                    >
                    > If you edit a mail message that has '>' as its first character in
                    > MacVim via the InputManager and then :wq it, Mail.app adds one quote
                    > level to it. Is this a MacVim, Mail or InputManager problem?

                    Sounds like Mail would be the culprit, but that is just a guess...

                    /Björn

                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_mac" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  Your message has been successfully submitted and would be delivered to recipients shortly.