Loading ...
Sorry, an error occurred while loading the content.

Re: Building MacVim.app on Leopard with Language Support

Expand Messages
  • Austin Ziegler
    ... That does. I may dig into what s required to provide a Leopard-only build since there are four architectures to deal with there. Has someone filed a bug
    Message 1 of 4 , Jan 16, 2008
    • 0 Attachment
      On Jan 15, 10:51 pm, Jason Foreman <ja...@...> wrote:
      > This might help you:
      > http://groups.google.com/group/vim_mac/browse_thread/thread/064da55ec412e768

      That does. I may dig into what's required to provide a Leopard-only
      build since there are four architectures to deal with there.

      Has someone filed a bug with Apple about this?

      -austin

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Kazuki Sakamoto
      Hi, ... If you want to run it on both Intel- and PowerPC-based Mac (build for universal binary), ... you need rebuild libiconv and perl5 for universal binary
      Message 2 of 4 , Jan 16, 2008
      • 0 Attachment
        Hi,

        On Jan 16, 2008 12:25 PM, Austin Ziegler <halostatue@...> wrote:
        > What do I need to do to get this to work?

        If you want to run it on both Intel- and PowerPC-based Mac (build for
        universal binary),

        > ld: warning in /opt/local/lib/libiconv.dylib, file is not of required
        > architecture
        > ld: warning in /opt/local/lib/perl5/5.8.8/darwin-2level/auto/
        > DynaLoader/DynaLoader.a, file is not of required architecture

        you need rebuild libiconv and perl5 for universal binary in your /opt/local.
        If you used MacPorts, try '+universal' option with 'port install'.

        And check src/auto/config.mk after 'configure'.

        > ld: warning in objects/version.o, file is not of required architecture

        This warning occurred in this situation.
        CFLAGS has '-arch i386' only.
        LDFLAGS has '-arch i386 -arch ppc'

        Add '-arch ppc' to CFLAGS.


        If you don't want to run it on both Intel- and PowerPC-based Mac,
        just remove '--with-mac-arch=both' option from 'configure' options.

        sakamoto

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.