Loading ...
Sorry, an error occurred while loading the content.

changing system keyboard layout on insert mode

Expand Messages
  • Dmitry Zubov
    Hello, I ve got an annoying problem. When entering insert mode with i button, my system keyboard layout changes to opposite (Russian). Can t even imagine
    Message 1 of 3 , Jan 5, 2008
    • 0 Attachment
      Hello, I've got an annoying problem. When entering insert mode with
      "i" button, my system keyboard layout changes to opposite (Russian).
      Can't even imagine what can be done with this.

      My .vimrc is:
      set si expandtab tabstop=4 shiftwidth=4 nu backspace=indent,eol,start

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Dmitry Zubov
      Actually, I said imi=0 and this solves the problem. --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_mac
      Message 2 of 3 , Jan 5, 2008
      • 0 Attachment
        Actually, I said imi=0 and this solves the problem.
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • björn
        ... You might want to :set imd instead to disable input mode switches completely, otherwise the input mode will switch when you hit / . I ve noticed that
        Message 3 of 3 , Jan 5, 2008
        • 0 Attachment
          On 05/01/2008, Dmitry Zubov <Dmitry.Zubov@...> wrote:
          >
          > Actually, I said imi=0 and this solves the problem.

          You might want to ":set imd" instead to disable input mode switches
          completely, otherwise the input mode will switch when you hit "/".

          I've noticed that many people are surprised by 'imd' being disabled by
          default. Maybe I should set it to be enabled by default so that
          people who want the input manager to switch when going between modes
          need to add "set noimd" to their .gvimrc. Any comments?

          /Björn

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.