Loading ...
Sorry, an error occurred while loading the content.

Compiling from source fails on OS X 10.5.1

Expand Messages
  • Jason
    Running make gives me the following error when I try to build Vim 7.1 from source on Leopard with GUI enabled. $ ./configure --prefix=/usr/local --enable-gui
    Message 1 of 5 , Dec 1, 2007
    • 0 Attachment
      Running make gives me the following error when I try to build Vim 7.1
      from source on Leopard with GUI enabled.

      $ ./configure --prefix=/usr/local --enable-gui --enable-multibyte --
      enable-rubyinterp --enable-pythoninterp
      $ make

      os_unix.c: In function 'init_signal_stack':
      os_unix.c:759: warning: 'struct sigaltstack' declared inside parameter
      list
      os_unix.c:759: warning: its scope is only this definition or
      declaration, which is probably not what you want
      os_unix.c:759: error: conflicting types for 'sigaltstack'
      /usr/include/signal.h:89: error: previous declaration of 'sigaltstack'
      was here
      os_unix.c:769: warning: passing argument 1 of 'sigaltstack' from
      incompatible pointer type
      make: *** [objects/os_unix.o] Error 1

      In order to get this far, I had to make the patch to src/configure.in
      and src/auto/configure that was suggested in the thread "./configure --
      disable-darwin fails on Leopard." Any help with this problem would be
      much appreciated!
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Matt Tolton
      Try --enable-gui=macvim. ... --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_mac maillist. For more information,
      Message 2 of 5 , Dec 1, 2007
      • 0 Attachment
        Try --enable-gui=macvim.

        On 12/1/07, Jason <widmannm@...> wrote:
        >
        > Running make gives me the following error when I try to build Vim 7.1
        > from source on Leopard with GUI enabled.
        >
        > $ ./configure --prefix=/usr/local --enable-gui --enable-multibyte --
        > enable-rubyinterp --enable-pythoninterp
        > $ make
        >
        > os_unix.c: In function 'init_signal_stack':
        > os_unix.c:759: warning: 'struct sigaltstack' declared inside parameter
        > list
        > os_unix.c:759: warning: its scope is only this definition or
        > declaration, which is probably not what you want
        > os_unix.c:759: error: conflicting types for 'sigaltstack'
        > /usr/include/signal.h:89: error: previous declaration of 'sigaltstack'
        > was here
        > os_unix.c:769: warning: passing argument 1 of 'sigaltstack' from
        > incompatible pointer type
        > make: *** [objects/os_unix.o] Error 1
        >
        > In order to get this far, I had to make the patch to src/configure.in
        > and src/auto/configure that was suggested in the thread "./configure --
        > disable-darwin fails on Leopard." Any help with this problem would be
        > much appreciated!
        > >
        >

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Nico Weber
        Hi, ... I can build the latest vim svn version just fine on os x 10.5.1, without any patches. I use your configure flags, albeit without ruby support. Does it
        Message 3 of 5 , Dec 1, 2007
        • 0 Attachment
          Hi,

          > $ ./configure --prefix=/usr/local --enable-gui --enable-multibyte --
          > enable-rubyinterp --enable-pythoninterp
          > $ make
          >
          > os_unix.c: In function 'init_signal_stack':
          > os_unix.c:759: warning: 'struct sigaltstack' declared inside parameter
          > list
          > os_unix.c:759: warning: its scope is only this definition or
          > declaration, which is probably not what you want
          > os_unix.c:759: error: conflicting types for 'sigaltstack'
          > /usr/include/signal.h:89: error: previous declaration of 'sigaltstack'
          > was here
          > os_unix.c:769: warning: passing argument 1 of 'sigaltstack' from
          > incompatible pointer type
          > make: *** [objects/os_unix.o] Error 1
          >
          > In order to get this far, I had to make the patch to src/configure.in
          > and src/auto/configure that was suggested in the thread "./configure
          > --
          > disable-darwin fails on Leopard." Any help with this problem would be
          > much appreciated!

          I can build the latest vim svn version just fine on os x 10.5.1,
          without any patches. I use your configure flags, albeit without ruby
          support. Does it help if you remove the ruby interpreter?

          Nico


          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • ashres@gmail.com
          I believe in a prior post dated August 14 (http://groups.google.com/ group/vim_mac/browse_thread/thread/b899302fce76c54f/91694556446644e1?
          Message 4 of 5 , Dec 9, 2007
          • 0 Attachment
            I believe in a prior post dated August 14 (http://groups.google.com/
            group/vim_mac/browse_thread/thread/b899302fce76c54f/91694556446644e1?
            lnk=gst&q=ruby#91694556446644e1)
            Bjorn stated that he had issues compiling in Ruby as a universal
            binary. I would *love* for Ruby to be compiled into MacVim, but
            unfortunately, I don't think that Bjorn (or anyone else) has figured
            out how to get it to work. :( Hoping this gets resolved soon. :)

            ashres

            /loves MacVim
            //Thanks, Bjorn!
            ///first time poster

            On Dec 1, 4:46 pm, Nico Weber <nicolaswe...@...> wrote:
            > Hi,
            >
            >
            >
            > > $ ./configure --prefix=/usr/local --enable-gui --enable-multibyte --
            > > enable-rubyinterp --enable-pythoninterp
            > > $ make
            >
            > > os_unix.c: In function 'init_signal_stack':
            > > os_unix.c:759: warning: 'struct sigaltstack' declared inside parameter
            > > list
            > > os_unix.c:759: warning: its scope is only this definition or
            > > declaration, which is probably not what you want
            > > os_unix.c:759: error: conflicting types for 'sigaltstack'
            > > /usr/include/signal.h:89: error: previous declaration of 'sigaltstack'
            > > was here
            > > os_unix.c:769: warning: passing argument 1 of 'sigaltstack' from
            > > incompatible pointer type
            > > make: *** [objects/os_unix.o] Error 1
            >
            > > In order to get this far, I had to make the patch to src/configure.in
            > > and src/auto/configure that was suggested in the thread "./configure
            > > --
            > > disable-darwin fails on Leopard." Any help with this problem would be
            > > much appreciated!
            >
            > I can build the latest vim svn version just fine on os x 10.5.1,
            > without any patches. I use your configure flags, albeit withoutruby
            > support. Does it help if you remove therubyinterpreter?
            >
            > Nico
            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • björn
            ... I would suggest you compile your own binary with ruby support because I doubt I ll find a way around this. Just follow the instructions on
            Message 5 of 5 , Dec 11, 2007
            • 0 Attachment
              On 10/12/2007, ashres@... <ashres@...> wrote:
              >
              > I believe in a prior post dated August 14 (http://groups.google.com/
              > group/vim_mac/browse_thread/thread/b899302fce76c54f/91694556446644e1?
              > lnk=gst&q=ruby#91694556446644e1)
              > Bjorn stated that he had issues compiling in Ruby as a universal
              > binary. I would *love* for Ruby to be compiled into MacVim, but
              > unfortunately, I don't think that Bjorn (or anyone else) has figured
              > out how to get it to work. :( Hoping this gets resolved soon. :)

              I would suggest you compile your own binary with ruby support because
              I doubt I'll find a way around this. Just follow the instructions on

              http://code.google.com/p/macvim/wiki/Building

              and make sure you add --enable-rubyinterp when you call ./configure.
              If you need more help just let us know.


              Good luck,
              Björn

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            Your message has been successfully submitted and would be delivered to recipients shortly.