Loading ...
Sorry, an error occurred while loading the content.

build fails with --enable-perlinterp on 10.5.1

Expand Messages
  • Daniel Hyde
    Hi there, Just moved to 10.5.1 (on intel) and am putting my dev environment back together, a big part of which is vim with perl compiled in. I m finding that
    Message 1 of 2 , Nov 30, 2007
    • 0 Attachment
      Hi there,

      Just moved to 10.5.1 (on intel) and am putting my dev environment back
      together, a big part of which is vim with perl compiled in.

      I'm finding that adding --enable-perlinterp to the configure options
      causes the build to fail, where otherwise it would succeed. This is
      using the system's default perl installation ("This is perl, v5.8.8
      built for darwin-thread-multi-2level", quoth perl --version). I
      haven't yet tried installing a custom perl build and compiling vim
      against that, but I'd rather not have to.

      I've attached a tarball containing configure/build logs so you can see
      where this is failing. I'm not in any way intimate with vim's own
      source so I wouldn't know where to begin trying to fix this myself.

      The tarball contents are:

      vim71-buildlogs/vim71-configure-vanilla -- stdout and stderr
      output of ./configure (no extra options)
      vim71-buildlogs/vim71-configure-withperl -- stdout and stderr
      output of ./configure --enable-perlinterp
      vim71-buildlogs/vim71-make-vanilla -- stdout and stderr
      output of (successful) build with the vanilla configuration
      vim71-buildlogs/vim71-make-withperl -- stdout and stderr
      output of (failing) build with perlinterp enabled
      vim71-buildlogs/vim71-patches -- list of patches applied

      From the error output when compiling with perlinterp enabled, it looks
      like a header is being included that uses "bool" before this has been
      defined. Poking around in the system perl headers (under
      /System/Library/Perl/5.8.8/darwin-thread-multi-2level/CORE/), it looks
      like "handy.h" unconditionally brings in stdbool.h, so perhaps this
      needs to be included somewhere, I don't know.

      The build also fails in the same way when I disable the carbon gui,
      set the target architecture to intel, etc etc. Basically all the
      configurations I've tried so far without perlinterp have built
      successfully, and the same configurations with the addition of
      perlinterp have failed in the same way. Since the only reason I'm
      building my own vim is to enable the builtin perl interpreter, this is
      more than a little frustrating!

      Hoping someone can help

      Cheers,

      Daniel

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • daniel.hyde@gmail.com
      Hi again, I ve found that vim.h is undefining bool when IN_PERL_FILE and MACOS are defined, and this is causing auto/if_perl.c to fail to build. The very
      Message 2 of 2 , Nov 30, 2007
      • 0 Attachment
        Hi again,

        I've found that vim.h is undefining bool when IN_PERL_FILE and MACOS
        are defined, and this is causing auto/if_perl.c to fail to build. The
        very dirty patch below is enough to get it building, and perldo seems
        to work correctly in the resulting binary. It looks like the
        condition around the undef needs to take into account OS X 10.5, but
        I'm not sure what the correct way to test for this is.

        Cheers,

        Daniel

        --- vim.h.bak 2007-12-01 11:55:03.000000000 +1100
        +++ vim.h 2007-12-01 11:55:15.000000000 +1100
        @@ -1989,7 +1989,7 @@
        # endif
        /* bool causes trouble on MACOS but is required on a few other
        systems */
        # if defined(bool) && defined(MACOS)
        -# undef bool
        +//# undef bool
        # endif

        # ifdef __BORLANDC__

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.