Loading ...
Sorry, an error occurred while loading the content.

How do I avoid "Press RETURN" at launch?

Expand Messages
  • Seal, John J
    I ve read everything I can find on avoiding |hit-enter|, but I still have to do it when I double-click a file owned by Vim 6. (Interestingly, the message
    Message 1 of 3 , Mar 1, 2002
    • 0 Attachment
      I've read everything I can find on avoiding |hit-enter|, but I still have to
      do it when I double-click a file owned by Vim 6. (Interestingly, the message
      actually says "Press RETURN" instead of "Hit ENTER".) What I want is for Vim
      to launch and display the text when I double-click a file, without having to
      press Return first.

      The Windows version doesn't do this, and neither does the Mac version when
      you open a file after Vim is already running. Even when I remove all the *rc
      files and launch Vim "naked", it still wants me to press Return. Setting
      ch=2 and shm=a doesn't help.

      Is there a way to turn this off?

      John Seal, Principal Software Engineer | Raytheon (MS-44) O-
      mailto:sealj@... | 6125 East 21st Street
      phone:317-306-4838 fax:317-306-3583 | Indianapolis, IN 46219-2058
    • Sven Guckes
      ... sure.. ... mind you, the a flag means all of the *above* - but the description has some more flags *below*. So how about adding the t flag, ie :set
      Message 2 of 3 , Mar 2, 2002
      • 0 Attachment
        * Seal, John J <sealj@...> [020301 20:36]:
        > What I want is for Vim to launch and display the text when I
        > double-click a file, without having to press Return first.

        sure..

        > I've read everything I can find on avoiding |hit-enter|,
        > but I still have to do it when I double-click a file owned by Vim 6.
        > Setting ch=2 and shm=a doesn't help.

        mind you, the 'a' flag means "all of the *above*" -
        but the description has some more flags *below*.

        So how about adding the 't' flag, ie ":set shm=at"?

        t truncate file message at the start if it is too long to fit
        on the command-line, "<" will appear in the left most column.

        (I keep reading this as ":set schmatt". ;-)

        > (Interestingly, the message actually says
        > "Press RETURN" instead of "Hit ENTER".)

        Which version are you using again? Vim-6?
        I keep forgetting with all those users.. ;-)
        Mind you, there are different versions for Mac
        (and meanwhile I have lost interest
        in keeping up-to-date with them).

        Sven [still waiting for *the* VimMac for 68k]
      • Benji Fisher
        ... Nice idea, but it does not work for me. I just tried it on OS X (Carbon vim 6.0) and I recall having this problem on Os 8.x. It looks as though t is
        Message 3 of 3 , Mar 5, 2002
        • 0 Attachment
          On Saturday, March 2, 2002, at 04:41 AM, Sven Guckes wrote:

          > * Seal, John J <sealj@...> [020301 20:36]:
          >> What I want is for Vim to launch and display the text when I
          >> double-click a file, without having to press Return first.
          >
          > sure..
          >
          >> I've read everything I can find on avoiding |hit-enter|,
          >> but I still have to do it when I double-click a file owned by Vim 6.
          >> Setting ch=2 and shm=a doesn't help.
          >
          > mind you, the 'a' flag means "all of the *above*" -
          > but the description has some more flags *below*.
          >
          > So how about adding the 't' flag, ie ":set shm=at"?
          >
          > t truncate file message at the start if it is too long to fit
          > on the command-line, "<" will appear in the left most column.
          >
          > (I keep reading this as ":set schmatt". ;-)

          Nice idea, but it does not work for me. I just tried it on OS X
          (Carbon vim 6.0) and I recall having this problem on Os 8.x. It looks
          as though "t" is already part of the default for 'shm', I already have
          'ch' set to 2, and there is plenty of room for the message. It just
          feels like making me hit the <CR>. :-(

          >> (Interestingly, the message actually says
          >> "Press RETURN" instead of "Hit ENTER".

          I get "Hit Enter" on OS X.

          > Which version are you using again? Vim-6?
          > I keep forgetting with all those users.. ;-)
          > Mind you, there are different versions for Mac
          > (and meanwhile I have lost interest
          > in keeping up-to-date with them).
          >
          > Sven [still waiting for *the* VimMac for 68k]

          Good luck. ;)

          --Benji Fisher
        Your message has been successfully submitted and would be delivered to recipients shortly.