Loading ...
Sorry, an error occurred while loading the content.

Re: keymap problem, mapping '2' and '6' to Char

Expand Messages
  • Kenneth Beesley
    ... Nico, Thanks for your help. I m not using the :imap command. I m using vim keymap files, stored in the standard place: ~/.vim/keymap/ I define my own
    Message 1 of 2 , Oct 8, 2007
    • 0 Attachment
      On 8 Oct 2007, at 13:14, Nico Weber wrote:

      >
      > Forwarding this as well. How exactly are you setting up your keymaps?
      > I tried `:imap 2 a`, after that hitting 2 inserts an a in insert
      > mode. Which keyboard layout are you using?


      Nico,

      Thanks for your help.

      I'm not using the :imap command. I'm using vim keymap files, stored
      in the standard
      place: ~/.vim/keymap/

      I define my own keymap files, and the one in question right now is
      called deseret-sampa_utf-8.vim
      I'll gladly send you (or anyone else) a copy, but I'm reluctant to
      attach such a file for
      a message going to a distribution list

      After the usual header boilerplate, deseret-sampa_utf-8.vim contains
      lines like the following:


      o <Char-0x1042C>
      oW <Char-0x1042C>

      u <Char-0x1042D>
      I <Char-0x1042E>
      E <Char-0x1042F>

      a <Char-0x10430>
      ae <Char-0x10430>

      6 <Char-0x10431>
      2 <Char-0x10432>

      U <Char-0x10433>

      aJ <Char-0x10434>
      aY <Char-0x10434>

      aW <Char-0x10435>
      w <Char-0x10436>

      On the left-hand side are ASCII-range input sequences inspired by the
      SAMPA
      transliteration of the International Phonetic Alphabet. On the right-
      hand side are
      the code point values of the Deseret Alphabet characters (block
      starting U+10400)
      with the corresponding phoneme value.

      I select this keymap in vim in the usual way

      :set keymap=deseret_sampa_utf-8.vim

      and everything works as expected except for the lines having '6' and
      '2' on the left-hand side.
      When I type 2, for example, instead of a U+10432 character being
      entered and displayed, as
      expected, I see just '2' on the screen.

      Ken




      > It worked fine for me with
      > German and Canadian (like US, but other flag ;-) ) layouts.
      >
      > Nico
      >
      > Begin forwarded message:
      >
      >> From: Kenneth Beesley <krbeesley@...>
      >> Date: October 5, 2007 7:25:26 PM GMT+02:00
      >> To: vim_multibyte@...
      >> Subject: Re: keymap problem, mapping '2' and '6' to Char
      >> Reply-To: vim_multibyte@...
      >>
      >>
      >> Nico,
      >>
      >> Background: I'm running OS X version 10.4.10
      >>
      >> I just installed the latest MacVim and tried it with a version of
      >> DejaVuSansMono.ttf, augmented
      >> with (monowidth) glyphs, the same width as the original
      >> DejaVuSansMono.ttf glyphs,
      >> for the Deseret Alphabet block (U+10400). It doesn't seem to work
      >> for me. When I select my
      >> Deseret Alphabet keymap and try to type Deseret Alphabet, I see
      >> pseudo glyphs in boxes
      >> rendered on the screen.
      >>
      >> Yesterday I downloaded, via svn, 7.1.135 and got it compiled and
      >> running on OS X.
      >> I also got 7.1.135 running on Red Hat Linux. These seem to work
      >> better, for my Deseret
      >> Alphabet editing, than MacVim, using the augmented version of
      >> DejaVuSansMono.ttf.
      >> Not perfect yet, but better.
      >>
      >> I see the keymap problem (involving digits on the left-hand-side of
      >> mappings) on both
      >> platforms with 7.1.135, and with MacVim. I'm confused to see your
      >> report that it works
      >> for you in the latest version of MacVim.
      >>
      >> When using MacVim, it complained about setting 'macatsui' in
      >> my .gvimrc file. It also complained
      >> about setting 'nomacatsui'. So I took out both for the tests.
      >> Would you consider sharing your
      >> .gvimrc file--perhaps there's something in there that makes it work
      >> better with MacVim.
      >
      > As Tony said, MacVim doesn't have this option.
      >
      >>
      >> Ken
      >>
      >>
      >>
      >> On 5 Oct 2007, at 04:01, Nico Weber wrote:
      >>
      >>>
      >>>> I've got a vim keymap problem when trying to map digits to Char
      >>>>
      >>>> But if I have, in the same keymap, a digit on the left-hand-side,
      >>>> e.g.
      >>>>
      >>>> 6 <Char-0x10431>
      >>>> 2 <Char-0x10432>
      >>>>
      >>>> then it does NOT work. Rather the 2 or 6 is rendered on the screen
      >>>> literally,
      >>>> without mapping to the Unicode (Deseret Alphabet) code point.
      >>>>
      >>>> Bug? or am I doing something wrong?
      >>>
      >>> Probably a bug. Which version are you using? It works ok with the
      >>> latest version of MacVim and the terminal version that's
      >>> preinstalled
      >>> (both OS X).
      >>>
      >>> Nico
      >>>
      >>>
      >>>>
      >>
      >>
      >>
      >
      > >


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.