Loading ...
Sorry, an error occurred while loading the content.

Re: Correct way to set PATH for MacVim and Fink

Expand Messages
  • Adam Byrtek
    ... I ve looked into this, and I found out that system() does take into account my zshenv settings, so it was not the root of the problem. The real problem was
    Message 1 of 8 , Oct 6, 2007
    • 0 Attachment
      On 9/24/07, Tim Allen <thristian@...> wrote:
      > Technically, if system() is calling the libc system() function (and it
      > had better be!), it *is* invoking a subshell, just not one that reads
      > ~/.zshenv.

      I've looked into this, and I found out that system() does take into
      account my zshenv settings, so it was not the root of the problem. The
      real problem was with Vim's executable() function, that doesn't take
      into account PATH set by the subshell.

      I've made a simple fix to put into vimrc, that doesn't mess with Mac
      properties or shell wrappers. In case anybody is interested:

      let $PATH=$PATH.":/sw/bin"

      Regards,
      Adam

      --
      Adam Byrtek

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.