Loading ...
Sorry, an error occurred while loading the content.

Gvim sourcing .vimrc and not .gvimrc

Expand Messages
  • consiglieri
    Hi At one point I used Edit - Startup Settings and saved the file which turned out to be .vimrc. After that everytime I start vim it sources .vimrc instead of
    Message 1 of 10 , Sep 12, 2007
    • 0 Attachment
      Hi

      At one point I used Edit -> Startup Settings and saved the file which
      turned out to be .vimrc. After that everytime I start vim it
      sources .vimrc instead of .gvimrc.

      How can I make Vim.app use .gvimrc instead?

      Thanks


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Nico Weber
      ... Vim.app should always source .vimrc as well as .gvimrc...are you sure your .gvimrc is not sourced as well? Nico
      Message 2 of 10 , Sep 12, 2007
      • 0 Attachment
        > At one point I used Edit -> Startup Settings and saved the file which
        > turned out to be .vimrc. After that everytime I start vim it
        > sources .vimrc instead of .gvimrc.
        >
        > How can I make Vim.app use .gvimrc instead?

        Vim.app should always source .vimrc as well as .gvimrc...are you sure
        your .gvimrc is not sourced as well?

        Nico


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • consiglieri
        Hi Been doing some testing..and I was mistaken, Vim.app is parcing both .vimrc and .gvimrc However the ctrl+] kombination is not working as a shortcut for
        Message 3 of 10 , Sep 12, 2007
        • 0 Attachment
          Hi

          Been doing some testing..and I was mistaken, Vim.app is parcing
          both .vimrc and .gvimrc

          However the ctrl+] kombination is not working as a shortcut for
          searching tags.

          As I understand it I should be able to have the cursor on lets say
          JFrame in a java file and type ctrl-] and see the source code for
          JFrame. It works if I do :ta JFrame but not with the shortcut.



          On 12 Sep, 14:22, Nico Weber <nicolaswe...@...> wrote:
          > > At one point I used Edit -> Startup Settings and saved the file which
          > > turned out to be .vimrc. After that everytime I start vim it
          > > sources .vimrc instead of .gvimrc.
          >
          > > How can I make Vim.app use .gvimrc instead?
          >
          > Vim.app should always source .vimrc as well as .gvimrc...are you sure
          > your .gvimrc is not sourced as well?
          >
          > Nico


          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Nico Weber
          ... This probably only really works with an english keyboard layout. Are you using an english layout? --~--~---------~--~----~------------~-------~--~----~ You
          Message 4 of 10 , Sep 12, 2007
          • 0 Attachment
            > However the ctrl+] kombination is not working as a shortcut for
            > searching tags.
            >
            > As I understand it I should be able to have the cursor on lets say
            > JFrame in a java file and type ctrl-] and see the source code for
            > JFrame. It works if I do :ta JFrame but not with the shortcut.

            This probably only really works with an english keyboard layout. Are
            you using an english layout?


            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • consiglieri
            No I m not, I am fortunate enough to use a swedish keyboard. I could change the key mapping if I knew how. I m also having difficulties with umlauts in vim
            Message 5 of 10 , Sep 12, 2007
            • 0 Attachment
              No I'm not, I am fortunate enough to use a swedish keyboard. I could
              change the key mapping if I knew how.
              I'm also having difficulties with umlauts in vim when using terminal
              (in Vim.app .gvim, it works fine). Terminal is set to use utf-8 and so
              is the encoding in .vimrc. But my å ä ö fill out dubbelspaces. This
              only occurs when using vim and not when I am in terminal.


              On 12 Sep, 17:13, Nico Weber <nicolaswe...@...> wrote:
              > > However the ctrl+] kombination is not working as a shortcut for
              > > searching tags.
              >
              > > As I understand it I should be able to have the cursor on lets say
              > > JFrame in a java file and type ctrl-] and see the source code for
              > > JFrame. It works if I do :ta JFrame but not with the shortcut.
              >
              > This probably only really works with an english keyboard layout. Are
              > you using an english layout?


              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Niklas Lindström
              Hi, with a swedish keyboard, ctrl-] is ctrl-å, i.e. the same physical place of the ] character on an english qwerty. Try that, it works for me in carbon vim
              Message 6 of 10 , Sep 12, 2007
              • 0 Attachment
                Hi,

                with a swedish keyboard, ctrl-] is ctrl-å, i.e. the same physical
                place of the "]" character on an english qwerty. Try that, it works
                for me in carbon vim and MacVim.

                Best regards,
                Niklas


                On 9/12/07, consiglieri <apelsinen@...> wrote:
                >
                > No I'm not, I am fortunate enough to use a swedish keyboard. I could
                > change the key mapping if I knew how.
                > I'm also having difficulties with umlauts in vim when using terminal
                > (in Vim.app .gvim, it works fine). Terminal is set to use utf-8 and so
                > is the encoding in .vimrc. But my å ä ö fill out dubbelspaces. This
                > only occurs when using vim and not when I am in terminal.
                >
                >
                > On 12 Sep, 17:13, Nico Weber <nicolaswe...@...> wrote:
                > > > However the ctrl+] kombination is not working as a shortcut for
                > > > searching tags.
                > >
                > > > As I understand it I should be able to have the cursor on lets say
                > > > JFrame in a java file and type ctrl-] and see the source code for
                > > > JFrame. It works if I do :ta JFrame but not with the shortcut.
                > >
                > > This probably only really works with an english keyboard layout. Are
                > > you using an english layout?
                >
                >
                > >
                >

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • Nico Weber
                ... System Preferences - International - Input Menu. Select Show input menu in menu bar at the bottom and select Canadian (or US , depending on which
                Message 7 of 10 , Sep 12, 2007
                • 0 Attachment
                  > No I'm not, I am fortunate enough to use a swedish keyboard. I could
                  > change the key mapping if I knew how.

                  System Preferences -> International -> Input Menu. Select "Show input
                  menu in menu bar" at the bottom and select "Canadian" (or "US",
                  depending on which flag yo prefer :-P) in addition to the language
                  you've already selected.

                  > I'm also having difficulties with umlauts in vim when using terminal
                  > (in Vim.app .gvim, it works fine). Terminal is set to use utf-8 and so
                  > is the encoding in .vimrc. But my å ä ö fill out dubbelspaces. This
                  > only occurs when using vim and not when I am in terminal.

                  This is probably a Terminal issue. Did you tell it to use utf8 somehow?

                  Nico


                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_mac" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • consiglieri
                  Eureka.. that works for me. Thanks ... --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_mac maillist. For more
                  Message 8 of 10 , Sep 12, 2007
                  • 0 Attachment
                    Eureka.. that works for me.
                    Thanks

                    On 12 Sep, 22:35, "Niklas Lindström" <lindstr...@...> wrote:
                    > Hi,
                    >
                    > with a swedish keyboard, ctrl-] is ctrl-å, i.e. the same physical
                    > place of the "]" character on an english qwerty. Try that, it works
                    > for me in carbon vim and MacVim.
                    >
                    > Best regards,
                    > Niklas
                    >
                    > On 9/12/07, consiglieri <apelsi...@...> wrote:
                    >
                    >
                    >
                    > > No I'm not, I am fortunate enough to use a swedish keyboard. I could
                    > > change the key mapping if I knew how.
                    > > I'm also having difficulties with umlauts in vim when using terminal
                    > > (in Vim.app .gvim, it works fine). Terminal is set to use utf-8 and so
                    > > is the encoding in .vimrc. But my å ä ö fill out dubbelspaces. This
                    > > only occurs when using vim and not when I am in terminal.
                    >
                    > > On 12 Sep, 17:13, Nico Weber <nicolaswe...@...> wrote:
                    > > > > However the ctrl+] kombination is not working as a shortcut for
                    > > > > searching tags.
                    >
                    > > > > As I understand it I should be able to have the cursor on lets say
                    > > > > JFrame in a java file and type ctrl-] and see the source code for
                    > > > > JFrame. It works if I do :ta JFrame but not with the shortcut.
                    >
                    > > > This probably only really works with an english keyboard layout. Are
                    > > > you using an english layout?


                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_mac" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  • consiglieri
                    Terminal is set to utf-8, in fact terminal displays everything nicely, its only when console vim is started that there is a problem. ...
                    Message 9 of 10 , Sep 12, 2007
                    • 0 Attachment
                      Terminal is set to utf-8, in fact terminal displays everything nicely,
                      its only when console vim is started that there is a problem.


                      On 13 Sep, 01:57, Nico Weber <nicolaswe...@...> wrote:
                      > > No I'm not, I am fortunate enough to use a swedish keyboard. I could
                      > > change the key mapping if I knew how.
                      >
                      > System Preferences -> International -> Input Menu. Select "Show input
                      > menu in menu bar" at the bottom and select "Canadian" (or "US",
                      > depending on which flag yo prefer :-P) in addition to the language
                      > you've already selected.
                      >
                      > > I'm also having difficulties with umlauts in vim when using terminal
                      > > (in Vim.app .gvim, it works fine). Terminal is set to use utf-8 and so
                      > > is the encoding in .vimrc. But my å ä ö fill out dubbelspaces. This
                      > > only occurs when using vim and not when I am in terminal.
                      >
                      > This is probably a Terminal issue. Did you tell it to use utf8 somehow?
                      >
                      > Nico


                      --~--~---------~--~----~------------~-------~--~----~
                      You received this message from the "vim_mac" maillist.
                      For more information, visit http://www.vim.org/maillist.php
                      -~----------~----~----~----~------~----~------~--~---
                    • Ben Schmidt
                      ... Maybe try fiddling with the settings to do with wide glyphs and so on in the Terminal Window Settings, and/or Vim s ambiwidth option. The problem seems
                      Message 10 of 10 , Sep 13, 2007
                      • 0 Attachment
                        consiglieri wrote:
                        > Terminal is set to utf-8, in fact terminal displays everything nicely,
                        > its only when console vim is started that there is a problem.

                        Maybe try fiddling with the settings to do with 'wide glyphs' and so on in the
                        Terminal Window Settings, and/or Vim's ambiwidth option.

                        The problem seems odd to me, though; I have had problems in Terminal with Vim and
                        Unicode stuff, but never anything quite like this, I don't think.

                        Ben.


                        Send instant messages to your online friends http://au.messenger.yahoo.com


                        --~--~---------~--~----~------------~-------~--~----~
                        You received this message from the "vim_mac" maillist.
                        For more information, visit http://www.vim.org/maillist.php
                        -~----------~----~----~----~------~----~------~--~---
                      Your message has been successfully submitted and would be delivered to recipients shortly.