Loading ...
Sorry, an error occurred while loading the content.

Re: Plugin: java code completion - vim7 omni complete [fixed]

Expand Messages
  • wishi
    Allright, thanks a lot for that. After installing in ~/.vim/ and changing my .vimrc everything works perfectly well. They should replace this to vim.org. wishi
    Message 1 of 5 , Sep 6, 2007
    • 0 Attachment
      Allright, thanks a lot for that. After installing in ~/.vim/ and
      changing my .vimrc everything works perfectly well. They should
      replace this to vim.org.

      wishi


      Am 04.09.2007 um 14:04 schrieb Nico Weber:

      >
      > Strange. Do you have a `java` in your path? I.e. if you type `java`
      > in terminal, do you get something else than "command not found"?
      >
      > I just installed javacomplete to see if it works for me, it does.
      > Here's what I did:
      >
      > 1. Download zip, extract it to Desktop
      > 2. Terminal: mkdir -p ~/.vim/autoload
      > 3. mv ~/Desktop/javacomplete/* ~/.vim/autoload
      > 4. cd ~/.vim
      > 5. mkdir doc
      > 6. mv autoload/javacomplete.txt doc
      >
      > After that, ~/.vim/autoload contained the files Reflection.java,
      > java_parser.vim and javacomplete.vim and ~/.vim/doc containted
      > javacomplete.txt.
      >
      > Now I fired up vim (I tested both Carbon vim and MacVim) and executed
      > `:helptags ~/.vim/doc` (see `:he add-local-help` for more
      > information), opened a java file and typed in manually `:set
      > omnifunc=javacomplete#Complete`. After that, when I first used C-x C-
      > o, the java file was compiled into a class file, and then it Just
      > Worked (it completed System.out.pr successfully. Package name
      > completion didn't work for me).
      >
      > Then I added
      >
      > if has("autocmd")
      > autocmd Filetype java setlocal omnifunc=javacomplete#Complete
      > endif
      >
      > to my ~/_vimrc , and from then on omnicompletion worked without
      > problems.
      >
      > HTH,
      > Nico
      >
      > ps: Always put local modifications in your ~/.vim directory, then
      > these settings are used by all vim instances you start. (`:he rtp`
      > gives a very terse overview).
      >
      >
      >>
      >> 1. Unzip javacomplete.zip to an autoload directory, e.g. $VIM/
      >> vimfiles/autoload
      >> Move javacomplete.txt to help directory, e.g. $VIM/vimfiles/doc.
      >
      > As said, these are bad suggestions.
      >
      >
      >
      >

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.