Loading ...
Sorry, an error occurred while loading the content.

small macvim bug

Expand Messages
  • Nico Weber
    Hi, after hitting C-v (to start blockwise visual mode), using the arrow keys ends visual mode. hjkl work fine. Also works fine in carbon vim, I guess this is
    Message 1 of 4 , Aug 28, 2007
    • 0 Attachment
      Hi,

      after hitting C-v (to start blockwise visual mode), using the arrow
      keys ends visual mode. hjkl work fine. Also works fine in carbon vim,
      I guess this is due to some standard mapping.

      Nico

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • björn
      ... The problem is :set keymodel=stopsel ...from :h keymodel stopsel Using a not-shifted special key stops selection. Special keys in this context are the
      Message 2 of 4 , Aug 29, 2007
      • 0 Attachment

        after hitting C-v (to start blockwise visual mode), using the arrow
        keys ends visual mode. hjkl work fine. Also works fine in carbon vim,
        I guess this is due to some standard mapping.

        The problem is ':set keymodel=stopsel'...from :h keymodel

               stopsel    Using a not-shifted special key stops selection.
            Special keys in this context are the cursor keys, <End>, <Home>,
            <PageUp> and <PageDown>.

        The reason keymodel is changed is so that shifted 'special keys' start selection mode; this to make MacVim behave according to the HIG.  So what should I do?  Break the HIG or break the usual arrow key behaviour in visual mode?  By the way, I was setting 'behave mswin' in the system gvimrc to get the shift-select behaviour.


        /Björn

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---

      • Nico Weber
        ... Is it possible to have shift-select support only in insert mode? That d be the best solution. Instead of a `:behave win` line I d set the four options it
        Message 3 of 4 , Aug 30, 2007
        • 0 Attachment
          > The reason keymodel is changed is so that shifted 'special keys'
          > start selection mode; this to make MacVim behave according to the
          > HIG. So what should I do? Break the HIG or break the usual arrow
          > key behaviour in visual mode? By the way, I was setting 'behave
          > mswin' in the system gvimrc to get the shift-select behaviour.

          Is it possible to have shift-select support only in insert mode?
          That'd be the best solution.

          Instead of a `:behave win` line I'd set the four options it sets
          explicitly (`:he :behave`). Explicit is better than implicit ;-)

          Nico

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Niklas Lindström
          Hi! I think it s better to break the HiG when Vim has a behaviour in conflict with it. (I did some editing of the MacVim gvimrc to disable behave mswin and
          Message 4 of 4 , Aug 31, 2007
          • 0 Attachment
            Hi!

            I think it's better to break the HiG when Vim has a behaviour in
            conflict with it. (I did some editing of the MacVim gvimrc to disable
            "behave mswin" and get back to some Alt (M) mappings I had for custom
            stuff.)

            I believe it's fine to support Cmd-key mappings that comply, since
            this is a non-standard key that vim doesn't use normally. But the rest
            should be optional with an extra script, or perhaps with: "behave
            mac"?

            Best regards,
            Niklas


            On 8/29/07, björn <bjorn.winckler@...> wrote:
            >
            > >
            > > after hitting C-v (to start blockwise visual mode), using the arrow
            > > keys ends visual mode. hjkl work fine. Also works fine in carbon vim,
            > > I guess this is due to some standard mapping.
            >
            > The problem is ':set keymodel=stopsel'...from :h keymodel
            >
            > stopsel Using a not-shifted special key stops selection.
            > Special keys in this context are the cursor keys, <End>, <Home>,
            > <PageUp> and <PageDown>.
            >
            > The reason keymodel is changed is so that shifted 'special keys' start
            > selection mode; this to make MacVim behave according to the HIG. So what
            > should I do? Break the HIG or break the usual arrow key behaviour in visual
            > mode? By the way, I was setting 'behave mswin' in the system gvimrc to get
            > the shift-select behaviour.
            >
            >
            > /Björn
            >
            >
            > >
            >

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          Your message has been successfully submitted and would be delivered to recipients shortly.