Loading ...
Sorry, an error occurred while loading the content.

MacVim toolbar issues

Expand Messages
  • Nico Weber
    Hi, the toolbar problems are caused by the line [toolbar setShowsBaselineSeparator:NO]; If this is uncommented, all is well. A short-term fix is to uncomment
    Message 1 of 3 , Aug 2 10:29 PM
    • 0 Attachment
      Hi,

      the toolbar problems are caused by the line

      [toolbar setShowsBaselineSeparator:NO];

      If this is uncommented, all is well. A short-term fix is to uncomment
      that line and to add

      [tabBarControl setStyleNamed:@"Unified"];

      to windowDidLoad so that it doesn't look completely hideous. The demo
      app included with PSMTabBarController doesn't seem to have that
      problem. I'll take another look tomorrow.

      Nico

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • björn
      ... Thanks for looking into this! The baseline separator is already causing me grief; try hiding the toolbar by clicking the pill button in the top right
      Message 2 of 3 , Aug 3 4:34 AM
      • 0 Attachment

        the toolbar problems are caused by the line

                 [toolbar setShowsBaselineSeparator:NO];

        If this is uncommented, all is well. A short-term fix is to uncomment
        that line and to add

             [tabBarControl setStyleNamed:@"Unified"];

        to windowDidLoad so that it doesn't look completely hideous. The demo
        app included with PSMTabBarController doesn't seem to have that
        problem. I'll take another look tomorrow.

        Thanks for looking into this!

        The baseline separator is already causing me grief; try hiding the toolbar by clicking the "pill button" in the top right corner of the window...this causes the separator to appear again, and when you click the pill button to show the toolbar the baseline separator is still there.  I've tried desperately to figure out how to make sure it is hidden whenever the toolbar is visible, but I gave up (for the moment).

        Now you tell me that it causes other problems as well...very annoying.  I might set the default style to "Unified" for now and let the baseline separator be.  However, if you can figure out a way to get around the problems with the baseline separator I would prefer the "Metal" style (it looks much nicer in my opinion).


        /Björn

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---

      • Nico Weber
        ... As I said: Disable the baseline separator when you create the toolbar (it only causes problems to change this after the toolbar is visible), and use the
        Message 3 of 3 , Aug 3 9:53 AM
        • 0 Attachment
          > Now you tell me that it causes other problems as well...very
          > annoying. I might set the default style to "Unified" for now and
          > let the baseline separator be. However, if you can figure out a
          > way to get around the problems with the baseline separator I would
          > prefer the "Metal" style (it looks much nicer in my opinion).

          As I said: Disable the baseline separator when you create the toolbar
          (it only causes problems to change this after the toolbar is
          visible), and use the tab bar as "separator": It can display itself
          as a 1px high line if only one tab is open.

          Nico


          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.