Loading ...
Sorry, an error occurred while loading the content.
 

Decomposed chars in Carbon gvim

Expand Messages
  • Jun T.
    Carbon version of gvim (7.1, may be 7.0 as well) seems to have a problem in displaying decomposed unicode characters. Open gvim (Carbon version, with
    Message 1 of 1 , May 24, 2007
      Carbon version of gvim (7.1, may be 7.0 as well) seems to have a problem in displaying "decomposed" unicode characters.

      Open gvim (Carbon version, with enc=tenc=utf-8, gfn=Monaco and macatsui) and type the following in the input mode:

      e ctrl-V u 0301

      This will input an "e with an accent" in decomposed form. It should look like the "pre-composed form", which can be input either by

      ctrl-V u 00e9

      or by digraph

      ctrl-K e '

      or by Mac's dead-key combination

      option-e e

      But the decomposed form will not show correctly. It may show just as an "e", or if you move the cursor around, then the accent may appear on the character next to the "e".

      This happens Carbon gvim 7.1 either with or without the atsui.patch by Jigod Jiang

      http://wiki.macvim.org/wiki/VimPatches/ATSUI

      If I set gfn=Osaka-Mono, then the original (un-patched) gvim7.1 can correctly show the decomposed "e with an accent" (with ugly non-antialiased fonts). But it still can not display correlcty Hiragana (or Katakana) with combining sound mark, e.g.

      ctrl-K h e ctrl-V u 3099

      whose pre-composed form is

      ctrl-K b e


      The console version (in Terminal.app or xterm) and X11 Athena gui version seem to work (Terminal.app with Osaka-Mono has some problem with an "e with an accent" but it the problem of Terminal.app, not of vim).
    Your message has been successfully submitted and would be delivered to recipients shortly.