Loading ...
Sorry, an error occurred while loading the content.

Re: Vim 7 no longer compiles on OS X

Expand Messages
  • Benjamin Esham
    ... OK, I ve resolved this problem. I had the ATSUI patch (http:// wiki.macvim.org/wiki/VimPatches/ATSUI) applied, and I think that it somehow conflicted with
    Message 1 of 4 , Apr 28, 2007
    • 0 Attachment
      Benjamin Esham wrote:

      > I recently updated to the latest SVN revision of Vim 7, and now it
      > won't compile. I'm using OS X 10.4.9 with Fink (although I am
      > compiling Vim manually, without Fink involved). The errors seem
      > all to be in gui_mac.c; there are about two dozen errors, and maybe
      > four dozen warnings. The last version I had compiled was something
      > around 7.0.220 (see ftp://ftp.vim.org/pub/vim/patches/7.0/README),
      > so I'm assuming that the problem lies in the patches for 7.0.232
      > and 233. Am I doing anything wrong, or are the patches just
      > buggy? Thanks for any help here.

      OK, I've resolved this problem. I had the ATSUI patch (http://
      wiki.macvim.org/wiki/VimPatches/ATSUI) applied, and I think that it
      somehow conflicted with patches 232 and 233. If I get time, I'll see
      if applying the ATSUI patch now gives the same problems, but at least
      my installation works again.

      --
      Benjamin D. Esham
      bdesham@... | AIM: bdesham128 | Jabber: same as e-mail
    • Jjgod Jiang
      Hi Benjamin, ... I created a new patch against the latest SVN version (r252).Will you please try:
      Message 2 of 4 , Apr 28, 2007
      • 0 Attachment
        Hi Benjamin,

        2007/4/29, Benjamin Esham <bdesham@...>:
        > OK, I've resolved this problem. I had the ATSUI patch (http://
        > wiki.macvim.org/wiki/VimPatches/ATSUI) applied, and I think that it
        > somehow conflicted with patches 232 and 233. If I get time, I'll see
        > if applying the ATSUI patch now gives the same problems, but at least
        > my installation works again.

        I created a new patch against the latest SVN version (r252).Will you
        please try:

        http://wiki.macvim.org/wiki/VimPatches/ATSUI?action=AttachFile&do=get&target=atsui.patch

        and see if it works for you?

        Thanks.

        - jjgod.
      • Benjamin Esham
        ... Hi Jjgod, Patching against the latest Vim 7.1 SVN works fine for me (i.e. both antialiasing and multibyte text work). Thanks a lot, -- Benjamin D. Esham
        Message 3 of 4 , May 8, 2007
        • 0 Attachment
          Jjgod Jiang wrote:

          > Hi Benjamin,
          >
          > 2007/4/29, Benjamin Esham <bdesham@...>:
          >> OK, I've resolved this problem. I had the ATSUI patch (http://
          >> wiki.macvim.org/wiki/VimPatches/ATSUI) applied, and I think that it
          >> somehow conflicted with patches 232 and 233. If I get time, I'll see
          >> if applying the ATSUI patch now gives the same problems, but at least
          >> my installation works again.
          >
          > I created a new patch against the latest SVN version (r252).Will you
          > please try:
          >
          > http://wiki.macvim.org/wiki/VimPatches/ATSUI?
          > action=AttachFile&do=get&target=atsui.patch

          Hi Jjgod,

          Patching against the latest Vim 7.1 SVN works fine for me (i.e. both
          antialiasing and multibyte text work).

          Thanks a lot,
          --
          Benjamin D. Esham
          bdesham@... | AIM: bdesham128 | Jabber: same as e-mail
          β€œIt is the unknown we fear when we look upon death and darkness,
          nothing more.” β€” Albus Dumbledore in HBP
        Your message has been successfully submitted and would be delivered to recipients shortly.