Loading ...
Sorry, an error occurred while loading the content.

Re: Where's my Vim icon?

Expand Messages
  • André Schaefer
    Hi Richard, the FAQ section on http://macvim.org/OSX/index.php recommends the line ... which works for me. have fun, André Schaefer aip.schaefer@mac.com
    Message 1 of 7 , Feb 28, 2007
    • 0 Attachment
      Hi Richard,

      the FAQ section on http://macvim.org/OSX/index.php recommends the line

      :set nomacatsui anti enc=utf-8 termencoding=macroman gfn=Monaco:h13

      which works for me.

      have fun,
      André Schaefer
      aip.schaefer@...



      Am 01.03.2007 um 07:43 schrieb Richard Newman:

      > :set antialias
      >
      > You will want to do some experimentation with your fonts, though.
      >
      > On 28 Feb 2007, at 10:13 PM, George V. Reilly wrote:
      >
      >> I see that fonts are not anti-aliased. Is that because it's a
      >> Carbon app instead of a Cocoa one?
      >
    • Nicolas Weber
      Hi, ... No, that has nothing to do with Carbon/Cocoa. Mac Vim s font handling code is simply buggy. You have to choose if anti-aliasing or unicode text display
      Message 2 of 7 , Mar 1, 2007
      • 0 Attachment
        Hi,

        > I see that fonts are not anti-aliased. Is that because it's a
        > Carbon app instead of a Cocoa one?

        No, that has nothing to do with Carbon/Cocoa. Mac Vim's font handling
        code is simply buggy. You have to choose if anti-aliasing or unicode
        text display works iuc (yes, that's an exclusive or :-P).

        Nico
      • Andre Schaefer
        Hello, I currently observe severe problems even with no antialiasing; utf-8 support seems to be buggy. I wonder, if there is some short term workaround? I
        Message 3 of 7 , Mar 1, 2007
        • 0 Attachment
          Hello,

          I currently observe severe problems even with no antialiasing; utf-8
          support seems to be buggy.

          I wonder, if there is some short term workaround? I currently edit a
          long utf-8 document and would be happy to use mac Vim.app instead of the
          shell vi or Aquamacs Emacs (although the latter is not bad in terms of
          stability and OS integration, it seems ;) - and it has viper-mode )

          I did try all the enc/(no)macatsui/(no)anti/gfn patterns it seems.

          Too bad: my ~/.gvimrc seems to let Vim.app crash, when doublecllicking.
          using the gvim starter script from the shell does work... strange.

          Seems to have something to do with my locale settings and translated
          menus, probably.

          I will post a trace, if that seems to be useful... ? (be patient; I am
          not at home at my mac currently)

          ciao,
          André


          Am Donnerstag, den 01.03.2007, 12:47 +0100 schrieb Nicolas Weber:
          > Hi,
          >
          > > I see that fonts are not anti-aliased. Is that because it's a
          > > Carbon app instead of a Cocoa one?
          >
          > No, that has nothing to do with Carbon/Cocoa. Mac Vim's font handling
          > code is simply buggy. You have to choose if anti-aliasing or unicode
          > text display works iuc (yes, that's an exclusive or :-P).
          >
          > Nico
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.