Loading ...
Sorry, an error occurred while loading the content.
 

Where's my Vim icon?

Expand Messages
  • george@reilly.org
    My first ever Mac arrived this morning. Forgive the newbie question. I downloaded vim7.0.188-univ.tar.bz2 and followed the instructions, giving me
    Message 1 of 7 , Feb 28, 2007
      My first ever Mac arrived this morning. Forgive the newbie question.

      I downloaded vim7.0.188-univ.tar.bz2 and followed the instructions,
      giving me /Applications/Vim.app and /Applications/gvim.app. However,
      no icon shows up in the Dock and Quicksilver doesn't know about it. If
      I run vim in Terminal, I get Vim 6.2. Ick!

      BTW, wiki.macvim.org is down.

      /George
    • Arnaud BARRÉ
      Welcome in the mac community ! You have to drag the gVim.app icon to the Dock and drop it! More information in this Mac 101 lesson
      Message 2 of 7 , Feb 28, 2007
        Welcome in the mac community !

        You have to drag the gVim.app icon to the Dock and drop it!

        More information in this Mac 101 lesson
        http://docs.info.apple.com/article.html?artnum=304728

        Regards,

        Arnaud


        On 2/28/07, george@... <george@...> wrote:
        > My first ever Mac arrived this morning. Forgive the newbie question.
        >
        > I downloaded vim7.0.188-univ.tar.bz2 and followed the instructions,
        > giving me /Applications/Vim.app and /Applications/gvim.app. However,
        > no icon shows up in the Dock and Quicksilver doesn't know about it. If
        > I run vim in Terminal, I get Vim 6.2. Ick!
        >
        > BTW, wiki.macvim.org is down.
        >
        > /George
        >
      • George V. Reilly
        Thanks, Arnaud, and the others who responded directly. I have Vim up and running now on Tiger. I m an experienced Windows developer and a competent Linux
        Message 3 of 7 , Feb 28, 2007
          Thanks, Arnaud, and the others who responded directly. I have Vim up
          and running now on Tiger. I'm an experienced Windows developer and a
          competent Linux user, but I had probably used Macs for a total of 8
          hours *ever* before today.

          I see that fonts are not anti-aliased. Is that because it's a Carbon app
          instead of a Cocoa one?

          /George

          --
          An intelligent mind is a mind which is not satisfied with explanations, with
          conclusions; nor is it a mind that believes, because belief is again another
          form of conclusion. An intelligent mind is an inquiring mind, a mind that is
          watching, learning, studying.
          -- J. Krishnamuti
          (Get Witty Auto-Generated Signatures from http://SmartBee.org)
          George V. Reilly george@...
          http://www.georgevreilly.com/blog


          Arnaud BARRÉ wrote:
          > Welcome in the mac community !
          >
          > You have to drag the gVim.app icon to the Dock and drop it!
          >
          > More information in this Mac 101 lesson
          > http://docs.info.apple.com/article.html?artnum=304728
          >
          > Regards,
          >
          > Arnaud
          >
          >
          > On 2/28/07, george@... <george@...> wrote:
          >> My first ever Mac arrived this morning. Forgive the newbie question.
          >>
          >> I downloaded vim7.0.188-univ.tar.bz2 and followed the instructions,
          >> giving me /Applications/Vim.app and /Applications/gvim.app. However,
          >> no icon shows up in the Dock and Quicksilver doesn't know about it. If
          >> I run vim in Terminal, I get Vim 6.2. Ick!
          >>
          >> BTW, wiki.macvim.org is down.
          >>
          >> /George
          >>
          >
        • Richard Newman
          ... You will want to do some experimentation with your fonts, though.
          Message 4 of 7 , Feb 28, 2007
            :set antialias

            You will want to do some experimentation with your fonts, though.

            On 28 Feb 2007, at 10:13 PM, George V. Reilly wrote:

            > I see that fonts are not anti-aliased. Is that because it's a
            > Carbon app instead of a Cocoa one?
          • André Schaefer
            Hi Richard, the FAQ section on http://macvim.org/OSX/index.php recommends the line ... which works for me. have fun, André Schaefer aip.schaefer@mac.com
            Message 5 of 7 , Feb 28, 2007
              Hi Richard,

              the FAQ section on http://macvim.org/OSX/index.php recommends the line

              :set nomacatsui anti enc=utf-8 termencoding=macroman gfn=Monaco:h13

              which works for me.

              have fun,
              André Schaefer
              aip.schaefer@...



              Am 01.03.2007 um 07:43 schrieb Richard Newman:

              > :set antialias
              >
              > You will want to do some experimentation with your fonts, though.
              >
              > On 28 Feb 2007, at 10:13 PM, George V. Reilly wrote:
              >
              >> I see that fonts are not anti-aliased. Is that because it's a
              >> Carbon app instead of a Cocoa one?
              >
            • Nicolas Weber
              Hi, ... No, that has nothing to do with Carbon/Cocoa. Mac Vim s font handling code is simply buggy. You have to choose if anti-aliasing or unicode text display
              Message 6 of 7 , Mar 1, 2007
                Hi,

                > I see that fonts are not anti-aliased. Is that because it's a
                > Carbon app instead of a Cocoa one?

                No, that has nothing to do with Carbon/Cocoa. Mac Vim's font handling
                code is simply buggy. You have to choose if anti-aliasing or unicode
                text display works iuc (yes, that's an exclusive or :-P).

                Nico
              • Andre Schaefer
                Hello, I currently observe severe problems even with no antialiasing; utf-8 support seems to be buggy. I wonder, if there is some short term workaround? I
                Message 7 of 7 , Mar 1, 2007
                  Hello,

                  I currently observe severe problems even with no antialiasing; utf-8
                  support seems to be buggy.

                  I wonder, if there is some short term workaround? I currently edit a
                  long utf-8 document and would be happy to use mac Vim.app instead of the
                  shell vi or Aquamacs Emacs (although the latter is not bad in terms of
                  stability and OS integration, it seems ;) - and it has viper-mode )

                  I did try all the enc/(no)macatsui/(no)anti/gfn patterns it seems.

                  Too bad: my ~/.gvimrc seems to let Vim.app crash, when doublecllicking.
                  using the gvim starter script from the shell does work... strange.

                  Seems to have something to do with my locale settings and translated
                  menus, probably.

                  I will post a trace, if that seems to be useful... ? (be patient; I am
                  not at home at my mac currently)

                  ciao,
                  André


                  Am Donnerstag, den 01.03.2007, 12:47 +0100 schrieb Nicolas Weber:
                  > Hi,
                  >
                  > > I see that fonts are not anti-aliased. Is that because it's a
                  > > Carbon app instead of a Cocoa one?
                  >
                  > No, that has nothing to do with Carbon/Cocoa. Mac Vim's font handling
                  > code is simply buggy. You have to choose if anti-aliasing or unicode
                  > text display works iuc (yes, that's an exclusive or :-P).
                  >
                  > Nico
                  >
                Your message has been successfully submitted and would be delivered to recipients shortly.