Loading ...
Sorry, an error occurred while loading the content.
 

Troubles with encodings when i use the dport vim version

Expand Messages
  • Arnaud BARRÉ
    Hi, Actually I use Vim_7.0-PPC and it works greats. I have no troubles with this version when i open ISO-8859-1 encoded file or when I type on my iBook
    Message 1 of 2 , Feb 20, 2007
      Hi,

      Actually I use Vim_7.0-PPC and it works greats. I have no troubles
      with this version when i open ISO-8859-1 encoded file or when I type
      on my iBook 'Panther' keyboard.

      In fact, I use this line in my ~/.gvimrc :
      set nomacatsui anti encoding=latin1 termencoding=macroman gfn=Monaco:h10

      Because i want to try to guitab.v5.diff patch, i compiled my own vim
      version. In fact, i use MacPort (Or Darwinports) and I added the line
      to the guitab.v5.diff patch
      I have no problem during the compilation and the gui tab works great!.
      Now i have a 'vim 7.0.201_0+aqua+cscope+perl+python+ruby+tcl ' version
      which look likes the mac-vim version (Binaries in /Applications, GVim
      to launch Vim, etc.)

      The problem start here. When I open some ISO-8859-1 files, I have some
      bad characters. The worst is when I type on my keyboard. My accents
      are not displayed. For exemple, if I type 'é' I have '~N'

      I tried some to change the enconding and termencoding options but i
      always have the same problems.

      I think, the encoding and termencoding have no effect on my vim version...

      Have you already had this problem?

      I use libiconv 1.11 during the compilation.

      Regards,

      Arnaud
    • Arnaud BARRÉ
      Hi, I found the problem. In fact, i not compile Vim with the multi_byte option. Arnaud
      Message 2 of 2 , Feb 26, 2007
        Hi,

        I found the problem. In fact, i not compile Vim with the multi_byte option.

        Arnaud

        On 2/20/07, Arnaud BARRÉ <arnaud.barre@...> wrote:
        > Hi,
        >
        > Actually I use Vim_7.0-PPC and it works greats. I have no troubles
        > with this version when i open ISO-8859-1 encoded file or when I type
        > on my iBook 'Panther' keyboard.
        >
        > In fact, I use this line in my ~/.gvimrc :
        > set nomacatsui anti encoding=latin1 termencoding=macroman gfn=Monaco:h10
        >
        > Because i want to try to guitab.v5.diff patch, i compiled my own vim
        > version. In fact, i use MacPort (Or Darwinports) and I added the line
        > to the guitab.v5.diff patch
        > I have no problem during the compilation and the gui tab works great!.
        > Now i have a 'vim 7.0.201_0+aqua+cscope+perl+python+ruby+tcl ' version
        > which look likes the mac-vim version (Binaries in /Applications, GVim
        > to launch Vim, etc.)
        >
        > The problem start here. When I open some ISO-8859-1 files, I have some
        > bad characters. The worst is when I type on my keyboard. My accents
        > are not displayed. For exemple, if I type 'é' I have '~N'
        >
        > I tried some to change the enconding and termencoding options but i
        > always have the same problems.
        >
        > I think, the encoding and termencoding have no effect on my vim version...
        >
        > Have you already had this problem?
        >
        > I use libiconv 1.11 during the compilation.
        >
        > Regards,
        >
        > Arnaud
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.