Loading ...
Sorry, an error occurred while loading the content.
 

Combining diacritics in Vim.app

Expand Messages
  • Kenneth Reid Beesley
    Newbie question: I have Vim.app installed, version 7.0. on a Tibook running OS X 10.4.8 When I launch it by clicking Vim.app, or using the gvim command from
    Message 1 of 2 , Jan 4, 2007
      Newbie question:

      I have Vim.app installed, version 7.0. on a Tibook running OS X 10.4.8
      When I launch it by clicking Vim.app, or using the 'gvim'
      command from xterm, I can insert Roman text without
      difficulty, but combining diacritics are not displayed properly

      E.g. if I type an 'e' followed by

      Ctrl-V u0300

      I should see an 'e' with a grave accent rendered over it.

      (0300 is the combining grave accent) the character 0300 is
      inserted in the buffer, and I can write the file and verify that the
      diacritic is indeed there, but it doesn't display in the vim window.

      How can I make such combining diacritics display properly in gvim?

      ***********************************

      I also installed a plain vim, with +multibyte +huge, version 7.0.178
      Running inside an xterm, this version _does_ display combining
      diacritics properly.

      Any advice would be appreciated.

      Ken
    • Benji Fisher
      ... I am afraid that this is one of the things that just does not work with the current font-rendering code. Watch this list for updates. Possibly helpful
      Message 2 of 2 , Feb 1, 2007
        On Thu, Jan 04, 2007 at 01:17:34AM -0700, Kenneth Reid Beesley wrote:
        > Newbie question:
        >
        > I have Vim.app installed, version 7.0. on a Tibook running OS X 10.4.8
        > When I launch it by clicking Vim.app, or using the 'gvim'
        > command from xterm, I can insert Roman text without
        > difficulty, but combining diacritics are not displayed properly
        >
        > E.g. if I type an 'e' followed by
        >
        > Ctrl-V u0300
        >
        > I should see an 'e' with a grave accent rendered over it.
        >
        > (0300 is the combining grave accent) the character 0300 is
        > inserted in the buffer, and I can write the file and verify that the
        > diacritic is indeed there, but it doesn't display in the vim window.
        >
        > How can I make such combining diacritics display properly in gvim?
        >
        > ***********************************
        >
        > I also installed a plain vim, with +multibyte +huge, version 7.0.178
        > Running inside an xterm, this version _does_ display combining
        > diacritics properly.
        >
        > Any advice would be appreciated.
        >
        > Ken

        I am afraid that this is one of the things that just does not work
        with the current font-rendering code. Watch this list for updates.

        Possibly helpful information:

        You can check the character under the cursor with the g8 command.
        :help g8

        You can run vim (not gvim) inside a Terminal.app window, and the
        combining diacritics display properly. At least, the example you gave
        looks right to me. This may depend on the font settings for
        Terminal.app. See FAQ #8 for running vim in a terminal window:
        http://macvim.org/OSX/index.php#FAQ

        HTH --Benji Fisher
      Your message has been successfully submitted and would be delivered to recipients shortly.