Loading ...
Sorry, an error occurred while loading the content.

Re: Character Palette does not work in GUI

Expand Messages
  • Ned Konz
    ... Looks like a Japanese Mac developer has already done some work on this... I searched for {newtsmdocument vim} and found: for Vim 7.0?
    Message 1 of 4 , Nov 14, 2006
    • 0 Attachment
      Benji Fisher wrote:
      > On Mon, Nov 13, 2006 at 05:43:09PM +0300, Michail Vidiassov wrote:
      >> Dear All,
      >>
      >> On Mon, 13 Nov 2006, Benji Fisher wrote:
      >>> I find that it works on Mac OS X 10.3.9 with vim 7.0 and
      >>> it does not work on Mac OS X 10.4.8 (vim 6.4 nor vim 7.0). I guess
      >>> that Apple changed the way it works and no one here has yet implemented
      >>> the new method.
      >> It seems that is a known issue, a discussion on carbon-dev mailing list
      >> (http://lists.apple.com/archives/carbon-dev/2005/Jun/msg01332.html)
      >> resulted in the conclusion that starting with 10.4 application has to be
      >> "TSM-aware", initialise Text Services Manager by calling NewTSMDocument.
      >> Other changes are not required.
      >>
      >> Sincerely, Michail
      >
      > Can you be more specific about where and how to make the change? A
      > patch would be most helpful. I looked at the thread you quoted, but I
      > do not know enough to use the information there. (See my disclaimer at
      > http://macvim.org/OSX/index.php#Credits .)
      >
      > --Benji Fisher
      >

      Looks like a Japanese Mac developer has already done some work on this...

      I searched for {newtsmdocument vim} and found:

      for Vim 7.0?
      http://iplab.naist.jp/member/mio-su/dist/vim/inline0.2.diff

      For Vim 6.2?
      http://www.kaoriya.net/testdir/patches-vim/kaoriya-20040517.diff

      --
      Ned Konz
      ned@...
      http://bike-nomad.com
    Your message has been successfully submitted and would be delivered to recipients shortly.