Loading ...
Sorry, an error occurred while loading the content.

Antialiased fonts in multibyte Vim.app

Expand Messages
  • Wojciech Grzemski
    Hello, Is there a way to build the multibyte Vim.app that could display nice, antialiased fonts at the same time? I pulled sources from subversion tree
    Message 1 of 4 , Oct 11, 2006
    • 0 Attachment
      Hello,

      Is there a way to build the multibyte Vim.app that could display nice,
      antialiased fonts at the same time? I pulled sources from subversion
      tree (I have revision 147 now) and tried building vim with couple of
      different build options, used different set of settings in .gvimrc (with
      and without macatsui, with different settings for termencoding etc.) but
      to no avail. I also tried patching the code with the patches that were
      sent to the list couple of months ago to the list by Jun T.
      ( http://marc.theaimsgroup.com/?l=vim-mac&m=114907838112145&w=2 ), but
      it does not seem to work with new Xcode :-(

      Thanks in advance for any info, help...

      Best,
      --
      Wojciech Grzemski <wgrzemski@...> "On Margate Sands..."
    • Timothy Reaves
      With the build I have, I found this in my gvimrc worked well, and gives me antialiased fonts. set font, antialias, encoding, and term set nomacatsui anti
      Message 2 of 4 , Oct 11, 2006
      • 0 Attachment
        With the build I have, I found this in my gvimrc worked well, and
        gives me antialiased fonts.

        "set font, antialias, encoding, and term
        set nomacatsui anti enc=utf-8 tenc=macroman gfn=Monaco:h11


        On Oct 11, 2006, at 10:20 PM, Wojciech Grzemski wrote:

        > Hello,
        >
        > Is there a way to build the multibyte Vim.app that could display
        > nice,
        > antialiased fonts at the same time? I pulled sources from
        > subversion
        > tree (I have revision 147 now) and tried building vim with
        > couple of
        > different build options, used different set of settings in .gvimrc
        > (with
        > and without macatsui, with different settings for termencoding
        > etc.) but
        > to no avail. I also tried patching the code with the patches that
        > were
        > sent to the list couple of months ago to the list by Jun T.
        > ( http://marc.theaimsgroup.com/?l=vim-mac&m=114907838112145&w=2 ), but
        > it does not seem to work with new Xcode :-(
        >
        > Thanks in advance for any info, help...
        >
        > Best,
        > --
        > Wojciech Grzemski <wgrzemski@...> "On Margate Sands..."
      • Wojciech Grzemski
        ... Well, could you post (or send me) your build options then? Because if it *really* works it would be sooo... nice. I mean, I really need multibyte fonts:
        Message 3 of 4 , Oct 12, 2006
        • 0 Attachment
          On Wednesday, 2006-10-11, Timothy Reaves wrote:
          > With the build I have, I found this in my gvimrc worked well, and
          > gives me antialiased fonts.
          >
          > "set font, antialias, encoding, and term
          > set nomacatsui anti enc=utf-8 tenc=macroman gfn=Monaco:h11

          Well, could you post (or send me) your build options then? Because if it
          *really* works it would be sooo... nice. I mean, I really need multibyte
          fonts: Polish, Greek, sometimes some Russian (or German) in the same
          file, and non-antialiased font is sometimes really, really hard to read.
          On the other hand the antialiased font with your settings *does not*
          display correctly multibyte fonts. Just try :digraphs to see how much is
          really there, or download any of the Unicode test files from the
          internet to see what your copy of Vim can really display. Sorry, if my
          previous post was not precise, but this is exactly what I need: a
          Vim.app where I can _read_and_write_ UTF-8 encoded files.

          All the best,
          --
          Wojciech Grzemski <wgrzemski@...> "On Margate Sands..."
        • Jun T.
          ... What kind of problem do you have? I m using Xcode2.4, gcc4.0.1. jun
          Message 4 of 4 , Oct 12, 2006
          • 0 Attachment
            At 10:20 PM -0400 06.10.11, Wojciech Grzemski wrote:
            >( http://marc.theaimsgroup.com/?l=vim-mac&m=114907838112145&w=2 ), but
            >it does not seem to work with new Xcode :-(

            What kind of problem do you have?
            I'm using Xcode2.4, gcc4.0.1.

            jun
          Your message has been successfully submitted and would be delivered to recipients shortly.