Loading ...
Sorry, an error occurred while loading the content.

Re: MUST have perl-support

Expand Messages
  • Benji Fisher
    There seem to be several problems here. If you are running Tiger, then do you have an Intel or PPC Mac? Did you compile yourself or did you get binaries from
    Message 1 of 5 , Jul 18, 2006
    • 0 Attachment
      There seem to be several problems here. If you are running Tiger,
      then do you have an Intel or PPC Mac? Did you compile yourself or did
      you get binaries from http://macvim.org/OSX/index.php or elsewhere?
      What is the output of :version ; in particular, does it include +perl ?
      Do you have any idea whether there is something in your gvimrc file that
      is causing the crash?

      What plugin did you have to put inside the Vim package? Where did
      you put it? What is the output of

      :scriptnames
      :verbose set rtp?

      BTW, I tried all the simple examples under

      :help perl-using

      on my 10.4/PPC PowerBook, and had no trouble.

      HTH --Benji Fisher

      On Tue, Jul 18, 2006 at 08:55:28AM +0100, Joseph Workman wrote:
      > I thought I would try to run it via command line to see what errors
      > came up on the terminal.
      >
      > sourcing "$HOME/.gvimrc"
      > finished sourcing $HOME/.gvimrc
      > E341: Internal error: lalloc(0, )Vim: Caught deadly signal BUS
      >
      > Writing viminfo file "/Users/jworkman/.viminfo"Vim: Finished.
      >
      > I also tried to run Vim6.4 and it worked just fine. However, I had to
      > place the plugin inside the VIM package because it was not sourcing
      > stuff in my $HOME/.vim directory. Why is that?
      >
      > What are the major benefits of Vim7 over Vim6.4 anyways?
      >
      > Any thoughts on fixing this would be greatly appreciated?
      >
      > Cheers
      > Joe
      >
      > On Jul 17, 2006, at 9:56 PM, Joseph Workman wrote:
      >
      > >I am missing perl-support . . . . There has to be someone out there
      > >who has it working on OSX Tiger!!!! Please, anyone!!!!! :o)
      > >
      > >Cheers
      > >Joe
    • Brian McKee
      ... Hash: SHA1 ... Hey, this is interesting - remember Benjii I told you Vim 7 crashed on my machine? I must confess to Joe that I m back to using 6.4 as I
      Message 2 of 5 , Jul 18, 2006
      • 0 Attachment
        -----BEGIN PGP SIGNED MESSAGE-----
        Hash: SHA1

        On 18-Jul-06, at 9:42 AM, Benji Fisher wrote:

        > There seem to be several problems here. If you are running
        > Tiger,
        > then do you have an Intel or PPC Mac? Did you compile yourself or did
        > you get binaries from http://macvim.org/OSX/index.php or elsewhere?
        > What is the output of :version ; in particular, does it include
        > +perl ?
        > Do you have any idea whether there is something in your gvimrc file
        > that
        > is causing the crash?
        >
        > What plugin did you have to put inside the Vim package? Where
        > did
        > you put it? What is the output of
        >
        > :scriptnames
        > :verbose set rtp?
        >
        > BTW, I tried all the simple examples under
        >
        > :help perl-using
        >
        > on my 10.4/PPC PowerBook, and had no trouble.
        >
        > HTH --Benji Fisher
        >
        > On Tue, Jul 18, 2006 at 08:55:28AM +0100, Joseph Workman wrote:
        >> I thought I would try to run it via command line to see what errors
        >> came up on the terminal.
        >>
        >> sourcing "$HOME/.gvimrc"
        >> finished sourcing $HOME/.gvimrc
        >> E341: Internal error: lalloc(0, )Vim: Caught deadly signal BUS
        >>
        >> Writing viminfo file "/Users/jworkman/.viminfo"Vim: Finished.
        >>
        >> I also tried to run Vim6.4 and it worked just fine. However, I had to
        >> place the plugin inside the VIM package because it was not sourcing
        >> stuff in my $HOME/.vim directory. Why is that?
        >>
        >> What are the major benefits of Vim7 over Vim6.4 anyways?
        >>
        >> Any thoughts on fixing this would be greatly appreciated?
        >>
        >> Cheers
        >> Joe
        >>
        >> On Jul 17, 2006, at 9:56 PM, Joseph Workman wrote:
        >>
        >>> I am missing perl-support . . . . There has to be someone out there
        >>> who has it working on OSX Tiger!!!! Please, anyone!!!!! :o)
        >>>
        >>> Cheers
        >>> Joe
        >


        Hey, this is interesting - remember Benjii I told you Vim 7 crashed
        on my machine?
        I must confess to Joe that I'm back to using 6.4 as I haven't figured
        out why yet.
        Maybe perl-support is the problem!

        Benji - note I think he is referring to http://vim.sourceforge.net/
        scripts/script.php?script_id=556
        not the examples you pointed out (which I've never seen before - have
        to investigate :-)

        Joe - I see from the latest release notes
        > + Adaption for Vim 7
        Are you using version 3? or an older version?
        In my case it's an older version - and I'm going to try the new one
        to see if it fixes my issue.

        Maybe it's a fixed problem.

        Brian
        -----BEGIN PGP SIGNATURE-----
        Version: GnuPG v1.4.1 (Darwin)

        iD8DBQFEvOljGnOmb9xIQHQRAmXWAKDhTjBxkcBsrwNK//CA3DP7Xt0kywCgvjNS
        sI2AxkmwLmW0YkqbiVc2P2w=
        =YPE7
        -----END PGP SIGNATURE-----
      • jose neta
        ... Hi everibody! I m using Tigger and and Intel processor. I m can t see the menus of c.vim, bash-support, perl-support. I did $:scriptnames and they appear
        Message 3 of 5 , Jul 21, 2006
        • 0 Attachment
          2006/7/18, Brian McKee <map@...>:
          >
          > -----BEGIN PGP SIGNED MESSAGE-----
          > Hash: SHA1
          >
          > On 18-Jul-06, at 9:42 AM, Benji Fisher wrote:
          >
          > > There seem to be several problems here. If you are running
          > > Tiger,
          > > then do you have an Intel or PPC Mac? Did you compile yourself or did
          > > you get binaries from http://macvim.org/OSX/index.php or elsewhere?
          > > What is the output of :version ; in particular, does it include
          > > +perl ?
          > > Do you have any idea whether there is something in your gvimrc file
          > > that
          > > is causing the crash?
          > >
          > > What plugin did you have to put inside the Vim package? Where
          > > did
          > > you put it? What is the output of
          > >
          > > :scriptnames
          > > :verbose set rtp?
          > >
          > > BTW, I tried all the simple examples under
          > >
          > > :help perl-using
          > >
          > > on my 10.4/PPC PowerBook, and had no trouble.
          > >
          > > HTH --Benji Fisher
          > >
          > > On Tue, Jul 18, 2006 at 08:55:28AM +0100, Joseph Workman wrote:
          > >> I thought I would try to run it via command line to see what errors
          > >> came up on the terminal.
          > >>
          > >> sourcing "$HOME/.gvimrc"
          > >> finished sourcing $HOME/.gvimrc
          > >> E341: Internal error: lalloc(0, )Vim: Caught deadly signal BUS
          > >>
          > >> Writing viminfo file "/Users/jworkman/.viminfo"Vim: Finished.
          > >>
          > >> I also tried to run Vim6.4 and it worked just fine. However, I had to
          > >> place the plugin inside the VIM package because it was not sourcing
          > >> stuff in my $HOME/.vim directory. Why is that?
          > >>
          > >> What are the major benefits of Vim7 over Vim6.4 anyways?
          > >>
          > >> Any thoughts on fixing this would be greatly appreciated?
          > >>
          > >> Cheers
          > >> Joe
          > >>
          > >> On Jul 17, 2006, at 9:56 PM, Joseph Workman wrote:
          > >>
          > >>> I am missing perl-support . . . . There has to be someone out there
          > >>> who has it working on OSX Tiger!!!! Please, anyone!!!!! :o)
          > >>>
          > >>> Cheers
          > >>> Joe
          > >
          >
          >
          > Hey, this is interesting - remember Benjii I told you Vim 7 crashed
          > on my machine?
          > I must confess to Joe that I'm back to using 6.4 as I haven't figured
          > out why yet.
          > Maybe perl-support is the problem!
          >
          > Benji - note I think he is referring to http://vim.sourceforge.net/
          > scripts/script.php?script_id=556
          > not the examples you pointed out (which I've never seen before - have
          > to investigate :-)
          >
          > Joe - I see from the latest release notes
          > > + Adaption for Vim 7
          > Are you using version 3? or an older version?
          > In my case it's an older version - and I'm going to try the new one
          > to see if it fixes my issue.
          >
          > Maybe it's a fixed problem.
          >
          > Brian
          > -----BEGIN PGP SIGNATURE-----
          > Version: GnuPG v1.4.1 (Darwin)
          >
          > iD8DBQFEvOljGnOmb9xIQHQRAmXWAKDhTjBxkcBsrwNK//CA3DP7Xt0kywCgvjNS
          > sI2AxkmwLmW0YkqbiVc2P2w=
          > =YPE7
          > -----END PGP SIGNATURE-----
          >

          Hi everibody! I'm using Tigger and and Intel processor.
          I'm can't see the menus of c.vim, bash-support, perl-support. I did
          $:scriptnames and they appear in the list. The problem is: I can't manage to
          put them work. I'm new in OS X and in Windows I found no problem but here
          ...


          --
          JPN
        Your message has been successfully submitted and would be delivered to recipients shortly.