Loading ...
Sorry, an error occurred while loading the content.

Re: FW: Vimspell on mac problems

Expand Messages
  • Bram Moolenaar
    ... I can reproduce it. The call stack shows: strlen + 8 ins_typebuf + 88 vgetorpeek + 2280 vgetc + 164 safe_vgetc + 16 normal_cmd + 192 mail_loop + 976 Thus
    Message 1 of 10 , Jun 16, 2006
    View Source
    • 0 Attachment
      Benji Fisher wrote:

      > On Thu, May 25, 2006 at 09:39:37AM -0400, Benji Fisher wrote:
      > > On Mon, May 22, 2006 at 06:42:36AM -0700, Furash Gary wrote:
      > > > My vimspell with 7.0 seems to work okay on the mac os x at first - it
      > > > shows words with problems, but if I right click and pick a replacement
      > > > word it crashes.
      > > > Gary Furash, MBA, PMP, Applications Manager
      > > > Maricopa County Attorney's Office
      > >
      > > I cannot reproduce this problem. What version of OS X are you
      > > using (and if it is 10.4.x, is your machine Intel or PPC based)? Did
      > > you compile yourself or where did you get Vim.app? Please give your
      > > :version output and details on what leads to a crash.
      > >
      > > I tested with OS X 10.3.9 (PPC) vim 7.0 compiled with "huge"
      > > features.
      > >
      > > I do see other problems with spell checking from the PopUp menu; I
      > > will discuss these on the vim-dev list. The crashing problem should
      > > probably move to the vim-mac list.
      >
      > Now I can reproduce the problem. It depends on how I start vim.
      > :-( Also, the problems I saw on Linux/GTK2 are either solved by setting
      > 'mousemodel' to "popup_setpos" or else unreproducible. :-( I have two
      > ways to start Vim.app :
      >
      > (1) From Finder.app, find Vim.app and CMD-O (or double click).
      >
      > (2) From a shell, use the gvim shell script, which does the same as
      > $ /Applications/Vim.app/Contents/MacOS/Vim -g &
      >
      > Start Vim.app either way. Do
      >
      > :set spell
      >
      > and enter the text "hjkl" into a new buffer. Either right-click or
      > control-click on this to bring up the PopUp menu. Choose
      > 'Change "hjkl" to' and then choose the first item, "hulk", from the
      > sub-menu. I find that nothing happens for a second or so, then the
      > PopUp menu re-appears. I make the same choices, and then the behavior
      > depends on how I started vim: if (1), then "hjkl" is replaced by
      > "hulk"; if (2), there is a long pause and then a crash.
      >
      > Can anyone else reproduce this?

      I can reproduce it. The call stack shows:

      strlen + 8
      ins_typebuf + 88
      vgetorpeek + 2280
      vgetc + 164
      safe_vgetc + 16
      normal_cmd + 192
      mail_loop + 976

      Thus it has something to do with getting typeahead characters.

      --
      hundred-and-one symptoms of being an internet addict:
      267. You get an extra phone line so you can get phone calls.

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ download, build and distribute -- http://www.A-A-P.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///
    Your message has been successfully submitted and would be delivered to recipients shortly.