Loading ...
Sorry, an error occurred while loading the content.

Re: Vimspell on mac problems

Expand Messages
  • Michael J. Bird
    Yes, I can reproduce this on a 10.4.6 PPC powerbook. I have a shortcut to the .app on my powerbar, and that s how I started it. It blew up. I ran the script
    Message 1 of 10 , May 25, 2006
    • 0 Attachment
      Yes, I can reproduce this on a 10.4.6 PPC powerbook. I have a
      shortcut to the .app on my powerbar, and that's how I started it. It
      blew up.
      I ran the script from a Terminal session. It blew up. I ran it from
      the Applications folder in Finder. It worked.

      I got this in my Terminal session:
      Vim: Caught deadly signal SEGV
      Vim: preserving files...
      Vim: Finished.


      I am using the PPC version of the pre-compiled binary (I think),
      here's the version info:
    • Michael J. Bird
      Sorry, here s the version info: VIM - Vi IMproved 7.0 (2006 May 7, compiled May 8 2006 12:56:43) MacOS X (unix) version Compiled by Jonathan Cooley
      Message 2 of 10 , May 25, 2006
      • 0 Attachment
        Sorry, here's the version info:
        VIM - Vi IMproved 7.0 (2006 May 7, compiled May 8 2006 12:56:43)
        MacOS X (unix) version
        Compiled by Jonathan Cooley <http://macvim.org/OSX>
        Huge version with Carbon GUI. Features included (+) or not (-):
        +arabic +autocmd -balloon_eval +browse ++builtin_terms +byte_offset
        +cindent
        -clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info
        +comments
        +cryptv +cscope +cursorshape +dialog_con_gui +diff +digraphs -dnd -
        ebcdic
        +emacs_tags +eval +ex_extra +extra_search +farsi +file_in_path
        +find_in_path
        +folding -footer +fork() -gettext -hangul_input +iconv +insert_expand
        +jumplist
        +keymap +langmap +libcall +linebreak +lispindent +listcmds +localmap
        +menu
        +mksession +modify_fname +mouse -mouseshape +mouse_dec -mouse_gpm
        -mouse_jsbterm +mouse_netterm +mouse_xterm +multi_byte +multi_lang -
        mzscheme
        -netbeans_intg -osfiletype +path_extra +perl +postscript +printer
        +profile
        +python +quickfix +reltime +rightleft +ruby +scrollbind +signs
        +smartindent
        -sniff +statusline -sun_workshop +syntax +tag_binary +tag_old_static
        -tag_any_white +tcl +terminfo +termresponse +textobjects +title -toolbar
        +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo
        +vreplace
        +wildignore +wildmenu +windows +writebackup -X11 -xfontset -xim -xsmp
        -xterm_clipboard -xterm_save
        system vimrc file: "$VIM/vimrc"
        user vimrc file: "$HOME/.vimrc"
        user exrc file: "$HOME/.exrc"
        system gvimrc file: "$VIM/gvimrc"
        user gvimrc file: "$HOME/.gvimrc"
        system menu file: "$VIMRUNTIME/menu.vim"
        fall-back for $VIM: "/Applications/Vim.app/Contents/Resources/vim"
        Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_MAC -fno-
        common -fpascal-strings -Wall -Wno-unknown-pragmas -mdynamic-no-pic -
        pipe -I. -Iproto -DMACOS_X_UNIX -no-cpp-precomp -I/Developer/SDKs/
        MacOSX10.4u.sdk/Developer/Headers/FlatCarbon -g -O -isysroot /
        Developer/SDKs/MacOSX10.4u.sdk -arch i386 -arch ppc -g -pipe -
        DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -I/usr/local/
        include -I/System/Library/Perl/5.8.6/darwin-thread-multi-2level/
        CORE -I/System/Library/Frameworks/Python.framework/Versions/2.3/
        include/python2.3 -I/System/Library/Frameworks/Tcl.framework/Headers
        -D_REENTRANT=1 -D_THREAD_SAFE=1 -I/usr/lib/ruby/1.8/universal-
        darwin8.0
        Linking: gcc -isysroot /Developer/SDKs/MacOSX10.4u.sdk -arch i386 -
        arch ppc -o Vim -framework Carbon -lncurses -liconv -L/usr/
        local/lib /System/Library/Perl/5.8.6/darwin-thread-multi-2level/auto/
        DynaLoader/DynaLoader.a -L/System/Library/Perl/5.8.6/darwin-thread-
        multi-2level/CORE -lperl -lm -lc -framework Python -framework Tcl -
        framework CoreFoundation -lruby -lobjc

        On May 25, 2006, at 10:37 AM, Michael J. Bird wrote:

        > Yes, I can reproduce this on a 10.4.6 PPC powerbook. I have a
        > shortcut to the .app on my powerbar, and that's how I started it.
        > It blew up.
        > I ran the script from a Terminal session. It blew up. I ran it from
        > the Applications folder in Finder. It worked.
        >
        > I got this in my Terminal session:
        > Vim: Caught deadly signal SEGV
        > Vim: preserving files...
        > Vim: Finished.
        >
        >
        > I am using the PPC version of the pre-compiled binary (I think),
        > here's the version info:
        >
        >
        >
        >
        > On May 25, 2006, at 9:40 AM, Benji Fisher wrote:
        >
        >> On Thu, May 25, 2006 at 09:39:37AM -0400, Benji Fisher wrote:
        >>> On Mon, May 22, 2006 at 06:42:36AM -0700, Furash Gary wrote:
        >>>> My vimspell with 7.0 seems to work okay on the mac os x at first
        >>>> - it
        >>>> shows words with problems, but if I right click and pick a
        >>>> replacement
        >>>> word it crashes.
        >>>> Gary Furash, MBA, PMP, Applications Manager
        >>>> Maricopa County Attorney's Office
        >>>
        >>> I cannot reproduce this problem. What version of OS X are you
        >>> using (and if it is 10.4.x, is your machine Intel or PPC based)?
        >>> Did
        >>> you compile yourself or where did you get Vim.app? Please give your
        >>> :version output and details on what leads to a crash.
        >>>
        >>> I tested with OS X 10.3.9 (PPC) vim 7.0 compiled with "huge"
        >>> features.
        >>>
        >>> I do see other problems with spell checking from the PopUp
        >>> menu; I
        >>> will discuss these on the vim-dev list. The crashing problem should
        >>> probably move to the vim-mac list.
        >>
        >> Now I can reproduce the problem. It depends on how I start vim.
        >> :-( Also, the problems I saw on Linux/GTK2 are either solved by
        >> setting
        >> 'mousemodel' to "popup_setpos" or else unreproducible. :-( I have
        >> two
        >> ways to start Vim.app :
        >>
        >> (1) From Finder.app, find Vim.app and CMD-O (or double click).
        >>
        >> (2) From a shell, use the gvim shell script, which does the same as
        >> $ /Applications/Vim.app/Contents/MacOS/Vim -g &
        >>
        >> Start Vim.app either way. Do
        >>
        >> :set spell
        >>
        >> and enter the text "hjkl" into a new buffer. Either right-click or
        >> control-click on this to bring up the PopUp menu. Choose
        >> 'Change "hjkl" to' and then choose the first item, "hulk", from the
        >> sub-menu. I find that nothing happens for a second or so, then the
        >> PopUp menu re-appears. I make the same choices, and then the
        >> behavior
        >> depends on how I started vim: if (1), then "hjkl" is replaced by
        >> "hulk"; if (2), there is a long pause and then a crash.
        >>
        >> Can anyone else reproduce this?
        >>
        >> --Benji Fisher
        >
      • Bem Jones-Bey
        Just for an extra datapoint, if you cd to the Applications folder before running it from the command line, then it does not crash. Tested on PPC Mac OS X
        Message 3 of 10 , May 25, 2006
        • 0 Attachment
          Just for an extra datapoint, if you cd to the Applications folder
          before running it from the command line, then it does not crash.

          Tested on PPC Mac OS X 10.4.6, with Universal Vim binary from
          macvim.org.

          On May 25, 2006, at 8:37, Michael J. Bird wrote:

          > Yes, I can reproduce this on a 10.4.6 PPC powerbook. I have a
          > shortcut to the .app on my powerbar, and that's how I started it.
          > It blew up.
          > I ran the script from a Terminal session. It blew up. I ran it from
          > the Applications folder in Finder. It worked.
          >
          > I got this in my Terminal session:
          > Vim: Caught deadly signal SEGV
          > Vim: preserving files...
          > Vim: Finished.
          >
          >
          > I am using the PPC version of the pre-compiled binary (I think),
          > here's the version info:
          >
          >
          >
          >
          > On May 25, 2006, at 9:40 AM, Benji Fisher wrote:
          >
          >> On Thu, May 25, 2006 at 09:39:37AM -0400, Benji Fisher wrote:
          >>> On Mon, May 22, 2006 at 06:42:36AM -0700, Furash Gary wrote:
          >>>> My vimspell with 7.0 seems to work okay on the mac os x at first
          >>>> - it
          >>>> shows words with problems, but if I right click and pick a
          >>>> replacement
          >>>> word it crashes.
          >>>> Gary Furash, MBA, PMP, Applications Manager
          >>>> Maricopa County Attorney's Office
          >>>
          >>> I cannot reproduce this problem. What version of OS X are you
          >>> using (and if it is 10.4.x, is your machine Intel or PPC based)?
          >>> Did
          >>> you compile yourself or where did you get Vim.app? Please give your
          >>> :version output and details on what leads to a crash.
          >>>
          >>> I tested with OS X 10.3.9 (PPC) vim 7.0 compiled with "huge"
          >>> features.
          >>>
          >>> I do see other problems with spell checking from the PopUp
          >>> menu; I
          >>> will discuss these on the vim-dev list. The crashing problem should
          >>> probably move to the vim-mac list.
          >>
          >> Now I can reproduce the problem. It depends on how I start vim.
          >> :-( Also, the problems I saw on Linux/GTK2 are either solved by
          >> setting
          >> 'mousemodel' to "popup_setpos" or else unreproducible. :-( I have
          >> two
          >> ways to start Vim.app :
          >>
          >> (1) From Finder.app, find Vim.app and CMD-O (or double click).
          >>
          >> (2) From a shell, use the gvim shell script, which does the same as
          >> $ /Applications/Vim.app/Contents/MacOS/Vim -g &
          >>
          >> Start Vim.app either way. Do
          >>
          >> :set spell
          >>
          >> and enter the text "hjkl" into a new buffer. Either right-click or
          >> control-click on this to bring up the PopUp menu. Choose
          >> 'Change "hjkl" to' and then choose the first item, "hulk", from the
          >> sub-menu. I find that nothing happens for a second or so, then the
          >> PopUp menu re-appears. I make the same choices, and then the
          >> behavior
          >> depends on how I started vim: if (1), then "hjkl" is replaced by
          >> "hulk"; if (2), there is a long pause and then a crash.
          >>
          >> Can anyone else reproduce this?
          >>
          >> --Benji Fisher
          >

          -- Bem Ajani Jones-Bey (ajani@...) -- http://ajani.org/ --
        • Axel Kielhorn
          ... Same here. (Yes, it is annoying, that s why I use z= most of the time.) ... Same again ... Same behaviour as in (1) (In insert mode and in normal mode) Vim
          Message 4 of 10 , May 26, 2006
          • 0 Attachment
            Am 25.05.2006 um 16:40 schrieb Benji Fisher:

            > Now I can reproduce the problem. It depends on how I start vim.
            > :-( Also, the problems I saw on Linux/GTK2 are either solved by
            > setting
            > 'mousemodel' to "popup_setpos" or else unreproducible. :-( I have two
            > ways to start Vim.app :
            >
            > (1) From Finder.app, find Vim.app and CMD-O (or double click).
            >
            > (2) From a shell, use the gvim shell script, which does the same as
            > $ /Applications/Vim.app/Contents/MacOS/Vim -g &
            >
            > Start Vim.app either way. Do
            >
            > :set spell
            >
            > and enter the text "hjkl" into a new buffer. Either right-click or
            > control-click on this to bring up the PopUp menu. Choose
            > 'Change "hjkl" to' and then choose the first item, "hulk", from the
            > sub-menu. I find that nothing happens for a second or so, then the
            > PopUp menu re-appears.

            Same here. (Yes, it is annoying, that's why I use z= most of the time.)

            > I make the same choices, and then the behavior
            > depends on how I started vim:


            > if (1), then "hjkl" is replaced by "hulk";

            Same again

            > if (2), there is a long pause and then a crash.

            Same behaviour as in (1) (In insert mode and in normal mode)

            Vim 7.0.17 on Mac OS 10.3.9 compiled with
            gcc (GCC) 3.3 20030304 (Apple Computer, Inc. build 1671)
            --enable-multibyte

            Axel
          • Axel Kielhorn
            ... Interesting datapoint. I didn t move Vim to the Application folder, I invoke it from the Dock or in the Terminal as
            Message 5 of 10 , May 26, 2006
            • 0 Attachment
              Am 25.05.2006 um 22:39 schrieb Bem Jones-Bey:

              > Just for an extra datapoint, if you cd to the Applications folder
              > before running it from the command line, then it does not crash.

              Interesting datapoint.
              I didn't move Vim to the Application folder, I invoke it from the Dock
              or in the Terminal as

              ~/src/Vim/vim70/src/darwin7.9/Vim.app/Contents/MacOS/Vim -g &

              When I cd to
              ~/src/Vim/vim70/src/darwin7.9/
              and call Vim as
              Vim.app/Contents/MacOS/Vim -g &

              I get:
              þÿþÿþÿþÿþÿþÿþÿþÿþ"†"‡"‚"ƒ"*")ÿþÿþÿþÿþÿþÿþÿþÿþ"'"(ÿþ!ÒÔhulk

              The second time I tried this, it was fine in normal mode, but I did get
              the crash in insert mode.

              Exception: EXC_BAD_ACCESS (0x0001)
              Codes: KERN_INVALID_ADDRESS (0x0001) at 0x6c526570

              0 libSystem.B.dylib 0x90007260 strlen + 0x20
              1 Vim 0x0006f86c ins_typebuf + 0x60 (getchar.c:930)
              2 Vim 0x00071428 vgetorpeek + 0x9dc (getchar.c:2297)

              I have encoding=utf-8

              Anything else that may be interesting?
              MacOS 10.3.9, gcc (GCC) 3.3 20030304 (Apple Computer, Inc. build 1671)
              --enable-multibyte
              Vim 7.0.17

              Axel
            • Bem Jones-Bey
              ... Interesting. I just get hulk . I have encoding=utf-8, but I also have nomacatsui and termencoding=macroman. I just tested it without setting those in my
              Message 6 of 10 , May 26, 2006
              • 0 Attachment
                On May 26, 2006, at 2:00, Axel Kielhorn wrote:

                > I get:
                > þÿþÿþÿþÿþÿþÿþÿþÿþ"†"‡"‚"ƒ"*")ÿþÿþÿþÿþÿþÿþÿþÿþ"'"(ÿþ!ÒÔhulk

                Interesting. I just get 'hulk'. I have encoding=utf-8, but I also
                have nomacatsui and termencoding=macroman. I just tested it without
                setting those in my .gvimrc, and I still don't get the garbage before
                hulk.

                > The second time I tried this, it was fine in normal mode, but I did
                > get the crash in insert mode.

                It also crashes for me in insert mode all the time, but not in normal
                mode when run fron the proper directory.

                -- Bem Ajani Jones-Bey (ajani@...) -- http://ajani.org/ --
              • Bram Moolenaar
                ... I can reproduce it. The call stack shows: strlen + 8 ins_typebuf + 88 vgetorpeek + 2280 vgetc + 164 safe_vgetc + 16 normal_cmd + 192 mail_loop + 976 Thus
                Message 7 of 10 , Jun 16, 2006
                • 0 Attachment
                  Benji Fisher wrote:

                  > On Thu, May 25, 2006 at 09:39:37AM -0400, Benji Fisher wrote:
                  > > On Mon, May 22, 2006 at 06:42:36AM -0700, Furash Gary wrote:
                  > > > My vimspell with 7.0 seems to work okay on the mac os x at first - it
                  > > > shows words with problems, but if I right click and pick a replacement
                  > > > word it crashes.
                  > > > Gary Furash, MBA, PMP, Applications Manager
                  > > > Maricopa County Attorney's Office
                  > >
                  > > I cannot reproduce this problem. What version of OS X are you
                  > > using (and if it is 10.4.x, is your machine Intel or PPC based)? Did
                  > > you compile yourself or where did you get Vim.app? Please give your
                  > > :version output and details on what leads to a crash.
                  > >
                  > > I tested with OS X 10.3.9 (PPC) vim 7.0 compiled with "huge"
                  > > features.
                  > >
                  > > I do see other problems with spell checking from the PopUp menu; I
                  > > will discuss these on the vim-dev list. The crashing problem should
                  > > probably move to the vim-mac list.
                  >
                  > Now I can reproduce the problem. It depends on how I start vim.
                  > :-( Also, the problems I saw on Linux/GTK2 are either solved by setting
                  > 'mousemodel' to "popup_setpos" or else unreproducible. :-( I have two
                  > ways to start Vim.app :
                  >
                  > (1) From Finder.app, find Vim.app and CMD-O (or double click).
                  >
                  > (2) From a shell, use the gvim shell script, which does the same as
                  > $ /Applications/Vim.app/Contents/MacOS/Vim -g &
                  >
                  > Start Vim.app either way. Do
                  >
                  > :set spell
                  >
                  > and enter the text "hjkl" into a new buffer. Either right-click or
                  > control-click on this to bring up the PopUp menu. Choose
                  > 'Change "hjkl" to' and then choose the first item, "hulk", from the
                  > sub-menu. I find that nothing happens for a second or so, then the
                  > PopUp menu re-appears. I make the same choices, and then the behavior
                  > depends on how I started vim: if (1), then "hjkl" is replaced by
                  > "hulk"; if (2), there is a long pause and then a crash.
                  >
                  > Can anyone else reproduce this?

                  I can reproduce it. The call stack shows:

                  strlen + 8
                  ins_typebuf + 88
                  vgetorpeek + 2280
                  vgetc + 164
                  safe_vgetc + 16
                  normal_cmd + 192
                  mail_loop + 976

                  Thus it has something to do with getting typeahead characters.

                  --
                  hundred-and-one symptoms of being an internet addict:
                  267. You get an extra phone line so you can get phone calls.

                  /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                  /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                  \\\ download, build and distribute -- http://www.A-A-P.org ///
                  \\\ help me help AIDS victims -- http://ICCF-Holland.org ///
                Your message has been successfully submitted and would be delivered to recipients shortly.