Loading ...
Sorry, an error occurred while loading the content.

v7.0 and Umlauts

Expand Messages
  • Andre Berger
    Since I have upgraded to a self-compiled huge v7.0/PPC, I ve got a charset problem in gvim in E-Mails. I m using a combination of mutt and gvim. Umlauts are
    Message 1 of 7 , May 8, 2006
    • 0 Attachment
      Since I have upgraded to a self-compiled huge v7.0/PPC, I've got a
      charset problem in gvim in E-Mails. I'm using a combination of mutt
      and gvim. Umlauts are displayed correctly in the Terminal, which is
      set to UTF-8 in Tiger. They're displayed as "wide" (double) gremlins
      in gvim. Both gvimrc and vimrc contain

      set encoding=utf-8
      let &termencoding = &encoding

      which used to work fine until now. I've set "nomacatsui" to benefit
      from antialiasing if that matters.

      -Andre
    • 4mir Salihefendic
      I got the same problem with Danish chars. I am on PPC Tiger 10.4.6. I use the macvim.org s version. I have this: set nomacatsui set encoding=latin-1 I also
      Message 2 of 7 , May 8, 2006
      • 0 Attachment
        I got the same problem with Danish chars.

        I am on PPC Tiger 10.4.6. I use the macvim.org's version.

        I have this:
        set nomacatsui
        set encoding=latin-1

        I also tried with UTF-8.

        Kind regards,
        4mir

        On 5/9/06, Andre Berger <andre.berger@...> wrote:
        > Since I have upgraded to a self-compiled huge v7.0/PPC, I've got a
        > charset problem in gvim in E-Mails. I'm using a combination of mutt
        > and gvim. Umlauts are displayed correctly in the Terminal, which is
        > set to UTF-8 in Tiger. They're displayed as "wide" (double) gremlins
        > in gvim. Both gvimrc and vimrc contain
        >
        > set encoding=utf-8
        > let &termencoding = &encoding
        >
        > which used to work fine until now. I've set "nomacatsui" to benefit
        > from antialiasing if that matters.
        >
        > -Andre
        >


        --
        =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
        4mir - http://amix.dk
        -----------------------------------------------------------
        /(bb|[^b]{2})/ that is the Question
      • Benji Fisher
        ... I wish there were an easy answer. The options that may matter include macatsui antialias encoding fileencoding guifont and maybe termencoding
        Message 3 of 7 , May 9, 2006
        • 0 Attachment
          On Tue, May 09, 2006 at 05:44:34AM +0200, Andre Berger wrote:
          > Since I have upgraded to a self-compiled huge v7.0/PPC, I've got a
          > charset problem in gvim in E-Mails. I'm using a combination of mutt
          > and gvim. Umlauts are displayed correctly in the Terminal, which is
          > set to UTF-8 in Tiger. They're displayed as "wide" (double) gremlins
          > in gvim. Both gvimrc and vimrc contain
          >
          > set encoding=utf-8
          > let &termencoding = &encoding
          >
          > which used to work fine until now. I've set "nomacatsui" to benefit
          > from antialiasing if that matters.
          >
          > -Andre

          I wish there were an easy answer. The options that may matter
          include

          'macatsui'
          'antialias'
          'encoding'
          'fileencoding'
          'guifont'

          and maybe

          'termencoding'

          (IIUC, 'termencoding' matters for characters that you type, not for
          reading from a file. Several people report that

          :set termencoding=macroman

          helps.)

          I am also using mutt (on Linux), so there should be a correct
          Content-type line in the headers. Does that help? Here are some
          characters with umlauts: äëïöüÄËÏÖÜ. (I entered these as <C-K>:a and
          so on. The lower-case "a" looks wrong on my terminal, but maybe that is
          just a font problem.) I tried entering these characters the same way in
          Vim.app, and they look fine to me (even the lower-case "a").

          Using 'nomacatsui' should make vim 7.0 render fonts pretty much
          the same way vim 6.4 did. Using 'macatsui' is supposed to help with
          some Unicode characters, maybe Japanese for example?

          HTH --Benji Fisher
        • Andre Berger
          ... Not for me, I ve set everything to UTF-8. ... No, can t see them on 7.0, and can t enter them readibly. Both works fine in 6.4.10 with Monaco:h14. ...
          Message 4 of 7 , May 9, 2006
          • 0 Attachment
            * Benji Fisher (2006-05-09):
            > On Tue, May 09, 2006 at 05:44:34AM +0200, Andre Berger wrote:
            > > Since I have upgraded to a self-compiled huge v7.0/PPC, I've got a
            > > charset problem in gvim in E-Mails. I'm using a combination of mutt
            > > and gvim. Umlauts are displayed correctly in the Terminal, which is
            > > set to UTF-8 in Tiger. They're displayed as "wide" (double) gremlins
            > > in gvim. Both gvimrc and vimrc contain
            > >
            > > set encoding=utf-8
            > > let &termencoding = &encoding
            > >
            > > which used to work fine until now. I've set "nomacatsui" to benefit
            > > from antialiasing if that matters.
            > >
            > > -Andre
            >
            > I wish there were an easy answer. The options that may matter
            > include
            >
            > 'macatsui'
            > 'antialias'
            > 'encoding'
            > 'fileencoding'
            > 'guifont'
            >
            > and maybe
            >
            > 'termencoding'
            >
            > (IIUC, 'termencoding' matters for characters that you type, not for
            > reading from a file. Several people report that
            >
            > :set termencoding=macroman
            >
            > helps.)

            Not for me, I've set everything to UTF-8.

            > I am also using mutt (on Linux), so there should be a correct
            > Content-type line in the headers. Does that help? Here are some
            > characters with umlauts: äëïöüÄËÏÖÜ. (I entered these as <C-K>:a and

            No, can't see them on 7.0, and can't enter them readibly. Both works
            fine in 6.4.10 with Monaco:h14.

            > so on. The lower-case "a" looks wrong on my terminal, but maybe that is
            > just a font problem.) I tried entering these characters the same way in
            > Vim.app, and they look fine to me (even the lower-case "a").
            >
            > Using 'nomacatsui' should make vim 7.0 render fonts pretty much
            > the same way vim 6.4 did. Using 'macatsui' is supposed to help with
            > some Unicode characters, maybe Japanese for example?

            Thanks Benji, your help is always appreciated. I found out if I set
            macatsui, I get my characters but no anti-aliasing; and vice versa.
            (It's the same with your PPC version.)

            -Andre
          • 4mir Salihefendic
            Benji: Thanks! I now use following: set gfn=Bitstream Vera Sans Mono:h14 set nomacatsui set termencoding=macroman set encoding=utf-8 And it works :) 4mir
            Message 5 of 7 , May 9, 2006
            • 0 Attachment
              Benji:
              Thanks!

              I now use following:
              set gfn=Bitstream\ Vera\ Sans\ Mono:h14
              set nomacatsui
              set termencoding=macroman
              set encoding=utf-8

              And it works :)

              4mir

              On 5/9/06, Andre Berger <andre.berger@...> wrote:
              > * Benji Fisher (2006-05-09):
              > > On Tue, May 09, 2006 at 05:44:34AM +0200, Andre Berger wrote:
              > > > Since I have upgraded to a self-compiled huge v7.0/PPC, I've got a
              > > > charset problem in gvim in E-Mails. I'm using a combination of mutt
              > > > and gvim. Umlauts are displayed correctly in the Terminal, which is
              > > > set to UTF-8 in Tiger. They're displayed as "wide" (double) gremlins
              > > > in gvim. Both gvimrc and vimrc contain
              > > >
              > > > set encoding=utf-8
              > > > let &termencoding = &encoding
              > > >
              > > > which used to work fine until now. I've set "nomacatsui" to benefit
              > > > from antialiasing if that matters.
              > > >
              > > > -Andre
              > >
              > > I wish there were an easy answer. The options that may matter
              > > include
              > >
              > > 'macatsui'
              > > 'antialias'
              > > 'encoding'
              > > 'fileencoding'
              > > 'guifont'
              > >
              > > and maybe
              > >
              > > 'termencoding'
              > >
              > > (IIUC, 'termencoding' matters for characters that you type, not for
              > > reading from a file. Several people report that
              > >
              > > :set termencoding=macroman
              > >
              > > helps.)
              >
              > Not for me, I've set everything to UTF-8.
              >
              > > I am also using mutt (on Linux), so there should be a correct
              > > Content-type line in the headers. Does that help? Here are some
              > > characters with umlauts: äëïöüÄËÏÖÜ. (I entered these as <C-K>:a and
              >
              > No, can't see them on 7.0, and can't enter them readibly. Both works
              > fine in 6.4.10 with Monaco:h14.
              >
              > > so on. The lower-case "a" looks wrong on my terminal, but maybe that is
              > > just a font problem.) I tried entering these characters the same way in
              > > Vim.app, and they look fine to me (even the lower-case "a").
              > >
              > > Using 'nomacatsui' should make vim 7.0 render fonts pretty much
              > > the same way vim 6.4 did. Using 'macatsui' is supposed to help with
              > > some Unicode characters, maybe Japanese for example?
              >
              > Thanks Benji, your help is always appreciated. I found out if I set
              > macatsui, I get my characters but no anti-aliasing; and vice versa.
              > (It's the same with your PPC version.)
              >
              > -Andre
              >


              --
              =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
              4mir - http://amix.dk
              -----------------------------------------------------------
              /(bb|[^b]{2})/ that is the Question
            • Andre Berger
              ... Works for me too with Monaco:h14; note, the macroman termencoding setting goes into gvim only, in my vimrc, termencoding is set to UTF-8 to match the
              Message 6 of 7 , May 9, 2006
              • 0 Attachment
                * 4mir Salihefendic (2006-05-09):
                > Benji:
                > Thanks!
                >
                > set nomacatsui
                > set termencoding=macroman
                > set encoding=utf-8

                Works for me too with Monaco:h14; note, the macroman termencoding
                setting goes into gvim only, in my vimrc, termencoding is set to
                UTF-8 to match the Terminal.app settings. This looks like a bug not a
                feature to me.

                -Andre
              • Benji Fisher
                ... Andre: Good point. I will add a note to the FAQ. I have not tested this much, but I assume that macatsui and antialias make no difference when
                Message 7 of 7 , May 10, 2006
                • 0 Attachment
                  On Wed, May 10, 2006 at 07:58:18AM +0200, Andre Berger wrote:
                  > * 4mir Salihefendic (2006-05-09):
                  > > Benji:
                  > > Thanks!
                  > >
                  > > set nomacatsui
                  > > set termencoding=macroman
                  > > set encoding=utf-8
                  >
                  > Works for me too with Monaco:h14; note, the macroman termencoding
                  > setting goes into gvim only, in my vimrc, termencoding is set to
                  > UTF-8 to match the Terminal.app settings. This looks like a bug not a
                  > feature to me.
                  >
                  > -Andre

                  Andre:

                  Good point. I will add a note to the FAQ. I have not tested this
                  much, but I assume that 'macatsui' and 'antialias' make no difference
                  when running in a terminal; ditto for 'guifont'. Both 'encoding' and
                  'termencoding' should be left at their default values when running in a
                  terminal, so you may as well set all of these (if you need them at all)
                  in your gvimrc file.

                  Does anyone disagree with this advice?

                  --Benji Fisher

                  P.S. macvim.org is close to its bandwidth quota. I may move to a
                  different host this week, and it may be unreachable for a day or two.
                Your message has been successfully submitted and would be delivered to recipients shortly.