Loading ...
Sorry, an error occurred while loading the content.
 

Re: Compile vim7.0

Expand Messages
  • Benji Fisher
    ... I do not get this error. There must be some difference between your system and mine, and it is hard to say what it is. I think the error message means
    Message 1 of 2 , May 8, 2006
      On Sun, May 07, 2006 at 08:03:06PM -0400, Silent1 wrote:
      > I'm trying to compile the latest stable version of vim 7 for my g4 mac
      > mini (running tiger), i've tried to compile all the betas released for
      > vim 7 and they all fail, the configure scirpt produces no errors but
      > when i type make it fails at this point,
      > /usr/bin/ld: Undefined symbols:
      > _XpmCreatePixmapFromData
      > _XpmFreeAttributes
      > _XpmReadFileToPixmap
      > /usr/bin/ld: warning weak symbol references not set in output with
      > MACOSX_DEPLOYMENT_TARGET environment variable set to: 10.1
      > /usr/bin/ld: warning weak referenced symbols:
      > _getaddrinfo
      > collect2: ld returned 1 exit status
      > make[1]: *** [vim] Error 1
      > make: *** [reconfig] Error 2
      >
      > I'm not sure what package i must download or what include i must pass
      > to the compiler, thanks in advance.

      I do not get this error. There must be some difference between
      your system and mine, and it is hard to say what it is.

      I think the error message means that you have configured to
      cross-compile for OS X 10.1. Try looking at the configure logs to
      figure out how and where the MACOSX_DEPLOYMENT_TARGET variable gets set.
      It is not set in your environment, is it?

      $ echo $MACOSX_DEPLOYMENT_TARGET

      HTH --Benji Fisher
    Your message has been successfully submitted and would be delivered to recipients shortly.