Loading ...
Sorry, an error occurred while loading the content.
 

Re: still no antialiasing in 7.0g

Expand Messages
  • David Morel
    ... I use Mac OSX 10.4.6 PPC, french localized. Behaviour is the same using Anonymous, Aerial Mono or Monaco. I use encoding=latin1 If i start with defaults,
    Message 1 of 6 , May 1, 2006
      Le 1 mai 06 à 14:15, Benji Fisher a écrit :

      > On Sun, Apr 30, 2006 at 11:29:17PM +0200, David Morel wrote:
      >>
      >> great ! her's the (apparently) winning combination on my setup :
      >>
      >> :set nomacatsui antialias
      >> :set termencoding=macroman
      >> :set encoding=latin1
      >>
      >> Thanks a lot.
      >>
      >> D.Morel
      >
      > I am glad to have some good news for a change! For the record,
      > what version of OS X are you using? What font? And are you
      > looking at
      > plain ASCII text or something more challenging ?

      I use Mac OSX 10.4.6 PPC, french localized. Behaviour is the same
      using Anonymous, Aerial Mono or Monaco.

      I use encoding=latin1

      If i start with defaults, typing é normally displays e acute ('2' key
      on a french keyboard),
      with :set nomacatsui, typing é displays a capital e grave,
      with :set nomacatsui and :set termencoding=macroman, typing é
      displays e acute.
      antialiasing works only with macatsui disabled

      contrary to what i thought (and what is written in the docs),
      termencoding is not set to "macroman" by default, but "".

      does that help ?

      Apparently, using odd (I'd like to display in size 11) font sizes
      still shows some kerning problems. okay, i'll use 10 ;)

      D.Morel
    • Alex Knaub
      ... set nomacatsui antialias set termencoding=macroman set encoding=latin1 set fileencodings=utf-8 works perfectly for me
      Message 2 of 6 , May 1, 2006
        2006/4/30, David Morel <david.morel@...>:
        >
        > Le 30 avr. 06 à 23:18, Benji Fisher a écrit :
        >
        > > On Sun, Apr 30, 2006 at 11:03:02PM +0200, David Morel wrote:
        > >> Hi,
        > >>
        > >> I just downloaded vim 7.0g hoping the antialiasing issue was solved,
        > >> alas it is not :) Still have aliased fonts on Tiger.
        > >>
        > >> I noticed, compiling from sources, that disabling multibyte support
        > >> enables antialiasing again. But then i lose the accented
        > >> characters...
        > >>
        > >> D.Morel
        > >
        > > As I just wrote in a separate post, font rendering is still known
        > > to be problematic. I see a difference when I
        > >
        > > :set antialias
        > >
        > > on my 10.3 and 10.4/PPC machines, but this causes problems with
        > > certain
        > > fonts. With
        > >
        > > :set nomacatsui noantialias
        >
        > great ! her's the (apparently) winning combination on my setup :
        >
        > :set nomacatsui antialias
        > :set termencoding=macroman
        > :set encoding=latin1

        set nomacatsui antialias
        set termencoding=macroman
        set encoding=latin1
        set fileencodings=utf-8

        works perfectly for me
      Your message has been successfully submitted and would be delivered to recipients shortly.