Loading ...
Sorry, an error occurred while loading the content.

vim-7.0d

Expand Messages
  • Erik Dahl
    I m trying to test this version to see if some of the font problems are gone and it seems to not recognize the carbon ui... ./configure --enable-gui=carbon -
    Message 1 of 7 , Apr 11, 2006
    • 0 Attachment
      I'm trying to test this version to see if some of the font problems
      are gone and it seems to not recognize the carbon ui...

      ./configure --enable-gui=carbon ->

      checking --enable-gui argument... Sorry, carbon GUI is not supported

      which seems strange...

      $ ./configure --help | grep carbon
      --enable-gui=OPTS X11 GUI default=auto OPTS=auto/no/gtk/gtk2/
      gnome/gnome2/motif/athena/neXtaw/photon/carbon


      any thoughts?

      -EAD
    • Adam Mercer
      ... Have you unpacked the vim-7.0d-extras.tar.gz tarball as well? As the carbon GUI version builds fine for me. Cheers Adam
      Message 2 of 7 , Apr 11, 2006
      • 0 Attachment
        On 11/04/06, Erik Dahl <edahl@...> wrote:
        > I'm trying to test this version to see if some of the font problems
        > are gone and it seems to not recognize the carbon ui...
        >
        > ./configure --enable-gui=carbon ->
        >
        > checking --enable-gui argument... Sorry, carbon GUI is not supported

        Have you unpacked the vim-7.0d-extras.tar.gz tarball as well? As the
        carbon GUI version builds fine for me.

        Cheers

        Adam
      • Benji Fisher
        ... That is likely the problem. I have been using the snapshots from ftp://ftp.vim.org/pub/vim/unstable/snapshot/ so I do not have to worry about more than
        Message 3 of 7 , Apr 11, 2006
        • 0 Attachment
          On Tue, Apr 11, 2006 at 12:10:53PM -0400, Adam Mercer wrote:
          > On 11/04/06, Erik Dahl <edahl@...> wrote:
          > > I'm trying to test this version to see if some of the font problems
          > > are gone and it seems to not recognize the carbon ui...
          > >
          > > ./configure --enable-gui=carbon ->
          > >
          > > checking --enable-gui argument... Sorry, carbon GUI is not supported
          >
          > Have you unpacked the vim-7.0d-extras.tar.gz tarball as well? As the
          > carbon GUI version builds fine for me.
          >
          > Cheers
          >
          > Adam

          That is likely the problem. I have been using the snapshots from
          ftp://ftp.vim.org/pub/vim/unstable/snapshot/
          so I do not have to worry about more than one archive. If you use
          these, make sure to use unzip (from a shell) and not Stuffit.

          If you have the right sources, it should build the GUI version by
          default; no need to --enable-gui=carbon .

          AFAIK the font problems will still be in 7.0d on Intel Macs.

          HTH --Benji Fisher
        • Alex Knaub
          ... The font problems and bocken antialiasing are on PPC Macs (OS X 10.4.6) too.
          Message 4 of 7 , Apr 12, 2006
          • 0 Attachment
            2006/4/12, Benji Fisher <benji@...>:
            > If you have the right sources, it should build the GUI version by
            > default; no need to --enable-gui=carbon .
            >
            > AFAIK the font problems will still be in 7.0d on Intel Macs.

            The font problems and bocken antialiasing are on PPC Macs (OS X 10.4.6) too.
          • Andre Berger
            ... I can confirm that. -Andre
            Message 5 of 7 , Apr 12, 2006
            • 0 Attachment
              * Alex Knaub (2006-04-12):
              > 2006/4/12, Benji Fisher <benji@...>:
              > > If you have the right sources, it should build the GUI version by
              > > default; no need to --enable-gui=carbon .
              > >
              > > AFAIK the font problems will still be in 7.0d on Intel Macs.
              >
              > The font problems and bocken antialiasing are on PPC Macs (OS X 10.4.6) too.

              I can confirm that.

              -Andre
            • ryan_newsgroups@mac.com
              Like I mentioned to someone else, you can fix the antialiasing issue on your own my modifying gui_mac.c. On Line 132 you ll find the following: #ifdef
              Message 6 of 7 , Apr 12, 2006
              • 0 Attachment
                Like I mentioned to someone else, you can fix the antialiasing issue on your own
                my modifying gui_mac.c. On Line 132 you'll find the following:

                #ifdef MACOS_CONVERT
                # define USE_ATSUI_DRAWING
                ATSUStyle gFontStyle;
                Boolean gIsFontFallbackSet;
                #endif

                If you comment this block out, or add an #undef USE_ATSUI_DRAWING
                immediately after, the antialiasing issue should go away. Also, I
                need to build with --with-features=huge, otherwise I can't paste into
                vim from other apps, I think because the multi_byte option isn't set
                in with the --with-features=normal setting.

                -- Ryan

                * Alex Knaub (2006-04-12):
                > 2006/4/12, Benji Fisher <benji@...>:
                > > If you have the right sources, it should build the GUI
                version by
                > > default; no need to --enable-gui=carbon .
                > >
                > > AFAIK the font problems will still be in 7.0d on Intel Macs.
                >
                > The font problems and bocken antialiasing are on PPC Macs (OS X
                10.4.6) too.

                I can confirm that.

                -Andre
              • Benji Fisher
                ... I did not notice any problems on my PPC Macs until I tested today. I have two, running OS X 10.3.9 and 10.4.5. In my testing, problems show up only when I
                Message 7 of 7 , Apr 13, 2006
                • 0 Attachment
                  On Wed, Apr 12, 2006 at 01:06:28PM +0200, Andre Berger wrote:
                  > * Alex Knaub (2006-04-12):
                  > >
                  > > The font problems and bocken antialiasing are on PPC Macs (OS X
                  > > 10.4.6) too.
                  >
                  > I can confirm that.

                  I did not notice any problems on my PPC Macs until I tested today.
                  I have two, running OS X 10.3.9 and 10.4.5.

                  In my testing, problems show up only when I set 'guifont' to
                  certain values. If I keep the default (empty) or Courier:h10 or
                  Courier:h12, I do not see any problems. If I set it to Courier:h11 or
                  Monaco:h11, then I begin to see problems with font rendering.

                  Is this consistent with what others see? On Intel Macs, are there
                  problems even with

                  :set gfn=

                  (the default)?

                  --Benji Fisher
                Your message has been successfully submitted and would be delivered to recipients shortly.