Loading ...
Sorry, an error occurred while loading the content.

various crashing problems with gcc-4

Expand Messages
  • Paul Forgey
    After successfully running 6.3 for a while I decided to upgrade to 6.4. There seems to be memory mismanagement in the configuration parser. So I tried
    Message 1 of 2 , Feb 19, 2006
    View Source
    • 0 Attachment
      After successfully running 6.3 for a while I decided to upgrade to
      6.4. There seems to be memory mismanagement in the configuration
      parser. So I tried re-fetching the 6.3 sources and I have the same
      result, so apparently gvim doesn't like gcc-4 (the default
      environment on Mac OS 10.4.x). If I gcc-select 3.3 things work fine.

      I can't imagine I'm the first to complain about this but I couldn't
      find anything in the archives.

      When using -g or gvim:

      % vim -g
      Vim: Caught deadly signal SEGV
      Vim: Finished.
      Segmentation fault

      gdb says:
      Starting program: /Users/paulf/vim64/src/vim -g
      Reading symbols for shared libraries .+ done

      Program received signal EXC_BAD_ACCESS, Could not access memory.
      Reason: KERN_INVALID_ADDRESS at address: 0x005fffff
      0xffff8c74 in ___memcpy () at /System/Library/Frameworks/
      System.framework/PrivateHeaders/ppc/cpu_capabilities.h:189
      189 /System/Library/Frameworks/System.framework/PrivateHeaders/
      ppc/cpu_capabilities.h: No such file or directory.
      in /System/Library/Frameworks/System.framework/
      PrivateHeaders/ppc/cpu_capabilities.h

      (gdb) bt
      #0 0xffff8c74 in ___memcpy () at /System/Library/Frameworks/
      System.framework/PrivateHeaders/ppc/cpu_capabilities.h:189
      #1 0x00036204 in repl_cmdline (eap=0xbfffea34, src=0x605300 "",
      srclen=-16, repl=0x18011e "\v\211", cmdlinep=0xbfffe9f8) at
      ex_docmd.c:4109
      #2 0x00039a30 in expand_filename (eap=0xbfffea34,
      cmdlinep=0xbfffe9f8, errormsgp=0xbfffea04) at ex_docmd.c:3962
      #3 0x0003ec44 in do_cmdline (cmdline=0x18011e "\v\211", getline=0,
      cookie=0x0, flags=11) at ex_docmd.c:2410
      #4 0x000ca298 in syn_cmd_onoff (eap=0xbfffef44, name=0xffef4
      "syntax") at syntax.c:3385
      #5 0x000d2a70 in ex_syntax (eap=0xbfffef44) at syntax.c:5774
      #6 0x0003edac in do_cmdline (cmdline=0x100804 "ed", getline=0x31124
      <getsourceline>, cookie=0xbffff2f8, flags=7) at ex_docmd.c:2474
      #7 0x00030b94 in do_source (fname=0x106184 "$HOME/.vimrc",
      check_other=0, is_vimrc=0) at ex_cmds2.c:2353
      #8 0x00063e18 in main (argc=0, argv=0x0) at main.c:1381

      So I tried commenting out the "syntax on" line in my .vimrc. That
      causes an endless loop of:

      vim(4576) malloc: *** Deallocation of a pointer not malloced:
      0x439820; This could be a double free(), or free() called with the
      middle of an allocated block; Try setting environment variable
      MallocHelp to see tools to help debug

      ..over and over and over until I -9 the process.

      MacOS is 10.4.5, gcc is powerpc-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1
      (Apple Computer, Inc. build 5247)

      VIM - Vi IMproved 6.4 (2005 Oct 15, compiled Feb 19 2006 12:25:32)
      Compiled by paulf@...
      Normal version with X11-Athena GUI. Features included (+) or not (-):
      -arabic +autocmd +balloon_eval +browse +builtin_terms +byte_offset
      +cindent
      +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info
      +comments
      +cryptv -cscope +dialog_con_gui +diff +digraphs -dnd -ebcdic -
      emacs_tags +eval
      +ex_extra +extra_search -farsi +file_in_path +find_in_path +folding -
      footer
      +fork() -gettext -hangul_input -iconv +insert_expand +jumplist -
      keymap -langmap
      +libcall +linebreak +lispindent +listcmds +localmap +menu +mksession
      +modify_fname +mouse +mouseshape -mouse_dec -mouse_gpm -mouse_jsbterm
      -mouse_netterm +mouse_xterm -multi_byte +multi_lang -netbeans_intg -
      osfiletype
      +path_extra -perl +postscript +printer -python +quickfix -rightleft -
      ruby
      +scrollbind -signs +smartindent -sniff +statusline -sun_workshop +syntax
      +tag_binary +tag_old_static -tag_any_white -tcl +terminfo +termresponse
      +textobjects +title +toolbar +user_commands +vertsplit +virtualedit
      +visual
      +visualextra +viminfo +vreplace +wildignore +wildmenu +windows
      +writebackup
      +X11 +xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
      system vimrc file: "$VIM/vimrc"
      user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
      system gvimrc file: "$VIM/gvimrc"
      user gvimrc file: "$HOME/.gvimrc"
      system menu file: "$VIMRUNTIME/menu.vim"
      fall-back for $VIM: "/usr/local/share/vim"
      Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_ATHENA
      -g -O2 -I
      /usr/X11R6/include
      Linking: gcc -L/usr/X11R6/lib -L/usr/local/lib -o vim -lXaw -lXmu -
      lXext -lXp
      m -lXt -lX11 -lSM -lICE -lncurses
    • Chris Allen
      ... You re not, and it is in there, somewhere ;) Turn off optimisation, it ll work then. HTH, Chris Allen
      Message 2 of 2 , Feb 19, 2006
      View Source
      • 0 Attachment
        On 2/19/06, Paul Forgey <paulf@...> wrote:
        > I can't imagine I'm the first to complain about this but I couldn't
        > find anything in the archives.

        You're not, and it is in there, somewhere ;) Turn off optimisation,
        it'll work then.

        HTH,
        Chris Allen
      Your message has been successfully submitted and would be delivered to recipients shortly.