Loading ...
Sorry, an error occurred while loading the content.

Re: MacVIM and UTF-8

Expand Messages
  • Jussi Hagman
    Sorry for ignoring this thread earlier.. And another sorry if I missed the point by hopping in in middle of conversation. ... gVim 7 on OS X is work in
    Message 1 of 13 , Dec 14, 2005
    • 0 Attachment
      Sorry for ignoring this thread earlier.. And another sorry if I
      missed the point by hopping in in middle of conversation.

      On 14.12.2005, at 16:33, Geoffrey Alan Washburn wrote:

      > Chris Allen wrote:
      >> On 14/12/05, Geoffrey Alan Washburn <geoffw@...> wrote:
      >>
      >>> I gave this a try and it seems to work correctly. However, it
      >>> doesn't seem to antialias fonts despite adjusting the "anti" and
      >>> "antialias" options. Do I need to rebuild it from source to get
      >>> antialiasing?

      gVim 7 on OS X is work in progress and broken in many ways regarding
      the fonts and text rendering. There is a reason that is not called
      stable, please use Vim 6.4 it should work fine with UTF-8 when
      multibyte is enabled at compile time. I would not recommend using
      vim7 on OS X with the Carbon interface at this point.

      >> You need to re-build without multibyte support if you want
      >> antialiasing to work. Antialiasing, along with underlining and
      >> italics, does not currently work with GVim under OS X.

      They work fine on Vim6 (italics with a separate patch).

      Greetings,
      Jussi


      --
      Jussi Hagman, jhagman@..., iChat/AIM: jussihagman, ICQ: 54004113
      Studentbyn 4 D 33, 20540 Åbo, Finland +358 50 56 51 170
    • Geoffrey Alan Washburn
      ... Well, as my earlier posts on the matter mentioned, the version of 6.4 I tried doesn t actually handle UTF-8 correctly (question marks with enc=utf-8 and
      Message 2 of 13 , Dec 14, 2005
      • 0 Attachment
        Jussi Hagman wrote:
        > gVim 7 on OS X is work in progress and broken in many ways regarding
        > the fonts and text rendering. There is a reason that is not called
        > stable, please use Vim 6.4 it should work fine with UTF-8 when
        > multibyte is enabled at compile time. I would not recommend using vim7
        > on OS X with the Carbon interface at this point.
        Well, as my earlier posts on the matter mentioned, the version of
        6.4 I tried doesn't actually handle UTF-8 correctly (question marks with
        enc=utf-8 and garbage with tenc=utf-8), or is it just that the 6.4
        binaries on macvim.org are not compiled with multibyte support?

        --
        [Geoff Washburn|geoffw@...|http://www.cis.upenn.edu/~geoffw/%5d
      • Geoffrey Alan Washburn
        On a completely irrelevant note, is there a way to configure my mailing list settings so I don t keep getting duplicate e-mails when people reply to me and the
        Message 3 of 13 , Dec 14, 2005
        • 0 Attachment
          On a completely irrelevant note, is there a way to configure my
          mailing list settings so I don't keep getting duplicate e-mails when
          people reply to me and the list?

          Chris Allen wrote:
          > On 14/12/05, Geoffrey Alan Washburn <geoffw@...> wrote:
          >
          >> Rebuilding without multibyte support would presumably disable UTF-8
          >> support? That would sort of get me back where I started :-/
          >>
          >
          > Yeah. It isn't quite as shiny as we generally expect Vim to be. I
          > miss the underlining the most.
          >
          >
          >> I guess it would seem that under MacOS X running GTK gvim or vim in a
          >> terminal is probably the best way to get the features I need.
          >>
          >
          > I recommend the terminal, myself, although Terminal.app is not without
          > its quirks.
          >
          > HTH,
          > Chris Allen
          >


          --
          [Geoff Washburn|geoffw@...|http://www.cis.upenn.edu/~geoffw/%5d
        • Jussi Hagman
          ... I was in a hurry to get dinner and forgot completely to mention that the support is of course quite limited (basically to latin-ish characters I would
          Message 4 of 13 , Dec 14, 2005
          • 0 Attachment
            On 14.12.2005, at 18:35, Geoffrey Alan Washburn wrote:

            > Jussi Hagman wrote:
            >> gVim 7 on OS X is work in progress and broken in many ways
            >> regarding the fonts and text rendering. There is a reason that is
            >> not called stable, please use Vim 6.4 it should work fine with
            >> UTF-8 when multibyte is enabled at compile time. I would not
            >> recommend using vim7 on OS X with the Carbon interface at this point.
            > Well, as my earlier posts on the matter mentioned, the version
            > of 6.4 I tried doesn't actually handle UTF-8 correctly (question
            > marks with enc=utf-8 and garbage with tenc=utf-8), or is it just
            > that the 6.4 binaries on macvim.org are not compiled with multibyte
            > support?

            I was in a hurry to get dinner and forgot completely to mention that
            the support is of course quite limited (basically to latin-ish
            characters I would guess) and that is the reason of the major re-
            engineering that has been happening with the font rendering for vim 7.

            So if you are trying to produce kanji, kana or something more exotic
            you must go to graphical vim7 (which I don't recommend) or use vim
            with a terminal as was suggested.

            Greetings,
            Jussi

            --
            Jussi Hagman, jhagman@..., iChat/AIM: jussihagman, ICQ: 54004113
            Studentbyn 4 D 33, 20540 Åbo, Finland +358 50 56 51 170
          • Preben 'Peppe' Guldberg
            ... Not really - the emails get sent to you by different routes. You would need to filter on the receiving end. Peppe -- se nocp cpo=BceFsx!$ hid bs=2 ls=2 hls
            Message 5 of 13 , Dec 14, 2005
            • 0 Attachment
              Geoffrey Alan Washburn wrote:
              > On a completely irrelevant note, is there a way to configure my
              > mailing list settings so I don't keep getting duplicate e-mails when
              > people reply to me and the list?

              Not really - the emails get sent to you by different routes. You would
              need to filter on the receiving end.

              Peppe
              --
              se nocp cpo=BceFsx!$ hid bs=2 ls=2 hls ic " P. Guldberg /bin/vi@...
              se scs ai isf-== fdo-=block cino=t0,:0 hi=100 ru so=4 noea lz|if has('unix')
              se sh=/bin/sh|en|syn on|filetype plugin indent on|ono S V/\n^-- $\\|\%$/<CR>
              cno <C-A> <C-B>|au FileType vim,mail se sw=4 sts=4 et|let&tw=72+6*(&ft=~'v')
            • Chris Devers
              ... Or *ahem* munge the list s reply-to header ... -- Chris Devers Ç#­n.ª“–“°J
              Message 6 of 13 , Dec 14, 2005
              • 0 Attachment
                On Wed, 14 Dec 2005, Preben 'Peppe' Guldberg wrote:

                > Geoffrey Alan Washburn wrote:
                > > On a completely irrelevant note, is there a way to configure my
                > > mailing list settings so I don't keep getting duplicate e-mails when
                > > people reply to me and the list?
                >
                > Not really - the emails get sent to you by different routes. You would
                > need to filter on the receiving end.

                Or *ahem* <flame-war> munge the list's reply-to header </flame-war> ...


                --
                Chris Devers

                Ç#­n.ª“–“°J
              • Geoffrey Alan Washburn
                ... I m pretty sure that there exists mailing list management software that is smart enough to recognize when one of the recipients is already in a To field.
                Message 7 of 13 , Dec 14, 2005
                • 0 Attachment
                  Preben 'Peppe' Guldberg wrote:
                  > Geoffrey Alan Washburn wrote:
                  >
                  >> On a completely irrelevant note, is there a way to configure my
                  >> mailing list settings so I don't keep getting duplicate e-mails when
                  >> people reply to me and the list?
                  >>
                  >
                  > Not really - the emails get sent to you by different routes. You would
                  > need to filter on the receiving end.
                  >

                  I'm pretty sure that there exists mailing list management software
                  that is smart enough to recognize when one of the recipients is already
                  in a "To" field. At least all the mailman based listed I've used seem
                  to do this.

                  Anyway, I'll take your answer as "no, our list software isn't very
                  smart."

                  --
                  [Geoff Washburn|geoffw@...|http://www.cis.upenn.edu/~geoffw/%5d
                Your message has been successfully submitted and would be delivered to recipients shortly.