Loading ...
Sorry, an error occurred while loading the content.

Re: continuing trouble associating Vim with file types in Tiger

Expand Messages
  • Daniele Venzano
    Copying this info.plist: http://www.brownhat.org/rlieh/Info.plist over the one available in the Vim.app bundle should solve the problem. Vim is not setting the
    Message 1 of 9 , Aug 12, 2005
    • 0 Attachment
      Copying this info.plist:
      http://www.brownhat.org/rlieh/Info.plist
      over the one available in the Vim.app bundle should solve the problem.

      Vim is not setting the CFBundleIdentifier field, causing Tiger to
      forget its existence.

      Bye.

      > * Chris Fonnesbeck <fonnesbeck@...>, 2005-08-11 23:10 +0200:
      >
      >> I was wondering if anyone has made headway with associating Vim as
      >> the
      >> default application for particular file types. I tried following the
      >> advice of an earlier thread on the subject (back in May), but to no
      >> avail. Any attempt to associate Vim with a given file time simply
      >> snaps back to the original file application in the info panel for
      >> that
      >> file. So far, no tinkering with Info.plist has improved the
      >> situation.
      >>
      >> Any recommendations most welcome.
      >>
      >> Thanks,
      >> Chris
      >>

      --
      Daniele Venzano
      http://www.brownhat.org
    • Andre Berger
      ... Daniele, just to make sure, you re suggesting to copy this file to the installed vim s Vim.app/Contents/, right? Not only it doesn t work for me: I cannot
      Message 2 of 9 , Aug 12, 2005
      • 0 Attachment
        * Daniele Venzano <venza@...>, 2005-08-12 10:20 +0200:
        > Copying this info.plist:
        > http://www.brownhat.org/rlieh/Info.plist
        > over the one available in the Vim.app bundle should solve the problem.
        >
        > Vim is not setting the CFBundleIdentifier field, causing Tiger to
        > forget its existence.
        >
        > Bye.

        Daniele,

        just to make sure, you're suggesting to copy this file to the
        installed vim's Vim.app/Contents/, right? Not only it doesn't work
        for me: I cannot assign all ".txt" files to Vim (though it shows up
        as a recommended application now) using Info: Change all in the
        Finder; Vim also never gets to the foreground when started from mutt
        with the exec switch, and doesn't seem to take clicks in the
        background either.

        I strongly suggest to make a backup copy of your Info.plist before
        trying.

        -Andre
      • Chris Fonnesbeck
        ... Yes, to confirm this certainly does not work, at least for vim 6.3 on Tiger. All files assigned to vim immediately snap back to the original application
        Message 3 of 9 , Aug 12, 2005
        • 0 Attachment
          On 8/12/05, Andre Berger <andre.berger@...> wrote:
          > * Daniele Venzano <venza@...>, 2005-08-12 10:20 +0200:
          > > Copying this info.plist:
          > > http://www.brownhat.org/rlieh/Info.plist
          > > over the one available in the Vim.app bundle should solve the problem.
          > >
          > > Vim is not setting the CFBundleIdentifier field, causing Tiger to
          > > forget its existence.
          > >
          > > Bye.
          >
          > Daniele,
          >
          > just to make sure, you're suggesting to copy this file to the
          > installed vim's Vim.app/Contents/, right? Not only it doesn't work
          > for me: I cannot assign all ".txt" files to Vim (though it shows up
          > as a recommended application now) using Info: Change all in the
          > Finder; Vim also never gets to the foreground when started from mutt
          > with the exec switch, and doesn't seem to take clicks in the
          > background either.
          >
          > I strongly suggest to make a backup copy of your Info.plist before
          > trying.
          >

          Yes, to confirm this certainly does not work, at least for vim 6.3 on
          Tiger. All files assigned to vim immediately snap back to the original
          application after clicking on "change all". Thanks for the advice
          though.

          C.
        • Andre Berger
          ... Found the background article I had in mind: -Andre
          Message 4 of 9 , Aug 12, 2005
          • 0 Attachment
            * Chris Fonnesbeck <fonnesbeck@...>, 2005-08-12 16:00 +0200:
            > On 8/12/05, Andre Berger <andre.berger@...> wrote:
            > > * Daniele Venzano <venza@...>, 2005-08-12 10:20 +0200:
            > > > Copying this info.plist:
            > > > http://www.brownhat.org/rlieh/Info.plist
            > > > over the one available in the Vim.app bundle should solve the problem.
            > > >
            > > > Vim is not setting the CFBundleIdentifier field, causing Tiger to
            > > > forget its existence.
            > > >
            > > > Bye.
            > >
            > > Daniele,
            > >
            > > just to make sure, you're suggesting to copy this file to the
            > > installed vim's Vim.app/Contents/, right? Not only it doesn't work
            > > for me: I cannot assign all ".txt" files to Vim (though it shows up
            > > as a recommended application now) using Info: Change all in the
            > > Finder; Vim also never gets to the foreground when started from mutt
            > > with the exec switch, and doesn't seem to take clicks in the
            > > background either.
            > >
            > > I strongly suggest to make a backup copy of your Info.plist before
            > > trying.
            > >
            >
            > Yes, to confirm this certainly does not work, at least for vim 6.3 on
            > Tiger. All files assigned to vim immediately snap back to the original
            > application after clicking on "change all". Thanks for the advice
            > though.

            Found the background article I had in mind:

            <http://lists.apple.com/archives/Carbon-dev/2005/May/msg01320.html>

            -Andre
          • Chris Fonnesbeck
            ... Thanks Andre ... sounds like we ll just have to wait.
            Message 5 of 9 , Aug 12, 2005
            • 0 Attachment
              On 8/12/05, Andre Berger <andre.berger@...> wrote:
              > * Chris Fonnesbeck <fonnesbeck@...>, 2005-08-12 16:00 +0200:
              > > On 8/12/05, Andre Berger <andre.berger@...> wrote:
              > > > * Daniele Venzano <venza@...>, 2005-08-12 10:20 +0200:
              > > > > Copying this info.plist:
              > > > > http://www.brownhat.org/rlieh/Info.plist
              > > > > over the one available in the Vim.app bundle should solve the problem.
              > > > >
              > > > > Vim is not setting the CFBundleIdentifier field, causing Tiger to
              > > > > forget its existence.
              > > > >
              > > > > Bye.
              > > >
              > > > Daniele,
              > > >
              > > > just to make sure, you're suggesting to copy this file to the
              > > > installed vim's Vim.app/Contents/, right? Not only it doesn't work
              > > > for me: I cannot assign all ".txt" files to Vim (though it shows up
              > > > as a recommended application now) using Info: Change all in the
              > > > Finder; Vim also never gets to the foreground when started from mutt
              > > > with the exec switch, and doesn't seem to take clicks in the
              > > > background either.
              > > >
              > > > I strongly suggest to make a backup copy of your Info.plist before
              > > > trying.
              > > >
              > >
              > > Yes, to confirm this certainly does not work, at least for vim 6.3 on
              > > Tiger. All files assigned to vim immediately snap back to the original
              > > application after clicking on "change all". Thanks for the advice
              > > though.
              >
              > Found the background article I had in mind:
              >
              > <http://lists.apple.com/archives/Carbon-dev/2005/May/msg01320.html>
              >
              Thanks Andre ... sounds like we'll just have to wait.
            • Daniele Venzano
              I have uploaded a new Info.plist on the same place as before (http:// www.brownhat.org/rlieh/Info.plist), but the only thing I changed was the icon name. That
              Message 6 of 9 , Aug 12, 2005
              • 0 Attachment
                I have uploaded a new Info.plist on the same place as before (http://
                www.brownhat.org/rlieh/Info.plist), but the only thing I changed was
                the icon name. That file is working for me, and I tried again to
                conform that.

                Did you rebuild the LaunchServices database by doing:
                /System/Library/Frameworks/ApplicationServices.framework/Versions/A/
                Frameworks/LaunchServices.framework/Versions/Current/Support/
                lsregister -r -v -f /Applications/Vim.app

                I forgot to mention this in the previous mail, but it is quite an
                important thing to make OsX aware that something changed.

                Bye.

                Il giorno 12/ago/05, alle ore 15:42, Chris Fonnesbeck ha scritto:
                > On 8/12/05, Andre Berger <andre.berger@...> wrote:
                >>
                >> Daniele,
                >>
                >> just to make sure, you're suggesting to copy this file to the
                >> installed vim's Vim.app/Contents/, right? Not only it doesn't work
                >> for me: I cannot assign all ".txt" files to Vim (though it shows up
                >> as a recommended application now) using Info: Change all in the
                >> Finder; Vim also never gets to the foreground when started from mutt
                >> with the exec switch, and doesn't seem to take clicks in the
                >> background either.
                >>
                >> I strongly suggest to make a backup copy of your Info.plist before
                >> trying.
                >>
                >>
                >
                > Yes, to confirm this certainly does not work, at least for vim 6.3 on
                > Tiger. All files assigned to vim immediately snap back to the original
                > application after clicking on "change all". Thanks for the advice
                > though.
                >
                > C.
                >
                >

                --
                Daniele Venzano
                http://www.brownhat.org
              • Andre Berger
                ... Didn t make a difference here, still no go. -Andre
                Message 7 of 9 , Aug 12, 2005
                • 0 Attachment
                  * Daniele Venzano <venza@...>, 2005-08-12 21:50 +0200:
                  > I have uploaded a new Info.plist on the same place as before (http://
                  > www.brownhat.org/rlieh/Info.plist), but the only thing I changed was
                  > the icon name. That file is working for me, and I tried again to
                  > conform that.
                  >
                  > Did you rebuild the LaunchServices database by doing:
                  > /System/Library/Frameworks/ApplicationServices.framework/Versions/A/
                  > Frameworks/LaunchServices.framework/Versions/Current/Support/
                  > lsregister -r -v -f /Applications/Vim.app
                  >
                  > I forgot to mention this in the previous mail, but it is quite an
                  > important thing to make OsX aware that something changed.

                  Didn't make a difference here, still no go.

                  -Andre
                Your message has been successfully submitted and would be delivered to recipients shortly.