Loading ...
Sorry, an error occurred while loading the content.

Problems with multibyte gvim on Mac OS X

Expand Messages
  • Benjamin Esham
    I m trying to compile gvim 6.3.085 (the latest) with support for multi-byte stuff. Compilation seems to go fine after I do `./ configure --enable-multibyte &&
    Message 1 of 3 , Jul 27, 2005
    • 0 Attachment
      I'm trying to compile gvim 6.3.085 (the latest) with support for
      multi-byte stuff. Compilation seems to go fine after I do `./
      configure --enable-multibyte && make && make install', but when I
      launch vim I get visual problems as in the screenshot below and the
      multibyte features don't seem to work anyway!

      Specifically, I set "encoding=utf-8". After typing some accented
      characters ("àèìòù"), there are display issues-- each character
      appears instead as "¬", and the displayed contents of the line
      changed as I moved the insertion point. When I opened the file in
      TextEdit, the displayed content was "ˆ“˜"; when I looked at
      the file in a hex editor, I saw "c288 c28f c293 c298 c29d 0a00". As
      far as I can tell, some of these aren't even valid UTF-8 bytes!

      The attached screenshot below shows "normal" gvim, before the
      multibyte support was added, and then the gvim with multibyte
      support. As you can see, every space is displayed as a dark square
      (this happens with other color schemes as well).

      Am I doing something wrong, or is there just not support for UTF-8 in
      Vim on Mac OS X?
    • Benjamin Esham
      ... I guess attachments to the list aren t allowed... you can view that image at http://www.bdesham.net/img/vim_multibyte.png -- Benjamin D. Esham
      Message 2 of 3 , Jul 27, 2005
      • 0 Attachment
        On Jul 27, 2005, at 7:51 PM, Benjamin Esham wrote:

        > The attached screenshot below shows "normal" gvim, before the
        > multibyte support was added, and then the gvim with multibyte
        > support. As you can see, every space is displayed as a dark square
        > (this happens with other color schemes as well).

        I guess attachments to the list aren't allowed... you can view that
        image at

        http://www.bdesham.net/img/vim_multibyte.png

        --
        Benjamin D. Esham
        bdesham@... | http://bdesham.net | AIM: bdesham128
        * Still using Internet Explorer? Firefox is newer, more secure,
        and has features like tabbed browsing. http://www.getfirefox.com
      • Chris Allen
        ... How very strange (cue I m sure it used to work ... )! Multibyte doesn t work for me using the stock build from macvim, either. It certainly does work
        Message 3 of 3 , Jul 27, 2005
        • 0 Attachment
          On 27/07/05, Benjamin Esham <bdesham@...> wrote:
          > I'm trying to compile gvim 6.3.085 (the latest) with support for
          > multi-byte stuff. Compilation seems to go fine after I do `./
          > configure --enable-multibyte && make && make install', but when I
          > launch vim I get visual problems as in the screenshot below and the
          > multibyte features don't seem to work anyway!

          How very strange (cue "I'm sure it used to work ...")! Multibyte
          doesn't work for me using the stock build from macvim, either. It
          certainly does work using Vim7aa out of CVS, though, and that has been
          pretty stable, in general, so it might meet your needs. I use it
          every day, and issues are only rare ;)

          Chris
        Your message has been successfully submitted and would be delivered to recipients shortly.