Loading ...
Sorry, an error occurred while loading the content.
 

Re: Error opening files with dot z extension on gvim for OS X

Expand Messages
  • Jim Tittsler
    ... Is it .z or .Z? (Or are the files on a case insensitive filesystem?) I suspect that vim thinks they are compressed files (see :help compress), and is
    Message 1 of 2 , Mar 6, 2005
      On Mar 6, 2005, at 08:09, Carl Youngblood wrote:

      > Hi, I'm having a problem with gvim when I open files ending in .z
      > extension.  These are just plain unix text files.  I'm writing source
      > code for the ZPL language, which expects files to have a dot z
      > extension.  For some reason gvim (not vi) gives me:
      >
      > Error detected while processing function <SNR>12_read:
      > line 32:
      > E484: Can't open file /tmp/v65761/1
      > Hit ENTER or type command to continue

      Is it .z or .Z? (Or are the files on a case insensitive filesystem?)

      I suspect that vim thinks they are compressed files (see :help
      compress), and is trying (and failing) to automatically expand them for
      you. As you discovered you can change their extension, or disable that
      feature by including
      let loaded_gzip = 1
      in your .vimrc or .gvimrc

      --
      Jim Tittsler http://www.OnJapan.net/ GPG: 0x01159DB6
      Python Starship http://Starship.Python.net/
      Ringo MUG Tokyo http://www.ringo.net/rss.html
    Your message has been successfully submitted and would be delivered to recipients shortly.