Loading ...
Sorry, an error occurred while loading the content.

Minor problem with vim on Mac OS X

Expand Messages
  • Cyrille Artho
    I have a problem under Mac OS X (Darwin + Aqua): No application in the terminal uses colors, although the built-in terminal understands ANSI color escape
    Message 1 of 3 , Aug 23, 2001
    • 0 Attachment
      I have a problem under Mac OS X (Darwin + Aqua): No application in the
      terminal uses colors, although the built-in terminal understands ANSI
      color escape sequences.
      I have replaced the builtin "ls" with GNU ls, which uses colors.
      However, vim 5.8, both compiled by myself or via "fink", does not use
      colors. Instead, it only uses bold or underlined text for "syntax
      coloring". This is of course not very practical. Does anybody know how
      to enable colors in vim?
      --
      Regards,
      Cyrille Artho - http://artho.com/ - Tel. +41 - [0]1 - 632 09 88
      Thieves respect property; they merely wish the property to become
      their property that they may more perfectly respect it.
      -- G.K. Chesterton, "The Man Who Was Thursday"
    • Stephane Huaulme
      Try to add the following .termcap file to your ~/ directory stephane
      Message 2 of 3 , Aug 27, 2001
      • 0 Attachment
        Try to add the following .termcap file to your ~/ directory

        stephane

        <Attachment missing>
        On Thursday, August 23, 2001, at 08:10 AM, Cyrille Artho wrote:

        > I have a problem under Mac OS X (Darwin + Aqua): No application in the
        > terminal uses colors, although the built-in terminal understands ANSI
        > color escape sequences.
        > I have replaced the builtin "ls" with GNU ls, which uses colors.
        > However, vim 5.8, both compiled by myself or via "fink", does not use
        > colors. Instead, it only uses bold or underlined text for "syntax
        > coloring". This is of course not very practical. Does anybody know how
        > to enable colors in vim?
        > --
        > Regards,
        > Cyrille Artho - http://artho.com/ - Tel. +41 - [0]1 - 632 09 88
        > Thieves respect property; they merely wish the property to become
        > their property that they may more perfectly respect it.
        > -- G.K. Chesterton, "The Man Who Was Thursday"
        >
      • Eugene Lee
        ... Try adding this to your .vimrc: set term=ansi syntax on -- Eugene Lee eugene@anime.net
        Message 3 of 3 , Aug 27, 2001
        • 0 Attachment
          On Thu, Aug 23, 2001 at 03:10:23PM +0200, Cyrille Artho wrote:
          :
          : I have a problem under Mac OS X (Darwin + Aqua): No application in the
          : terminal uses colors, although the built-in terminal understands ANSI
          : color escape sequences.
          : I have replaced the builtin "ls" with GNU ls, which uses colors.
          : However, vim 5.8, both compiled by myself or via "fink", does not use
          : colors. Instead, it only uses bold or underlined text for "syntax
          : coloring". This is of course not very practical. Does anybody know how
          : to enable colors in vim?

          Try adding this to your .vimrc:

          set term=ansi
          syntax on


          --
          Eugene Lee
          eugene@...
        Your message has been successfully submitted and would be delivered to recipients shortly.