Loading ...
Sorry, an error occurred while loading the content.

Re: Additional information.....

Expand Messages
  • Unnsse Khan
    Fellow vimmers, In addition, to my response (the e-mail that I posted, like 3 minutes ago): Here s what happened when I ran gvim from the command line using
    Message 1 of 6 , Dec 26, 2004
    • 0 Attachment
      Fellow vimmers,

      In addition, to my response (the e-mail that I posted, like 3 minutes ago):

      Here's what happened when I ran gvim from the command line using gvim and
      tried :scriptnames

      1: /Users/untz/.vimrc

      2: /Applications/Vim.app/runtime/syntax/syntax.vim

      3: /Applications/Vim.app/runtime/syntax/synload.vim

      4: /Applications/Vim.app/runtime/syntax/syncolor.vim

      5: /Applications/Vim.app/runtime/filetype.vim

      6: /Applications/Vim.app/runtime/menu.vim

      7: /Applications/Vim.app/runtime/colors/torte.vim

      8: /Applications/Vim.app/runtime/plugin/explorer.vim

      9: /Applications/Vim.app/runtime/plugin/gzip.vim

      10: /Applications/Vim.app/runtime/plugin/netrw.vim

      11: /Applications/Vim.app/runtime/plugin/rrhelper.vim

      12: /Applications/Vim.app/runtime/plugin/tohtml.vim

      13: /Users/untz/.gvimrc

      14: /Applications/Vim.app/runtime/syntax/nosyntax.vim

      Hit ENTER or type command to continue


      See, it still points to /Users/untz/.gvimrc

      But it isn't compliant with the settings inside the particular .gvimrc...

      -Unnsse

      On 12/26/04 5:12 AM, "Matthew J. Stott" <stottm@...> wrote:

      > Something is still not right with your path to the vim executables...
      >
      > It is indeed parsing your .vimrc as the first error is Error detected
      > while processing /Users/untz/.vimrc
      >
      > The second error indicates it is still trying to run /usr/bin/vim
      > (Apples Included 6.2 version) and not the
      > /Applications/Vim.app/Contents/MacOS/Vim - It's still trying to source
      > the now missing /usr/share/vim
      > location. (syntax on command looks to the runtime location) The Apple
      > included /usr/bin/vim is compiled to look in /usr/share/vim for it's
      > runtime files. The Vim.app runtime location is within the Vim.app
      > bundle in /Applications/Vim.app/runtime/.
      >
      > Try renaming the /usr/bin/vim
      >
      > move /usr/bin/vim /usr/bin/vim.apple
      >
      > Also your gvim alias is wrong, it needs to be:
      > alias gvim="/Applications/Vim.app/Contents/MacOS/Vim -g"
      >
      > The executable is not gvim it's Vim and you pass it the -g switch to
      > launch the GUI.
      >
      > Alternatively you can use alias gvim="open -a Vim" and it will launch
      > the GUI as well. The open command will always launch the GUI, it works
      > with other GUI apps like TextEdit. Checkout the open manpage "man
      > open" command.
      >
      > You also seem to have Fink installed as I see paths pointing to /sw/bin
      > - Make sure you remove any Vim versions you installed via Fink.
      >
      >
      >
      > On Dec 26, 2004, at 5:54 AM, Unnsse Khan wrote:
      >
      >> Happy holidays fellow vimmers!
      >>
      >> Da Woon Jung was right! I actually got it working ....
      >>
      >> Now the problem is, it seems to be not running my .vimrc's settings...
      >>
      >> I poked around and found out that I another version of vim in my
      >> computer
      >> @ /usr/share/vim/
      >>
      >> So, what I did was I deleted that directory by doing a rm -rf vim
      >> (after a
      >> "cd /usr/share/"
      >>
      >> Now, when I run vim from the command line, I get this message:
      >>
      >> Raven:~ untz$ vim
      >> Error detected while processing /Users/untz/.vimrc:
      >> line 1:
      >> E484: Can't open file /usr/share/vim/syntax/syntax.vim
      >> line 2:
      >> E185: Cannot find color scheme torte
      >> Hit ENTER or type command to continue
      >>
      >> The vim that was in /usr/share/vim/ was vim 6.2 and I am using vim 6.3
      >>
      >> When I type gvim from the command line (it finally works!) :), but it
      >> doesn't take my .vimrc settings... It seems that somewhere else on my
      >> Mac
      >> OSX that it is set to looking for the deleted vim 6.2 (that was
      >> located in
      >> /usr/share/bin).
      >>
      >> Here is the contents of both my .gvimrc (I have gvim.app placed in
      >> /Applications also) and my .vimrc:
      >>
      >> syntax on
      >> colorscheme torte
      >> set ts=4
      >> set nu!
      >> set guifont=Bitstream\ Vera\ Sans\ Mono\ 20
      >>
      >> This is what my .profile file looks like:
      >>
      >> Raven:~ untz$ cat .profile
      >> alias vim="/Applications/Vim.app/Contents/MacOS/Vim"
      >> alias gvim="/Applications/gvim.app/Contents/MacOS/gvim"
      >> test -r /sw/bin/init.sh && . /sw/bin/init.sh
      >> Raven:~ untz$
      >>
      >> I even tried to copy my .vimrc and .gvimrc in the base directories of
      >> /Applications/Vim.app && /Applications/gvim.app and I am still not
      >> getting
      >> the particular settings that I wanted...
      >>
      >> However, seeing gvim work from the command line is so awesome...
      >>
      >> I use Eclipse but have stuck to vim because I dislike it when IDEs
      >> don't
      >> have full screen windows and it seems like with vim, vi, gvim, etc.
      >> one
      >> doesn't even need to ever touch the mouse pad (this totally rocks!)
      >>
      >> Well, its great that I got this configured during Christmas... Now,
      >> I'll be
      >> able to fully utilize the power of my Mac OSX 's Unix shell and
      >> develop some
      >> great software! ;)
      >>
      >> Kudos to the vim community! May vim live long!
      >>
      >> If anyone can help me with setting this application's .vimrc & .gvimrc
      >> to
      >> point to the same directory, and also help me turn off where it is
      >> pointing
      >> to the deleted /usr/share/vim directory (which was 6.2), I would be
      >> very
      >> grateful.
      >>
      >> Merry Christmas & God bless,
      >>
      >> Unnsse
      >>
      >>
      >>
      >>
      >> On 12/13/04 12:54 AM, "Da Woon Jung" <dirkpitt2050@...> wrote:
      >>
      >>> I'm sorry for the previous spam, I didn't realize you (Unnsse) tried
      >>> my solution.
      >>>
      >>> Just to be safe, try following these steps _exactly_:
      >>>
      >>> 1. If you're using Panther, download
      >>> http://macvim.org/OSX/files/binaries/OSX10.3/vim6.3.tar.bz2
      >>> If on Jaguar, download
      >>> http://macvim.org/OSX/files/binaries/OSX10.2/vim6.3.tar.bz2
      >>>
      >>> 2. Double click the downloaded archive, and drag Vim into your
      >>> Applications folder. That is /Applications.
      >>>
      >>> 3. Verify that Vim is operational by double-clicking it to launch it
      >>>
      >>> 4. Close Vim, open a terminal, and type
      >>> /Applications/Vim.app/Contents/MacOS/Vim -g
      >>>
      >>> Note that the message: "GUI cannot be used: Not enabled at compile
      >>> time" is probably because you were trying to execute the vim that came
      >>> with Panther (which is terminal-only), or you downloaded a
      >>> terminal-only or X11 version. Or you made an alias in your .profile
      >>> and you forgot to source .profile or run a new shell. Or you followed
      >>> previous instructions suggesting that you sudo and ln and now you've
      >>> got some alias pointing to a symbolic link pointing to who knows
      >>> where. Even I'm getting confused trying to follow all these previous
      >>> posts and well-intentioned suggestions.
      >>>
      >>> Just start over, and if you follow these simple instructions to the
      >>> letter then things should be much better.
      >>>
      >>> BTW, to check what vim you're running, at the terminal, type: which
      >>> vim
      >>>
      >>> All the above might be moot if you're running OS X 10.1 or below, but
      >>> in that case I can try and compile a version for you.
      >>>
      >>> Cheers,
      >>> DW
      >>
      >>
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.